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Preface
Why a ‘Getting Started for Design’ Manual ?
12d Model is supplied with a comprehensive on-line Reference manual which describes the function of 
each menu option in detail. It is a Reference manual however and makes no attempt to describe how to use 
12d for production surveying and civil engineering work.

The Getting Started for Design manual is designed to show you how to work with the on-line help system, 
and then as the first section of Training, help you start to learn how to use 12d to achieve typical civil 
engineering tasks. The Getting Started for Design manual uses examples where possible to clarify usage. It 
complements rather than replaces the on-line Reference manual. In general, information in the on-line 
Reference manual will not be duplicated here.

The Getting Started for Design manual is available as a printed manual and as a PDF file on the 12d Model 
Training DVD.

Training Material

The training tutorials assumes that a series of files are already on your hard disk. These tutorial files are 
automatically installed from the CD during installation of the 12d Model software.

Getting Started for Surveying
There is also a Getting Started for Surveying which has the first seven chapters in common with the 
Getting Started for Design manual (on-line help and basic modelling) but then diverts to cover topics from 
the direction of a Surveyor whereas the Getting Started for Design manual continues on with alignment 
design techniques. 

The Getting Started for Surveying manual is available as a printed manual and as a PDF file on the 12d 
Model Training DVD.

Using the Practise and Small Versions of 12d Model
The Practise version of 12d Model is limited to a maximum of 5,000 points. Following the procedures as 
stated in the Training Manual may create projects with more than 5,000 points. 

Where appropriate, the text will suggest how to vary the input for each instruction so that the example 
feature can be completed within the limits of the 12d Model Practise version. 

The number of points used at any time in the Practise and small versions can be displayed by the option

Projects => Check base points

The easiest way to reduce the current point count is to delete any unwanted models with 

Models => Delete

The installed icon on your desktop for running the practise version of 12d with these training files is 
labelled ‘12d v8.00 Practise Training’.

Please Note: Projects created by Practise versions of 12d Model cannot be accessed by Release versions of 
12d Model and vice-versa.
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1 Installing 12d Model
The 12d Model 8 Installation CD can be used to install the Release and Practise versions of 12d Model 8.

The Practise version is limited to a maximum of 5,000 points and creates projects that cannot be accessed 
by the Release versions of 12d Model and vice-versa.

However the Practise version can be used free of charge by 12D Solutions customers and registered 
Practise Users.

Installing the Release Version for Sites Not Running 12d Model 7 or 12d Model 8

For a new installation of the Release version of 12d Model 8, the user is provided with

one dongle
one 12d Model 8 Installation CD
an email or a floppy with the file nodes.4d on it with the V8 authorisation in it.

Because most new computers do not have a floppy disk drive, the 12d Model 8 nodes.4d file will normally 
be emailed to you rather than sent on a floppy disk. Before installing 12d Model 8, you must copy the 12d 
Model 8 nodes.4d into a folder that can be accessed during the installation.

Please do not change the name of the nodes.4d file. The installation and 12d Model will only search for a 
file called nodes.4d. During the installation of 12d Model 8, you will be asked to browse to the folder 
containing the nodes.4d file.

Please check that you have all three items before commencing the installation.

The notes for a new install of  the Release version of 12d Model 8 are on the 12d Model 8 Installation CD 
or can be downloaded from the 12d web site www.12d.com under the Updates area.

Installing the Release Version for Sites Already Running 12d Model 7 or 12d Model 8

Existing 12d Model 7 or 12d Model 8 users upgrading to 12d Model 8 are provided with

one 12d Model 8 Installation CD
one What’s New in V8 DVD
an email or a floppy with the file nodes.4d on it with the V8 authorisation in it.

The dongle you already have will work with the new version of 12d Model 8.

Because most new computers do not have a floppy disk drive, the 12d Model 8 nodes.4d file will normally 
be emailed to you rather than sent on a floppy disk. Before installing 12d Model 8, you must copy the 12d 
Model 8 nodes.4d into a folder that can be accessed during the installation.

Please do not change the name of the nodes.4d file. The installation and 12d Model will only search for a 
file called nodes.4d. During the installation of 12d Model 8, you will be asked to browse to the folder 
containing the nodes.4d file.

The notes for upgrading to the Release version of 12d Model 8 are on the What’s New in V8 DVD or can 
be downloaded from the 12d web site www.12d.com under the Updates area.

Important Note

If 12d Model 8 is already running on your computer, please uninstall it before installing a new version of 
12d Model 8.

Installing the Practise Version:

For a Practise installation of 12d Model, all that is needed is:

one 12d Model Installation CD
or 12d Model Practise download from www.12d.com

The Practise version must be Registered with 12D Solutions once it is installed on a computer. A new 
Registration is required for each computer that the Practise version is run on.

The notes for installing the practise version of 12d Model are on the 12d Model 8 Installation CD or can be 
downloaded from the 12d web site www.12d.com under the 12d Model Practise area.
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2 Before You Begin the Training

2.1 Installing the Training Files
If you have installed Training from the 12d Model Installation CD, then the Training folder will have been 
automatically created for you but where the files reside on the disk depends on whether you installed the 
Release version or the Practise version of 12d Model.

The Training manual dialogue assumes that the working folder (i.e. shortcut) of your ‘12d Model 8 
Training’ or ’12d Model 8 Practise Training’ icon is set to

c:\12djobs\8.0\Training   for the Release version of 12d Model
and

c:\12 Model 8 Practise\Training   for the Practise version of 12d Model 

The training files can be installed in any sub-folder on your hard disk. 

For convenience in this manual, is assumed that the training files are installed in

c:\12djobs\8.00\Training

but it is very rare in the Training Manual that you ever need to know exactly where on disk the data resides. 
All the required material is already in the "Training" folder.

2.2 12d Icons on your Desktop
It is recommended that you use the ‘12d Model 8 Training’ icon for the Release version or ’12d Model 8 
Practise Training’ icon for the Practise version whilst initially working with this training manual. The 
reason for this is that the icon points directly to the folder containing the training files.

Be aware that there is a separate ‘12d Model 8’ icon recommended for 12d production work. The shortcut 
for this icon is generic and is set to

c:\12djobs or c:\12d Model 8 Practise    for the "12d Model 8 Practise" icon.

With a little extra button pushing to point to the right path, it is possible to access the ‘Training’ area from 
the ’12d Model 8’ icon

For convenience in this manual, is assumed that the ‘12d v8.00 Training’ icon is used.

2.3 Using the Practise Version
Remember that the Practise version of 12d Model is limited to a maximum of 5,000 points.

Following the procedures as stated in the Training Manual may create projects with more than 5,000 
points. Where appropriate, the text will suggest how to vary the input for each instruction so that the 
example feature can be completed within the limits of the 12d Model Practise version. 

2.4 Overview of 12d File and Folder Structures
Before you begin using 12d, it is useful to understand how 12d uses the file and folder structure under 
Windows 2000, XP and Vista.

12d recognises long filenames up to 256 characters so you are not limited to the old DOS convention of 8.3 
filenames. Whilst long filenames under Windows can contain spaces it is recommended that you use 
underscores ‘_’ in file and folder names created externally from 12d. 

The 12d program and its support files are installed on your hard disk, typically into folder c:\Program 
Files\12d and various subfolders below. When the software was installed, the ‘12d Model 8’ program icon 
will have been setup to point to a working folder where your data files will be stored - typically c:\12djobs.

As each job you work on will have different files, it is strongly recommended that you keep each job in a 
separate subfolder. This is done manually and can be anywhere on your hard disk or network. For 
convenience, you may prefer to keep them all under one major folder e.g. c:\12djobs. 
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The tutorial is about designing a road and the training the files have been set up in a folder 
c:\12djobs\8.00\Training\8.00\Design\Getting Started Basic.

In the general case for production work however, if you were about to start work on a new job by the name 
‘Highway’, you would begin by creating a new folder under 12djobs i.e. c:\12djobs\Highway. This is done 
either from the 12d Project Selection panel, or before starting 12d using Windows Explorer. Either numeric 
or alpha characters may be used in folder names so you may prefer to use job numbers rather than names. 
Also under Windows, 12d is not case sensitive for folder names, so ‘Highway’ is seen as the same name as 
‘highway’.

If you just accept the 12d default working folder (c:\12djobs) as the place to put your data files, 12d will 
still operate correctly but it will become difficult over time for you to separate which files belong to which 
jobs once you have multiple jobs on the go.

2.5 The 12d Concept of ‘Projects’
12d can have more than one project within the one Windows folder which can be worked on 
independently. For example, projects under ‘Highway’ might be ‘Stage 1’ and ‘Stage 2’ or ‘Fred’ and 
‘Bill’. Each project has its own data and configuration setup which controls the number of views, which 
models are on display etc.

New projects like these can be created from within 12d by pointing at the c:\12djobs\Highway folder and 
then typing a new project name. If this is done twice during separate 12d sessions, you will have created 
two unique projects. Internally, 12d handles this by creating two separate folders on disk in the Highway 
folder.

c:\12djobs\Highway\Stage_1.project

c:\12djobs\Highway\Stage_2.project

Because of this structure, the projects can be worked on independently. All internal files from one project 
are kept separate from the other internal files of another. However, all input and output files, mtf files, 
chains, plots and reports go into the folder containing the project (e.g. Highway) and are not held inside 
the project itself. Hence to prevent projects interfering with each other, it is best to create a separate folder 
and create each project in its own folder.

For example, create a folder “Highway\Stage1” and from within 12d, attach to that folder and then create 
the project “Stage 1”. 12d then creates a subfolder “Stage_1.project:

c:\12djobs\Highway\Stage1\Stage_1.project

Once inside 12d, from within any one project, it is possible to import any or all data from another project 
so there is some flexibility on a major job to move/copy survey or design data between stages if staging is 
used and then have multiple users perform parallel development. Model and tin sharing could later be used 
to subsequently assemble staged project data at the completion of a major job. Within any one project, 
model names must be unique so some planning is necessary if parallel development streams are 
subsequently to be reassembled. Models can be renamed at any time. Models are discussed in See Chapter 
4.11 (on page 43).

Provided no 12d user is currently accessing a particular project, it (the project folder) can be manipulated 
just like any folder i.e. copied, deleted etc. using Windows Explorer, obviously external from 12d. Such 
manipulation is very similar to how Windows Explorer might be used to copy and delete CAD files and 
folders. Copying and renaming is obviously a fast way of setting up a new development stream or new 
user.

However, information inside the project folder should not be manipulated except from within 12d Model 
since this will corrupt the project and data could be lost. For example, model names can only be renamed 
from within 12d Model. 

At any one time, a 12d session can only access one project. It is possible to change from one project to 
another without exiting 12d.

The creation of at least one ‘Project’ under any job is compulsory within 12d. Thus even if there is no 
concept of staging within the ‘Highway’ project, you must still define a Project. In this case you might use 
the same name for both the Job and the Project or name the Project just ‘proj’
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If you need to manually place any files on disk for this project (e.g. survey files from a total station or 
CAD files to get data into 12d), it is recommended that you place them in the folder. 

c:\12djobs\Highway

The user should never need to know about or manually access the files within the Project folder. To 
maintain the integrity of 12d, it is important that you never edit any of the ‘internal’ 12d files which are in 
(typically)

c:\12djobs\Highway\Stage_1.project

2.6 File Backup Procedures
To ensure that you can retrieve any job or project at any time from backup procedures, it is important that 
a complete ‘set’ of files is taken whenever backup is created. To backup the files associated with the 
‘Highway’, you would typically backup all files and sub-folders in and below

c:\12djobs\Highway

There are configuration files used that may be used in the Highway job, that are supplied by 12D Solutions 
and are automatically installed from the 12d Model CD. These files are in 

c:\Program Files\12d\12dmodel\8.00\set_ups

c:\Program Files\12d\12dmodel\8.00\library

There are other user configurable files that 12d may use and require to fully recreate all steps of a project. 
They are not supplied on the 12d installation CD. These files are typically in 

c:\Program Files\12d\12dmodel\8.00\user

c:\Program Files\12d\12dmodel\8.00\user_lib

These folders may contain files that have been configured specifically for your site e.g. your corporate 
standard mapping, template and plot parameter files, your particular Total Station survey macros and any 
user defined macros etc. In general, such files are not project specific, however because these files are user 
configurable they may be changed at any time and hence particular project specific versions of them may 
be needed as part of the complete file set of a project.

In the above case, the folders shown are for 12d version 8.0. As implied, the files in these folders will 
never be changed automatically by the installation process when you reinstall a later version of 12d. 

The above paths are indicative only. It is possible that folders have been setup at different places for your 
site. For more information on exactly where all library and user folders are located, refer to the following 
environment variables in Appendix A of the on-line Reference manual.

USER_4D

USER_LIB_4D

SET_UPS_4D

LIB_4D
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3 12d Model Help
The 12d Help can be accessed by selecting 12d Model on the Help menu item on the main 12d Model 
menu.

 

Alternatively, individual topics for a panel or menu can be invoked by using the F1 key or the Help button 
on any 12d Model panel.

More information on the Help system will now be given.

Contents
The Contents allows you to look at the overall structure of the Help and access any part of it.

Warning - only topics in the Help can be accessed through the Contents list so any folders in the Content 
folders must be expanded until topics are displayed. Topics can be easily identified because they have a 
question mark beside them indicating that Help is available.

For example, double clicking on ’Tools and Concepts’ expands the next level of ’Tools and Contents’.

Help on Microsoft’s help system
12d Model help
12d macro programming language help

links to web site www.12d.com
12d Model modules authorized
email details of your 12d Model to 12D Solutions
dongle testing panel
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Double clicking on the topic ’Picking Strings’ will then display the topic.

The Contents then disappear leaving Help open at the selected topic.

Double clicking on ’Contents’ on the top of the Help will bring the Contents listing back up.
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Index
The Index option searches through all entries in the Index of the Help.

As the first few characters of the required entry are typed in, the matching index entries are displayed.

Double clicking on the displayed entries will go to the topic in the Help containing the selected index 
entry. If more than one topic includes the index entry, then the list of topics is displayed.

If the index has sub-indices, they can be searched by first typing in the main index followed by a comma, 
then a space and the first few characters of the sub-index.
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Find
The most powerful searching method for the Help system is Find. 

Simply click on the Find tab to search for words or phrases that may be contained in a Help topic.

If Find is being invoked for the first time, the ’Find Setup Wizard’ runs to create an index of every word in 
the Help.

From then on, selecting the Find tab goes straight to the Find screen.
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Panel Help Button
Every panel has a Help button which when selected goes to the topic describing that panel.

Help button to go
directly to the Help
topic for the panel.
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F1 Key
Another method of invoking Help is by using the F1 key as follows: 

when a menu or panel is on the screen and has focus (the menu or panel title area will be highlighted), 
pressing F1 will bring up the help for that menu or panel.

Warning - some of the items on the Strings menu automatically start up a string select and change the 
focus from the panel to a View. This means that pressing F1 will bring up the Help for the View and not the 
Help for the panel. 

To get Help for such a panel, click on the panel to bring the focus back to the panel before pressing F1. The 
top of the panel will highlight showing that it has focus.

Navigating in Help
Once at a topic in the Help, the <<  and  >> buttons at the top of the Help topic will go to the previous 
and next Help topics respectively. 

Individual Help topics can be printed by clicking Print at the top of the Help page.

Because it is difficult to print large sections of Microsoft’s Help system, a PDF file of the entire 12d Model 
Reference Manual has been created and can be used to print out large sections of the manual.

The 12d Model Reference Manual PDF file is on the 12d Model 8 Installation CD in the folder 
Documentation\Reference_Manual.

go back one topic go to next topic
print the
current topic
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4 Basic Operations

4.1 The ‘Mouse’
12d works best with a three button mouse (preferable a wheel mouse). 12d will work with a (Microsoft) 
two button mouse but the lack of the middle button means that you have extra mouse clicks to perform. 

All 12d Documentation uses the following notation for mouse functions.

LB = left mouse button  - used for picking screen items, menus etc.

MB = middle mouse button  - used to accept the highlighted item

RB = right mouse button  - used to pop up a list of alternatives

The left button is the ‘Select’ button – typically used to select graphic items or text. The middle button (or 
wheel) is the ‘Accept’ button, used to confirm a selection. The right button is the ‘Menu’ button. It is 
context sensitive and often displays a list of alternatives available at that instant. 

With a two button mouse you achieve this functionality by clicking the right mouse button to pop up the 
‘Pick Operations’ menu and then clicking LB on Accept or by simply pressing the <Enter> key

The term ‘clicking’ a button means pressing it down and releasing it again. The position of the mouse is 
taken at the time the button is released. In this tutorial manual, items that are selected by a mouse click are 
in bold.

As we get more experienced, we will also introduce the term ‘dragging’ the mouse for some advanced 12d 
operations. We do this by pressing down a button and whilst still holding it down, moving the mouse so 
that the screen cursor moves. Once a definite distance has been achieved, just a millimetre or two is 
sufficient, release the button. 12d notes the vector you defined and can use this information to detect the 
direction in which you dragged the mouse.

Finally, we will use the term ‘double clicking’. This is where we press the button twice in quick 
succession. This is often used for short-cuts.
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4.2 Starting Up - The Project Selection panel
If you installed 12d Model Training from the 12d Model Installation CD, then a ‘12d Model V8.0 
Training’ icon will have been created on your desktop. Double clicking on this icon will take you directly 
into the 12djobs\8.00\Training folder.

Once you are inside 12d, the Project Selection panel will appear. 

Firstly, click the LB over the folder icon at the right end of the Folder field to pop up a panel that allows 
you to see and point to your directory structure. 

In the ‘Select Folder’ panel that pops up, highlight Design 
and double click LB, highlight Getting Started Basic and 
double click.

 Click LB on Open to complete the selection and the list of projects in Getting Started Basic will be 
displayed.
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Notes:

1. It is important to select names that are meaningful to your job as you may have several projects 
associated with a large or complex job.

2. You only need to create a new project once. To access this project in subsequent 12d sessions, double 
click the LB on the project name from the pop up list. 12d will normally pop up the list automatically. 
If needed, you can use the          button to open the list manually.

RULES FOR ENTERING DATA INTO PANELS

Important: The cursor must be locked into the appropriate data entry field when typing data into a 12d 
panel. Often this will happen automatically. If you cannot see the cursor flashing in the data field in which 
you want to enter data, use the mouse to position the cursor anywhere over the data field and click the LB 
to lock the cursor into the field before typing any data. Terminate the data entry sequence by pressing the 
Enter key.

If you make a mistake, you can always select the erroneous entry by double clicking over it with the mouse 

Note the pop up list of projects will be empty because 
there are currently no projects in the folder 
GettingStarted Basic.

You must now supply a name for your new Project. Place the cursor into the Project field, click LB and 
type ‘Stage 1’.

To continue click LB on Proceed
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LB. The text should then appear highlighted. As you retype it, the old entry is deleted.

When filling in data in any 12d panel, it is not essential to terminate the entry of data by pressing the 
‘Enter’ key. You can use the ‘Tab’ and ‘BackTab’ keys to move from field to field. You can also use the 
mouse to jump between fields. If you do press the Enter key to terminate the entry of data into a field, 12d 
will immediately validate the data in that field and supply an error message if appropriate

. 

Click on Set to save the 
details and Finish to close 
the panel.

Once a project is selected, the graphics screen will display, with the Project Details panel open.  Fill in the 
panel with the relevant required details.

Note that you must use the LB to click between fields and cannot use the ‘Enter’ or ‘Tab’ keys.
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4.3 The Initial Screen Layout
The default background colour for a view is black. Black is the best colour for reducing eye strain, and for 
distinguishing colours displayed in the view. The names we use for the various parts of the screen are 
shown on the diagram below. Your screen may not appear exactly as shown as most components on the 
screen can be moved or turned off by user configuration options.

To make the Getting Started manuals easier to print on in-house printers, all of our illustrations have a 
white background colour.

If your screen appears fragmented (as shown in the above view), it is because the main 12d window is not 
maximised. To bring the various parts of 12d together such that it appears more orderly, click LB on the 
‘square’ Screen Maximise button in the top right hand corner of the window labelled ‘12d Model …Project 
“C:\12djobs\8.00\Training\Design\Getting Started Basic\Stage 1”.

Note that the View with the white background is headed ‘Plan 1’. Each View in 12d is assigned to a 
Window. Like all Windows, they can be Minimised, Maximised or Closed. 

The ‘Plan 1’ View can be maximised by clicking LB on the square button in the top right hand corner of 
the view menu.

    Snaps tool bar

Screen maximise
minimise button

Drop down
main menu bar

View titleView type
and name View button

Output

window

area

area

CAD control bar

Text control bar

CAD tool bar

view workbook tabs

Screen message box
View coordinates box

Snaps cogo toolbar Symbol control bar

Recalc Panel
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This then takes up the entire viewing area. Alternatively, you can double click LB on the plan view title 
area to maximise the view (The blue area to the left of the Minimise button). To reduce it back to its 
original size you can hit the restore icon.

The ‘Recalc’ panel is used to quickly rerun design calculations and will be discussed later. We will move 
the panel down to the bottom left of the screen.

The view should then look as shown below.

     Minimise
     Maximise

 Close

Restore icon
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4.4 How to Find Your Way Around 12d Menus
12d options are run by a number of methods. The ‘Drop Down’ menu system from the bar running across 
the top of the screen is the main way we access 12d programs.

In addition to the ‘Drop Down’ Main menu system, there is a ‘12d Model’ menu which is maintained for 
compatibility reasons with earlier versions of the software. This is found at Projects=>12d Model menu.

12d has a unique graphical user interface (GUI) involving hundreds of menu items. These are logically 
grouped by function in a ‘Walk Right’ and ‘Tear Off’ menu system. ‘Walk Right’ menus are menus 
designed such that if you move the mouse cursor right on a menu item containing a right arrow, a further 
menu will pop up, usually on the right hand side. ‘Tear Off’ menus means that a menu can be torn off it’s 
parent menu and relocated elsewhere on the screen for clarity of operation. In general, it is possible to have 
multiple copies of the same ‘Tear Off’ menu on the screen at one time.

Notice that the order of items left-to-right on the ‘Drop Down’ Main menu bar is the same as the top-to-
bottom order on the ‘Walk Right’ 12d Model menu. You can select menu items from either one of these 
sources – the end result is the same.

The ‘Drop Down’ menu bar conforms to normal Microsoft standards so it can be dragged and placed at 
any of the four sides of your desktop. It is probably most useable left at the top of your desktop. 

The following comments apply to ALL menus. To move any menu around on the screen, you ‘drag’ it by 
depressing the LB in the ‘blue’ coloured View Title area, anywhere other than over the ‘X’ in the top right 
hand corner. With the button still depressed, move the mouse to the desired location and release the button 
to repin the menu. The same procedures also apply when moving panels and views. When doing this just 
make sure that LB is clicked in the general heading area and not on a View button.

To ease the learning and usage process, a menu description system has been adopted in this manual that 
describes where to look to achieve a specific function. For instance, to import an AutoCAD DXF file of 
point and line data into 12d, you ‘Walk Right’ on the 12d Model menu or from the ‘Drop Down’ main 

click on 12d Model menu

 

brings up the old menu
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menu bar, through two submenus and select DWG/DXF. This instruction is documented as…

File I/O =>Data Input =>DWG/DXF/DXB 

To display submenus from the ‘Walk Right’, you do not need to use the mouse buttons. Simply position the 
mouse cursor over the 12d Model menu and once ‘File I/O’ is highlighted, slide the mouse right over the 
arrow and the ‘File I/O’ menu will pop up. Slide further right on the ‘Data Input’ menu item and the ‘Data 
Input’ menu will pop up. 

Your screen should appear as follows

Alternatively, you can use the ‘Drop Down’ menu bar to get to the same point …
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To get to this same point using the pull down system, you need to click LB on [File I/O] on the ‘Drop 
Down’ menu bar and then proceed as before on the walk rights as shown below.

Regardless of which menu selection method you used, place the cursor over the words ‘DWG/DXF/DXB’ 
and click the left mouse button (LB) once. The ‘Read DWG/DXF Data’ panel will appear.

Once the panel is selected, the Walk Right menu system should collapse and be removed from the screen. 
If you move and repin any of the menus however, they will not collapse automatically.

If a menu is in the way, you can move it as stated above. Any menu can be removed by clicking LB on the 
‘X’ button in the top right hand corner. 

You would normally now start entering data into the panel. At this time, we will not proceed further with 
this panel. Shut down the panel by clicking LB on the             in the top right hand corner or clicking LB on 
Finish at the base of the panel.

The panel is placed on the screen at the 
location where the mouse cursor was when 
LB was clicked.
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4.5 Toolbars and Controlbars

CAD Toolbar and CAD Contolbar
In 12d Model there are CAD options which are available under both the Strings =>CAD menu and on the 
CAD Toolbar on the left hand side of the 12d Model screen.

The CAD options create various elements using a number of methods. These options make use of Tool 
bars and Control bars. Tool bars just have icons on them but Control bars have icons and also controls 
such as a model box on them. The method groupings are shown on the toolbars (e.g. Points, Lines etc.). 

The user can select an icon on the tool bar and a Flyout for all options of the grouping are displayed. This 
can be done by selecting the appropriate group symbol by holding down the left mouse button on the icon. 
This shows all the different options for that grouping in a flyout panel. Whilst still holding down the left 
mouse button, the user can move along the flyout toolbar to the appropriate option. 

The elements created from the CAD options will have attributes as defined by the Cad Control Bar. This 
control bar is placed on the top left hand side of the screen under the main menu control bar on the creation 
of a project

The fields and buttons used in this control bar have the following functions.

Field Description Type Defaults Pop-Up

N name box names.4d names

name of string. If a valid name already exists in names.4d, the [N] button can be used to bring up a 
choice box of available names. On selection of a valid name, the rest of the values in the control bar 
will be filled out. e.g. colour, linetype etc.

CAD Controlbar

CAD toolbar

CAD Change String
flyout toolbar
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model box cogo existing models

this field can be recognised by the model icon button on the right hand side of the field. The user can 
select an existing model by selecting the model icon. If a new model is to be used, the user simply types 
the model name into the field.

colour box red standard 12d colours

this field can be recognised by the colour icon button on the right hand side of the field. The user can 
select a 12d standard colour model by selecting the colour icon

height input Measures menu

this field allows a height or z value to be assigned to the created elements. If a valid value exists, this 
value will be applied to the created element. This is regardless if the z value was specified in an XYZ 
box. 

If no value is specified, the level will be interpolated where possible. A value of null can be entered into 
the height field as well so that created points will be given a null height value.

linetype box 1 valid linestyles

this field can be recognised by the linestyle icon button on the right hand side of the field. The user 
can select a valid linestyle by selecting the linestyle icon

weight box

this field allows the user to type in a line weight for the cad item created

button

the Tinable field sets whether the vertices and segments are tinable (used in triangulations), not 
tinable (not used in triangulations) or only the vertices (points) are tinable.

button

the eye dropper allows the user to select an existing element which will define the cad control bar 
values.
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The CAD options are available from the CAD toolbar or from the CAD menu under Strings.

When options are chosen from the CAD Toolbar, help messages are written to the Screen Message Box at 
the bottom of the 12d Model screen. Since there is no panel or menu involved with the CAD toolbar 
options, there is nowhere for an F1 key to function for on-line help. 

Hence all the CAD options are documented under each of the walk-right menus for the

 Strings  =>CAD menu.

CAD Toolbar

Strings => CAD menu
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CAD Text Toolbar and Text Controlbar
The various Text options are:

Text can occur as a text string, on vertices of a 4d string, and on vertices and segments of a super string. 
Each type of text has a vertex (these are displayed when Vertices are toggled on in a plan view), a 
justification point, a rotation, an offset and a raise value. The vertex and justification point only coincide if 
the offset and raise values are both zero. All text on a 4d string must have the same height, colour, angle, 
offset and raise. Each part of the text on a super string vertex segment can be independently modified 
depending on the settings for the super string.

For text options, the created elements will have attributes as defined by the Text Control Bar. This control 
bar is placed at the top right of the screen under the main menu control bar on the creation of a project

The fields and buttons used in this control bar have the following functions.

Field Description Type Defaults Pop-Up

Textstyle data box 

On pressing the button a list of available textdata with predefined names read from the 
texstyle_names.4d file are displayed.  

CAD Text Toolbar

Strings =>CAD =>Text menu
Text Controlbar
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If you require a different textsyle, the user can edit the current settings by selecting the edit button to 
bring up the textstyle data panel. This allows for definition of textstyle, units, height offset raise etc.

textstyle box 1 available textstyles

the user can select an existing textstyle by selecting the textstyle icon or entering a value into the input 
box to the left of the button. 
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text height box 10

the user can measure a height by selecting the text height icon or entering a value into the input box to 
the left of the button. The value units are defaulted to world units. This can be changed in the textstyle 
data box
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Symbol Controlbar
The Symbol Controlbar is normally at the top right of the 12d Model screen.

Users can define their own symbols to draw at vertices of 12d Model strings. The definition of symbols are 
stored in a file called symbols.4d.

The fields and buttons used in this control bar have the following functions.

Field Description Type Defaults Pop-Up

Symbol data box 

On pressing the button a list of available symbols with predefined names read from the symbols.4d file 
are displayed. 

Symbol Control toolbar

If you require a 
different symbol, the 
user can edit the 
current settings by 
selecting the edit 
button to bring up the 
Symbol Information 
panel. This allows for 
definition of symbol, 
colour, size, rotation, 
offset and raise.
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Snaps Toolbar
The Snaps Toolbar is normally at the top right hand corner of the 12d Model screen.

Snaps are used when picking strings - see Chapter 7.4 ’Snap Settings’.

4.6 Status Bar
The Status Bar is an optional part of your desktop. It appears at the base of your desktop. The Status Bar 
contains the Screen Message Box and the View Coordinates Box. It is strongly recommended that you 
keep it turned ON. 

If desired, the Status Bar may be turned OFF at any time. From the View drop down menu bar, click LB on 
View, untick the Status Bar checkbox. To turn it back ON, repeat the selection but this time tick the 
checkbox.

4.7 Screen Message Box
The Screen Message Box contains messages that help you interact with the 12d menus. For instance, when 
importing a DWG/DXF/DXB file as shown previously, you have to select a file name to read. Let us 
investigate the messages 12d gives us to help us with this simple operation. 

If the DWG/DXF/DXB Data panel is not already showing, select it again as shown previously. Click in the 
‘File’ name entry data field. Observe that the following response appears in the Screen Message Box

File [Caret][Same As][Menu] select a button

You interpret this help message as follows. 12d is asking you to supply a file name. The three sets of 
square brackets [ ] correspond to your response via the three mouse buttons, LB, MB and RB. 

The LB message ‘Caret’ indicates the position of the cursor if you want to type an answer using the 
keyboard. 

To type an answer, you must first make sure that the cursor is locked onto the field you wish to modify. 
The cursor must appear as a flashing vertical bar before 12d will accept any data from the keyboard. You 
can reposition the caret anywhere in the existing word by using the LB. You could then edit it by using the 
‘Backspace’ key. Alternatively you can use the ‘Delete’ key to delete the character to the right of the 
cursor or the Arrow keys to move within the word. The ‘Home’ and ‘End’ keys take you to either end of 
the existing entry. To delete the entire entry, double click anywhere in the text to highlight it. Then press 
the delete key to erase the entry or just start typing to replace it.

The MB message ‘Same As’ indicates that you can point at any existing item on your desktop. This would 
not normally be used for a file name. 

The RB message ‘Menu’ puts up a menu. At this time, no items are available. If another filename was 
copied to the windows clipboard then the ‘Paste’ would be highlighted.

Or finally, you can click LB on the folder icon to locate the required file

The Screen Message Box area changes dynamically with the position of the cursor on the screen so watch 
it closely for helpful messages.

4.8 View Coordinates Box
Note the location of the View Coordinates Box at the bottom right of the desktop. This box displays the X-
Y coordinates of the cursor when in a Plan view and Chainage-Height when in a Section view.

4.9 The Output Window

Snaps toolbar
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Unlike previous versions, the Output Window by default no longer appears as a full desktop width white 
background window just above the Status Bar, but instead appears as a tab at the bottom left of the screen 
and flashes if there are any messages that need to be reviewed. This Window can be pinned to your 
desktop, but to maximise use of your desktop for 12d views etc., it is best to leave it as is. You can also  
convert the output window to a view, just like a 12d View. 

To turn the Output Window OFF at any time, you need to access the menu bar that appears across the top 
of your desktop. From the Window Drop Down menu bar, click LB on Window, untick the Output 
Window checkbox. To turn it back ON, repeat the selection but this time tick the checkbox.

To make the Output Window appear as a normal  Window on you desktop, place the cursor anywhere over 
the ‘white’ background area of the Output Window and click RB. In the pop up menu, click on the 
Convert to Window menu with the LB. The command Window will then appear somewhere on your 
desktop as a Window. It may be moved by clicking LB in the blue Output Window heading area, dragging 
the cursor to another part of your desktop and releasing the LB to pin it down. 

If you wish to close the "floating" Output Window just click on the            as you would with any other 
view.  

There are three view types available in 12d. They are Plan, Section and Perspective. It is possible to have 
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multiple plan, section and perspective views on the desktop at one time, each showing different 
information. There is no limit to the number of views you may create.

Each View has a View type and name such as ‘Plan 1’, ‘Section 2’ etc. The name appear in the View Title 
Area. This is the blue heading at the top of each view. Just below the name is the View Button Area which 
contains the most common View buttons (i.e. a subset of the complete list of view options). The View 
buttons appears horizontally after the view name. The View Button Area appears automatically with each 
view as the view is created and each view type has different view buttons that reflect it’s characteristics. 
The view name defaults to a number but can be over typed with any alphanumerics.

The view buttons on the Plan view are:

Each view also has its own menu (the view menu) which can be brought up by clicking the LB on the view 
button called ’Menu’.

The View menus can also be brought up in another special way:

if you click the RB in the View Button Area or the View Title Area, you will also get the View menu to 
pop up. Clicking RB again in the View Button Area or the View Title Area will remove the view menu.

So by using the RB, view menus can be accessed even if the ’Menu’ item is not visible in the View Button 
Area.

The View menu contain options available for that particular view type. It is a superset of the buttons that 
appear on the horizontal View Button Area. If the View is made very small or moved off the right hand 
side of the desktop, the various buttons on the horizontal View Button Area will not be selectable as they 
will not be visible. In such case, you have to use the RB in the View Button Area to get access to the 
various View menu items.

Views may be created, resized, overlapped, moved and deleted as required. When you create a view, 12d 
will automatically supply it an ascending number for reference purposes e.g. ‘Section 2’. Views can 
overlap Menus and Panels that are already on the desktop.

Hence there are four menu systems in 12d, one for each view type (plan, section and perspective) and an 
overall main menu.

Plan view buttons

Menu Fit
Pan

Zoom

Shrink

       Toggle

     Refresh
     PlotAdd

Remove
         Previous
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4.10 Basic View Operations
We will now practice some basic View operations

To create a new View, select Views=>New=>Plan from the main menu to create a view with the next 
view number.

Alternatively, you can use Views=>Create=>Plan View. Pick Create with the LB after first supplying a 
View name or accepting the ‘number’ supplied by 12d as the View name.

Once the View is on display, the following operations can be performed from the View Button Area at the 
‘top’ of the View. To move a View to a new location on your desktop, depress the LB in the View Title 
Area – the ‘blue’ area showing the words ‘Plan 1’. Whilst you still have the mouse button depressed, drag 
the mouse and you will see the View move. ‘Pin’ the View again by releasing the LB.

Use the standard Windows features to change the size of the View. Place the cursor near any corner or 
midside of the existing plan view and when the drag arrows popup, depress and hold down the LB and 
drag the mouse to see the Window size change. Pin the new location of the corner by releasing the LB.

To delete a View just click LB on the ‘X’ button in the top right hand corner of the view. You can also 
delete a view by clicking LB on the Menu button in the View Button area to popup the View menu and 
then click LB on Delete.

For the purpose of the tutorial, leave one large Plan View ‘1’ on the desktop. We will subsequently 
demonstrate how the various views are linked. Information in a Plan view can also appear in Section and 
Perspective views for instance.

4.11 Introduction to Models
Models are a 12d concept also present in most CAD systems. It is similar for instance to the layering 
concept in IntelliCAD and AutoCAD, or level in Microstation. Basically each Model represents a 
repository for data. Each point or line that is created or imported into 12d is put into a Model. By turning 
Models ‘On’ and ‘Off’, it is possible to change the amount of information that is displayed. This control is 
provided in each View so it is possible to have different Models on display in different Views.

It is important to note that the data in the various models is always permanently stored in 12d. It is a user 
controlled convention to only show a subset of models at any one time.

There is no limit to the number of models used in any one 12d Project.

If you want multiple copies of a certain line (i.e. string), it is possible for instance to copy the line from one 
Model to another. The lines can then be displayed independently. If both Models were on at once, the 
information will appear as one line instead of two since the strings are coincident. It is possible to 
selectively snap to and edit either line in such a case.

At any time, individual Models can be Renamed, Duplicated, Cleared (removes all points and lines but 
the name of the model is retained) or Deleted. 

Models can be temporarily Removed (from selection lists) and subsequently reinstated through the Add 
function. 

It is also possible to copy models between projects (See Models=>Utilities=>Copy Project Models). 
These are advanced features of 12d that we need not concern ourselves with at this time.

4.12 Introduction to Strings
12d is very much a ‘strings’ rather than ‘points’ based system. In it’s simplest form, a string is a line 
between two points or vertices. In fact a single vertex is also a special type of string known as a ‘point 
string’. A string may be made up of multiple straight line segments connecting many points (vertices). 
Strings may contain curves and arcs as well as straight lines. Strings vary in complexity from 2d (x,y and 
constant z value) to multidimensional (e.g. an alignment string has both horizontal and vertical geometry 
independently defined). In general, as well as x, y and z values, strings have properties such as string 
name, string type, string colour, line style, and chainage. Strings also have a ‘point/line’ property that can 
be set such that they appear as ‘disconnected points’ or ‘connected lines’. From a design point of view, 
strings are much more useful than points. 
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4.13 Introduction to Panels
A panel is simply a means of supplying multiple answers to 12d in a concise manner. Once a panel appears 
on the desktop, you can use the mouse or the Tab and BackTab keys to position the cursor over any data 
field. Remember, when typing data from the keyboard, the cursor must be flashing in the data field for 
characters to be accepted. 

When supplying data to a 12d panel, you do not need to terminate the entry of data into a field by pressing 
the Enter key. For instance, you can use the Tab and BackTab keys or the mouse to move to another field 
after entering data. If you do press the Enter key to terminate the entry of data into a field, 12d will 
immediately validate the data in that field and supply an error message if appropriate. 

When validating 12d supplied or previously entered data in other words, where you do not need to change 
the data in a field - it is not necessary to place the cursor in the data field. Just press the Enter key to pass 
through each field in the panel in turn. 

When typing data into a field, please observe that the ‘Delete’ key deletes a single character to the right of 
the cursor. The ‘Backspace’ key is also active. If you need to delete multiple characters, drag the LB across 
the characters to highlight them (or double click over a word) and press the ‘Delete’ key to delete them or 
start typing to replace them.

In general, 12d has been setup so that data can be selected from lists rather than typed from the keyboard. 
When entering data into a field, if there is a list of alternatives already known to 12d, pressing the LB at the 
icon the end of the field will display the list.

To practice this, bring up the ‘Read xyzs Data’ panel - .from the Main menu, click LB on 

File I/O =>Data Input =>xyzs

Set the ‘Default line colour’ in the above panel to ‘dark green’ by clicking LB on the colour icon (the little 
white box to the right of the word ‘white’ in the fourth data field). A list of available colours will pop up. 
Use the mouse to click LB on ‘dark green’ and then process it by clicking LB on the Select button at the 
base of the panel.

click LB on the colour icon to bring up the list of 
colours

colour 
icon
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Alternatives: You can double click LB on ‘dark green’ to short-cut this sequence. You could also have 
used the down arrow key to work your way down through the list to highlight the word ‘dark green’ and 
then pressed the Enter key.

In a manner similar to the colour panel field just discussed, most panel fields have a pop-up list of choices 
available and the list is activated by clicking on the icon at the right hand end of the panel field. Some 
times there will be a special icon such as the ’colour’ icon in the previous example or the file box icon at 
the end of the ’File’ field of the Read DWG/DXF Data panel.

Other icons that may be used are:

Note the message area at the base of the panel (just above the Read button in the ’Read xyzs Data’ panel). 
Each panel has its own message area to help you interact with 12d. If 12d does not appear to be working 
the way you think it should, you will often get helpful information in the Panel Message area if you make 
a mistake. Look in the Screen Message Box as well as it is also updated when interacting with panels.

If a panel is in the way, you can move it as stated above. Any panel can be removed (shut down) by 
clicking LB on the ‘X’ button in the top right hand corner or by clicking on the Finish button. 

If you want to keep a panel that is already filled in such that you can refer to it later, you may decide to 
temporarily minimise it by clicking LB on the ‘-‘ button. It can later be maximised again by clicking LB on 
the ‘overlapping windows’ button (where the ‘-‘ used to be).

As we don’t wish to proceed further with this panel click LB on Finish or click LB on the ‘X’  button in the 

message area

choice
icons

choicemodel

file tin textstyle info

line weight

colour colour when
none selected

view

line style polygon symbol
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top right hand corner of the panel.
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5 Starting the Tutorial
Before starting your tutorial, it is assumed that your overall desktop layout is as shown in Chapter 4.3,  i.e. 
one large plan view on display called ‘Plan 1’.

5.1 Importing Point Data into 12d
The easiest way to understand the use of Models and Panels is to import some data into 12d and see by 
example.

Point and Line data can be imported into 12d from a variety of sources. For the purposes of the tutorial, we 
will use the simplest of these - a simple ASCII file containing point number, x, y and z coordinates along 
with a code.

We will begin by reading in a Points file called ‘DETAIL SURVEY.dat’.

 

The format is one point per line containing a point number, x, y and z coordinate, string name and string 
number all separated by commas. 
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To read in the file, click LB on File I/O =>Data Input =>x y z general from the Main menu. 

12d gives you the ability to fill in 
this panel once and then save the 
setup to a parameter file.  This 
allows you, on subsequent 
occasions, to call up the parameter 
file and then you only need select the 
data to be read.

To make things easier we have 
already created a parameter file and 
stored it in the user library.

Click on the folder icon at the end of 
the Parameter file field.

A blank folder panel will pop up, but 
if you walk right on the [User Lib] 
directory at the bottom of the panel 
you will see the file 
PtNo,X,Y,Z,Str,StrNo.xyf  

Double click on the file and click on 
the Read icon to read it into the Read 
X Y Z General File panel.
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Your Plan View should now look as follows

You will now notice that the panel 
fills in most of the fields once the 
paramater file is read in.  However, 
you still need to set two fields 
yourself.  Firstly, the parameter file is 
a general file to read in comma 
delimitered data with the Point 
Number, X Coord, Y Coord, Z Value, 
String Name and String Number 
format, so we therefore need to select 
the data to be read in.  

Click on the folder icon next to the 
File  field and select the file DETAIL 
SURVEY.DAT

Next select the icon next to the 
Default text style field and select any 
textstyle.  As we have no text in our 
data, the default textstyle is 
unimportant.

Finally click on the icon at the end of 
Add to view field and select 1.  This 
will automatically add all the data in 
the Default model - unknown - onto 
view number 1.

Your finished panel should now look 
as shown. 

Click on the Read button at the bottom 
of the panel to read the data into 12d.
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You will notice that all of the data has been imported into ‘Plan 1’ in the model ‘unknown’ and that the line-
strings appear green in colour and the point-strings are brown as set in the import panel. 
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5.2 Plan View Operations
Now that we have some data, we can begin to look at some more of the Plan view features of 12d. 

Bring up the Plan view Menu.

In the Plan View Button Area, you will observe a ‘+’ and ‘-‘. This is a shorthand technique for turning 
models on and off. 

Remember in our View so far, we have just one model - ‘unknown’. At this stage it is on display.

Click on the ‘-’ sign button with LB. A list of available models to remove from the view pops up. Pick 
‘unknown’ and click LB on ‘Select’. You will observe the lines and points (crosses) in model ‘unknown’ 
are removed from the view. The ‘+‘ works in a similar way to add models to the View. Practice adding and 
removing models from the view with the + and -. Remember, the models are not being deleted with the ‘-‘, 
merely removed from the current View. Leave the View with ‘unknown’ on display.

After multiple pans and zooms, you sometimes wish to return to a point where all of your data appears in 
the view. This is equivalent to an AutoCAD Zoom-Extents. Click on Fit with LB to see all of your data.

This facility allows you to move the centre of the view but retain the current zoom factor. Click on Pan 
with LB. You then press down LB on a point in the View and then drag the mouse. The data in the view 
will move with the mouse until LB is released.

Select Zoom (to Zoom In) from the Plan View Button area with LB. Click LB on two diagonal points of a 
rectangle and then click LB once anywhere in the plan view. The information will appear enlarged based 
on the size of the rectangle.

If your mouse has a wheel as part of the middle button, then it can be used to dynamically zoom in or out. 
Simply click LB in the plan view at the point you want to zoom about and then roll the wheel forward to 
zoom in and backwards to zoom out.

This is equivalent to Zoom Out. It works just like Zoom but in reverse.

Menu

Adding/removing models

Fit

Dynamic Pan

Zoom

MB Wheel Zoom

Shrink

Previous
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If you click LB on Previous, the view will appear as it was prior to the Zoom. 12d always keeps the details 
of the previous view setting available so that you can return to it quickly. Only one level of previous view 
settings is kept.

There are multiple items under the Toggle Pop Up menu. At this time, we will try only one of them. Select 
Grid with the LB. A rectangular grid should appear. If you click LB on Toggle =>Grid again, the Grid 
will be removed from the display.
The appearance of the grid can be changed by clicking LB on the Menu button in the View Button Area 
and click LB on Settings =>Grid. You can change any of the settings in the panel. Try changing the grid 
spacing from 100 to 10 in both x and y directions and click LB on Set. You will notice that the Grid can be 
turned on and off from either the panel settings or the Toggle =>Grid switch. Click LB on Finish to 
terminate the panel.

All the information on the view will be redrawn. This can also be achieved by clicking MB anywhere in 
the View Title Area or anywhere in the View Button Area except over the ’+’ or ’-’ buttons.

Bring up the Plan view Plot Menu.

Toggle

Refresh

Plot
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5.3 Birds-Eye Views and ‘Throwing’ Between Views
We saw in Chapter 4.10 ’Basic View Operations’ how to create a new View. To introduce some new 
concepts in 12d, we need a second small Plan view on the desktop. Firstly resize your existing ‘Plan 1’ 
view to take up around 2/3 of the right hand side of your desktop.

From the main menu, click LB on Views=>New=>Plan and place a small view about 50mm square in the 
top left hand corner of your desktop. This will create View ‘Plan 2’. See Chapter 4.10 for full details on 
how to create and resize Views. 

Note that when creating a View using Views=>Create=>Plan View, 12d pops up the ‘New Plan View’ 
panel. The View Name field will already have a ‘number’ in it supplied by 12d. 12d will always supply 
you a View number that is not currently in use. If you want, you can overtype the number suggested by 12d 
provided the number you type does not currently exist (it may have been created earlier and then been 
deleted. It is OK to reuse a previous number). 

In the View ‘Plan 2’, use the ‘+’ sign button to display the ‘unknown’ model. From the ‘Plan 2’ View 
Button area, click LB on Zoom and click a point in the lower left corner of the View ‘Plan 2’. Before 
selecting the second point of the Zoom rectangle, move the cursor into the other View i.e. ‘Plan 1’.

Select the second point of the Zoom rectangle in either View. After selecting the second point of the Zoom 
rectangle, you will notice the following prompt in the View Message Box

<View Zoom>[Select][Dynamc][Cancel]Select Destination View - RB to cancel D toggles dynamic

12d is prompting you to select the View you want ‘zoomed’. Click LB in View ‘Plan 1’. The zooming will 
then take effect in View ‘Plan 1’.
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Notice that using this technique, it is possible to achieve a birds-eye effect where the smaller View displays 
the complete model whilst the larger ‘working’ view is zoomed to an extent where it displays only the 
detail that you are currently working on. You would typically do all of your zooming in View ‘Plan 2’ but 
have the detail updated in View ‘Plan 1’. You could even do this with different models turned on. In the 
birds-eye view, you would typically only turn on sufficient detail to enable you to zoom on known 
features.

It is suggested you practice zooming and throwing between Views as this is a powerful concept in 12d and 
you should feel comfortable at using it.

After completing this exercise, delete View ‘Plan 2’ as it is no longer needed. You will now see a second 
way to delete a View. Click LB in the View Menu button in the View Button Area of ’Plan 2’ and select 
Delete and Yes to confirm the deletion. The Delete View menu can also be brought up by clicking LB on 
the Menu button in the View Button Area of the View you wish to delete and select Delete and Yes to 
confirm the deletion.

It is suggested that you move View ‘Plan 1’ to the upper left corner of your desktop. Make the ‘Plan 1’ 
view fill the desktop by dragging the border. To do this, click and hold the LB somewhere near the lower 
right corner of the View to pick up the corner. Drag the mouse to stretch the View out to the lower right 
corner of your desktop and release the LB to set the new size of the view.
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5.4 Deleting a Model
As we now wish to proceed to better ways of importing data into 12d, we need to delete the model  
‘unknown’ as it is no longer required.

From the Main menu, click with LB on Models=>Delete=>Delete a model

5.5 Redraw - Fixing up a Modified or Erroneous View
Whenever data is removed from a View e.g. turning off the display of a model, the view does not 
automatically get refreshed. 12d typically removes a model by overdrawing the information using the 
background colour, usually ‘black’. This operation can leave the view looking speckled and unclear. 

You can force the view to refresh by clicking LB on the Refresh button, or click MB in the View Button 
Area anywhere other than over the ‘+’ or ‘-‘ view buttons. The whole View will be repainted instantly to 
display the corrected information. 

It is also possible that some of the menus may at times become corrupted. Windows is a very complex 
multitasking environment and the menus are stored in memory which is being updated continuously. If you 
ever get parts of your desktop that don’t look correct, you can force your entire desktop (all menus, views 
etc.) to be refreshed by typing Control-R at any time. Alternatively you can refresh just any one Menu by 
clicking MB in the menu title area.

5.6 View Coordinates Box
Note the location of the View Coordinates Box at the bottom of the desktop. If you move the cursor around 
in the Plan View area, you will notice that the x and y values are changing continuously. The values shown 
are those at the tip of the cursor. They are updated with every cursor movement. 

5.7 Work Book Mode
The 12d Desktop has various optional displays. One of those is Work Book Mode. In this mode, tabs are 
displayed on a bar just above the Status Bar at the bottom of your desktop. If you have the Output Window 
in the default position (across the base of your desktop), the tabs bar is displayed just above the Output 
Window.

Each tab corresponds to a 12d View. To set any 12d view as your active view just click LB on the 
appropriate Tab. Note that when a view is active, the View title highlights in blue.

Click LB on the Model field button to pop up a list of 
models to delete. Click on ‘unknown’ with LB.

Click LB on Delete and then Yes twice to confirm the 
deletion
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5.8 Saving a Project
The changes to the Project you are working on are currently only stored in memory. To make the changes 
permanent and update your files on disk you need to Save the Project. This can be done at any time by 
clicking LB on Save from the Projects Menu (Project =>Save).

12d will occasionally pop up a panel reminding you ‘Do you want to save the project? Click on Yes with 
LB to force a Save to occur. The timing at which this message appears is set from the Main menu in 
Project =>Management =>Defaults. See the data field ‘Save Interval (min)’ under the ‘System Settings’ 
tab. 

The default is every 15 minutes. You can set the time interval to zero to turn this feature off altogether.

If you ever crash out of 12d due to a power failure for instance, any changes since your last Save operation 
will be lost. 

5.9 Exit 
To terminate a 12d session, click LB on Exit from the Project menu (Project =>Exit). If you try to Exit 
12d after changes have been made to your Project, 12d will remind you of the changes by prompting you 
for a further Save operation. 

5.10 Restarting 12d with an Existing Project
When you restart 12d and return to an existing project, the appearance of the desktop will be just as you 
last left it. The number of Views, appearance of all models and user defined parameters are redisplayed 
using the settings that are stored with the Project data.

The next time you start 12d, 
the project ’Stage 1’ will 
appear in the previous projects 
list. 

Double clicking LB on ’Stage 
1’ in the list will take you into 
the project  ’Stage 1’.

previous projects list
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Alternatively, if you navigate to the folder containing the project ’Stage 
1’, you will automatically get a pop up list of all available projects in 
that folder to select from. 

Click LB on ‘Stage 1’ to highlight it and then click LB on the Select 
button. Alternatively, you can double click on ‘Stage 1’ to bypass the 
Select button.

If you have trouble restarting 12d, remember you called this Project 
‘Stage 1’. See Chapter 4.2 to remind yourself how to start 12d.
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6 Basic Modelling

6.1 Use of the Mapping File (.mf) and Linestyles
We will now repeat the process of importing data into 12d but this time we will use a mapping file to make 
12d place the information into a more convenient form for final design.

The previously created model has been deleted. We will import the file ‘DETAIL SURVEY.DAT’. To read 
in the file, click LB on File I/O=>Data Input=>x y z general from the Main menu. 

This time we are not automatically adding the data to a view as this feature only adds the Default model to 
the view.  However, the mapping file gives us the opportunity to import the point and line data into 
particular models with their own linestyles and colours.  To open the Mapping File click on the folder icon 
next to the Map file field and click on [Edit]. 

For instance, the entry in the mapping file for entity label ‘CG’ reads

In Chapter 5.1 we used the parameter file 
‘PtNo,x,y,z,Str,StrNo.xyf’, Recall this file 
by clicking on the folder icon to the right of 
the Parameter file field and selecting it 
from the list.  Click on the read button          
to fill in the panel.

You will still need to fill in some of the fields 
so click LB on the ’folder’ button at the right 
end of the File data field to popup a list of 
files. Double click LB on file ‘DETAIL 
SURVEY.dat’. This file has both points and 
strings with coding. A typical string code in 
the file is ‘CG’ for Change of grade.

This time, we will import the data using a 
mapping (mf) file. Use LB on the folder 
button for the Map file field.  You will 
notice that the pop up box is empty.  
However, if you walk right on the User Lib 
menu at the bottom of the panel, you can 
select the ‘DETAIL SURVEY.mf’ file.  We 
keep our map file, together with title blocks 
etc., in the library so that we can access them 
easily from all projects. 

A model prefix ‘survey ’ is typed in to group 
the survey models away from the future 
design models. Ensure that you place a 
<space> after the ‘survey’ so that the model 
names do not run together.

Any data not coded correctly will be placed 
in the Default model ‘unknown’

Click on Read to read the data into 12d 
Model.
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The CG string will be imported with a string name of CG, be placed in the model ‘TOPO CHANGE 
GRADE’, appear as an orange line with a dashed line style (DS BB). This is a user defined linestyle that 
will be used in the final plotted drawings. Note that in this file all line styles are in upper case to make them 
compatible with the line styles typically used in CAD programs.

Click LB on Finish to exit the Map file panel.

To see the various features that have just been created, we now need to add multiple models to the view. 
The easiest way to do this is to click LB on the ‘+’ sign button in the View Button Area to pop up the 
Models to Add panel.

6.2 Saving model listing to a file for future use
 We will now perform a function that is only meaningful later on when we are manipulating TINs. First we 
need to click on the ‘Plan 1’ view tab such that Plan View 1 is now our focus. The heading in view ‘Plan 1’ 
should appear coloured bright blue and it should be to the forefront.

The current thirteen models on the view are exactly the models that are used to create the ’natural surface’ 
tin. We will now see how to record these models in a form that can be used in the future to restore those 
same models to another view.

Click LB in the panel title area (over the words 
Models to Add), move the panel and repin it with LB 
so that it doesn’t collapse after each selection.

Now double click LB on each model in turn and watch 
them appear in view ‘Plan 1’. Leave the model 
‘unknown’ inactive

 Click LB on ‘X’  to shut down the panel.

Clearly by using the mapping file, we have seen how 
the information in each model can now be 
manipulated independently.
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From the Main menu click LB on View=>Models Save/Restore

This file can be read at any future time by use of the Restore option. This will add the same models to a 
view which need not necessarily view ’Plan1’. 

Type in the file name survey. Pressing 
[Enter] will add the extension .vml

Click LB on the view icon then select 
view 1

Click LB on Save

Click LB on Finish to exit the panel
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6.3 Triangulation
We will now use this point and line information to create a 3d surface or TIN (Triangulated Irregular 
Network). One of the concepts in 12d is that a TIN can be created from a single Model or a single View. In 
general, you will use Views to create models since you can control which models are on display in a View. 
It is important to understand that when creating a TIN from a View, only those models on display in the 
View will be used in creating the TIN and only then if they are set to be tinable in the map file. For 
instance, if you were forming a TIN to represent the natural surface, you could leave turned ON any 
models that represented underground surfaces prior to creating the TIN, because in the mapping file they 
would be set to be non tinable.

When using a mapping file to read in data, strings can be flagged as being tinable (Breaklines) or non-
tinable. Only tinable strings are used in the triangulation. Breaklines are used to pick up the topographical 
features accurately. When forming triangles, 12d ensures that every breakline has the sides of one or more 
triangles along the entire breakline i.e. triangles never cross breaklines (unless the breaklines themselves 
cross).

For the purposes of the ongoing tutorial, please ensure that all models in view ‘Plan 1’ are on display prior 
to creating the TIN. ‘Plan 1’ should look as shown above.
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From the Main menu, click LB on 
Tins=>Create=>Triangulate data 

The following panel pops up.

Fill in the first tab of the panel as shown.

The Retriangulate function option is used to construct a 
function which, when recalculated, will run a 
retriangulation on the tin. Place the cursor in the data 
field with the LB and type ‘TIN GROUND’

Each TIN requires a name. Position the cursor in the 
New tin name field and type in ‘GROUND’. If you press 
the Enter key, this name will also be used to fill in the 
Model for tin field but with the prefix ‘tin ’ (see panel). 
The TIN name is subsequently used to refer to this 
specific TIN.

Position the cursor in the ‘Model for Tin field’ and type 
in the suffix ‘,1’ after the name so that the model is 
displayed as the TIN is created. It is permissible to 
overtype this name but this is not recommended. 

Click on the Nulling tab.

Click on the Apply Nulling check mark.

There are two options here, you can either set the 
parameters to null the external triangles or you can use a 
polygon to null all triangles outside this polygon.  The 
DTMBDY string will be used as the boundary for the tin. 
Click LB on the Null polygon string icon then click LB 
on the DTMBDY string followed  by clicking middle 
button (MB) to accept the string.

Click LB on Triangulate to create the TIN. There will be 
a short delay and then your TIN will be created and on 
display as shown below.

 Click LB on Finish to terminate the panel. 

Click on the Data tab.

As we wish to triangulate all the data in plan view 1 and 
leave the mapping file to determine which data to use, 
click LB on the view         icon.  Select ‘1’ from the list. 
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Note that the TIN is clipped at the selected null polygon ensuring only the surveyed data is included. Now 
that we have a TIN we can display the TIN data in a variety of ways
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6.4 Tin inquire.

Click LB in the menu title area (where it says Tin Inquire), move the menu and 
Pin it with the LB. This operation is necessary to stop the menu from collapsing 
after the first menu pick.

Click LB on Aspect, and the Tin Aspect Inquire panel will pop up.

Move the cursor over the Tin icon button at right end of the 
‘Tin’ field and use the LB to pop up a list of Tins. Double 
click LB on GROUND. Then click LB in the menu title 
area (where it says Tin Aspect Inquire), move the panel to a 
clear area of your screen and pin it with the LB. Do not 
Click on the Finish button in the panel.

Repeat this procedure with both the Height and Slope menu 
items.

Once all three panels are on the screen, move the cursor 
anywhere over the TIN and observe what happens. When the 
cursor is positioned over any one triangle, the three point 
coordinates of the triangle are being used to linearly 
interpolate ‘on the fly’ to calculate the exact x,y,z coordinates 
of the cursor. Also the aspect and slope of the triangle is 
shown in the respective panels.

From the Main menu, click LB on Tins=>Inquire and the Tin Inquire panel pops up.

Click LB on Finish on all three panels to put them away. Also click LB on  ‘X’  on the Tin Inquire menu to 
shut it down. 

We will now look at the various ways information in TINs can be viewed.
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6.5 ‘Fast’ Contours
We now want to remove all of the models from the View except ‘tin GROUND’. From the View menu (in 
the View Button area), click LB on the ‘-‘ sign to pop up the Models to Remove panel. 

 

Click LB in the panel title area (over the words Models to 
Remove), move the panel and repin it with LB so that it 
doesn’t collapse after each selection.

Now click the LB on the first survey model.  Drag the mouse 
down the list to highlight all the survey models and click on 
‘Select’. Alternatively, you could double click LB on each 
model in turn except ‘tin natural surface’. Click LB on ‘X’  to 
shut down the panel.

Now from the View 
buttons, click LB on 
the Toggle button to 
bring up the Toggle 
menu.

Then click LB on Tin  
contours. You should 
see the following red 
and green contour lines 
appear.
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 If you click Toggle=>Tin contours again, the View will revert to the ‘green triangle’ display. 

The appearance of the contours can be changed by clicking LB on the Menu button in the View Button 
Area. Click LB on Settings=>Tins=>Contours and the following panel will pop up.

At the completion of experimenting it is suggested that you put the settings back to their default values (as 
above) at this time. 

Click LB on Finish to terminate the panel. Your new settings will remain in effect indefinitely until 
changed.

You can change any of the settings in the 
panel including colour. Click LB on the 
colour icon at the right end of the contour 
colour field to see a popup list of available 
colours. Select one by double clicking LB.

Try changing the contour increment (spacing) 
from 1 to 5 and the bold increment from 5 to 
25. Click LB on Set to activate the changes. 
You will notice that the ‘Fast’ contours can be 
turned on and off from either the ‘Draw 
triangles contours’ tick box panel setting or 
the Toggle=>Tin Contours switch.
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6.6 ‘Fast’ Flow Arrows
It is recommended that you turn on the drainage models for this exercise. From the View menu (in the 
View Button area), click LB on the ‘+‘ sign button and double click LB on ‘survey TOPO BANK 
BOTTOM’, ‘survey TOPO BANK TOP’ and ‘survey TOPO DRAIN CLINE’. Make sure that the ‘tin 
GROUND’ model is also still turned on. The easiest way to confirm this is click LB on the ‘-‘ sign button 
in the View Button Area and look at the list of the models that could be turned off. Click LB on the ‘X’  
button to terminate the list.

Now from the View menu, click LB on Toggle=>Tin contours then Toggle=>Tin edges. The purpose of 
this is to outline each triangle. Then click LB on Toggle=>Tin flow. You should now see an arrow appear 
at the centre of each triangle representing the direction of water flow.

Try zooming in on a section of the model for a closer look. When you have finished zooming, click on Fit 
to again fill the View window.

Click both Toggle=>Tin edges and Toggle=>Tin flow again and the View will revert to the ‘green 
triangle’ display. 

The appearance of the flow arrows can be changed by clicking LB on the Menu button in the View Button 
Area. Click LB on Settings=>Tins=>Flow Arrows and the following panel will pop up.
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Click LB on Set to activate the changes. You will notice that the Flow arrows can be turned on and off 
from either the ‘Draw triangles flow’ tick box panel setting or the Toggle=>Tin Flow switch. 

Click LB on Finish to terminate the panel. Your new settings will remain in effect indefinitely until 
changed (for this project only).

You can change the size of the arrow 
heads and their colour. Click LB on the 
colour icon for the ‘Colour for arrows’ 
field to popup a list of available colours. 
Select one by double clicking LB.

Try changing the arrow length from 10 to 
5 world coordinates (in this case metres). 
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6.7 Perspective View
We will now look at the perspective view facilities in 12d to examine the surface we created above.

Firstly, move your existing Plan view off the right hand side of your screen. Do this by clicking LB at the 
left end of the View Title Area (over the words Plan 1). Move the cursor to the right of your screen and 
you will see the View move. ‘Pin’ the View again by clicking the LB such that just a small section of the 
View is on display.

Now create a new perspective view. Click LB on Views=>New=>Perspective OpenGL from the Main 
menu and a new view pops up. Alternatively by selecting Views=>Create=>Perspective OpenGL view 
from the Main menu, a panel pops up. 

Note the new view is created immediately and is placed over the top of your existing windows.

You should use the standard windows features to ‘Tile’ the views. Click in the view title area for ‘plan 
view 1’ then select Windows=>Tile Vertical

Your overall screen layout should now look something like this.

If necessary, put the cursor in the View 
name field, backspace over the existing 
entry (or use the Delete key) and type ‘2’. 

Click LB on Create. 
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The view buttons on the Perspective view are:

We now need to add the TIN to the perspective view. In the View Button Area of ‘Perspective 2’, click LB 
on the ‘+‘  sign button and double click LB on tin GROUND. Click LB on the Fit icon. Your Perspective 
view should now look as follows

Menu

Fit

Toggle

Refresh

Plot

Add

Remove

Previous

Eye

Walk

Drive

Pan

Window

Shrink Orbit

Joy
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6.8 Joy Panel
The Joy (short for Joystick) provides a quick way of orientating your eye in relation to your data when 
manipulating a Perspective view.

The Joy panel is accessed from the View Buttons Area. Click LB on the Joy button in the View Button 
Area of ‘Perspective OpenGL 2’ and the Joy View panel appears. 

Try clicking LB on In and Out icons 

and observe what is happening. You eye is moving inwards or 
outwards from the data.

Also try Up, Down, Left and Right. icons

If you get lost or zoom in too far, you can always start again by 
clicking LB on Fit in the View Button Area.

The angular step between each up or down step defaults to 15 degrees. You can change this if you want 
smaller increments by entering a new value in the Angular Step field.

Similarly, the Distance changed on each In/Out movement defaults to 100 (metres in our case as all data 
is in metres).

The easiest way to reset a view so that you can see all of the data is to click LB on Fit from the View 
Button Area.
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6.9 Orbit Panel
The Orbit is another way to  orient your eye in relation to your data when manipulating a Perspective view.

The Orbit panel is accessed from the View Buttons Area. Click LB on the Orbit button in the View Button 
Area of ‘Perspective OpenGL 2’ and the Orbit panel appears. 

With the ‘Orbit’ radio button selected use the LB to rotate the image in 
the perspective view.

You can use the middle button wheel at the same time to zoom in and out 
in the perspective view

If you get lost or zoom in too far, you can always start again by clicking 
LB on Fit in the View Button Area.

The easiest way to reset a view so that you can see all of the data is to 
click LB on Fit from the View Button Area.



12d Model Getting Started and Training Manual

Page 74 February 2007

6.10 ‘Fast’ Meshes in Perspective view
We will now see how to quickly display the TIN in mesh form. 

From the Perspective View menu, click LB on Toggle=>Tin mesh. You should see a coarse rectangular 
grid of red and green mesh lines appear. 

The appearance of the mesh can be improved by reducing the mesh spacing. Click LB on the Menu button 
in the View Button Area of the ‘Perspective OpenGL 2’ view and then click LB on Settings=> 
Tins=>Mesh. The following panel will pop up.
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When toggled OFF the view will revert to displaying the green triangles. Your revised view should look as 
shown below. 

Click LB on Finish to terminate the Mesh settings panel.

The effect of the creeks superimposed on the TIN is created by turning on the Drainage model. Click LB 
on the ‘+’ sign button in the View Button Area and double click LB on ‘survey TOPO BANK BOTTOM’, 
‘survey TOPO BANK TOP’ and ‘survey TOPO DRAIN CLINE’.

Change the settings to those shown in the panel. 
Change the mesh spacing from 100 to 10 in both 
x and y directions and bold x and y spacing from 
1000 to 100. Click LB on Set to activate the 
settings.

You will notice that the Mesh can be turned ON 
and OFF from either the ‘Draw triangles mesh’ 
tick box in the panel or from the View menu via 
the Toggle=>Tin Mesh switch.
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Note that 12d always displays the models in the order that they are turned on with the ‘+’ and ‘-‘ buttons. 
Thus to get the effect of survey DRAIN Cline (and any other models) superimposed on your TIN, you first 
turn all models off, then turn the TIN on first and then any other models to be superimposed last. Note that 
clicking LB on the Menu button in the View Button Area for ‘Perspective OpenGL 2’ and selecting 
Models=>Remove all models is a fast way to turn all models off.

The above perspective view orientation will stay as set indefinitely unless changed by further Joy or 
equivalent perspective view operations. 
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6.11 Contours in Perspective Views
Sometimes it is useful to display contours in perspective views. You do this from the Toggle button. 
Simply click LB on Toggle=>Tin Contours as before. 

The contour spacing and colours of the Perspective view can be changed just as we did before in the Plan 
view. This time however you would click LB on the Menu button in the View Button Area of the 
‘Perspective Open GL 2’ view. As before then click LB on Settings=>Tins=>Contours. See Chapter 6.5 
for more details.

Click Toggle=>Tin contours again to revert to the ‘green triangles’ display.
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6.12 Shaded Views
It is also useful to view a perspective as a colour shaded view. 12d has the ability to define up to 10,000 
colours and use these to create a flat shaded view. During the shade, 12d will find and use the ‘colours.12d’ 
file supplied with the tutorial. The angle that each triangle makes with the sun (a point light source at 
infinity) is used to click LB on a different shade of green. The angle of the Sun can be varied but 45 
degrees (the default) gives the maximum contrast.

To quickly shade all the TINs on the perspective view, simply click LB on Toggle=>Shade. 

To access the Shade View panel to modify the shade settings, click LB on the Menu button in the View 
Button Area of ‘Perspective OpenGL 2 and then click LB on Settings=>Shade.

Now every time the view is refreshed or the view changed, the shaded view will reappear. 

To get back to a ‘green triangles’ rather than a shaded view, click LB on Toggle=>Shade to toggle the 
shade off. 

Clicking LB in the ‘Shade tins’ field tick box will toggle on and
off the shading. A tick indicates the shade is activated.

Click LB on Set to create the shaded view. All TINs in the view
will be shaded using the faces in order furthest to nearest the 
viewer. This has the effect of removing faces that are hidden 
from view.

Click LB on Finish to terminate the panel.



Chapter 7  String Picking Concepts

February 2007 Page 79

7 String Picking Concepts
We will now investigate picking concepts and how the mouse is used to interact with 12d when pointing to 
and selecting items on your screen. Initially, do all picking (i.e. mouse clicking) with the LB. This uses the 
12d Model Tentative pick. Later we will look at Fast picking using MB.

In plan view ‘1’ turn on all the models except the triangulation (tin GROUND).

Zoom in to the left dam. Your overall screen layout including the ‘Plan 1’ view should now look as shown 
below.

Whilst the ‘string picking’ concepts are used throughout 12d, especially during construction of design 
features where we want to connect into existing geometry, we will learn about them by example through 
the relatively simple ‘String Inquire’ feature.
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7.1 String Inquire
String Inquire is used to inquire and view the details of a typical line (i.e. string) that is already present in 
the View. From the Main menu, click LB on Strings=>Inquire to bring up the following panel. 

NOTE: the String Inquire panel can also be brought up by pressing the F2 key. This has been defined in
the standard 12d Model function key short cuts.

Click LB on Pick and then move the cursor anywhere over 
one of the bank strings and click LB.

If you placed the cursor over a line:

If your Snap settings are still set to their 
default values, you should see the line go 
yellow (shown here as red) and a yellow 
(shown cyan) square box appear at the last 
location of your cursor when you clicked 
LB. 

If you placed the cursor over a point 
connecting the line segments: 

If you happened to snap to a point on the 
line rather than the line itself, you will see 
the line go yellow (shown red) and a 
yellow (shown cyan) diamond appear at 
the last location of the cursor when you 
clicked LB.
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The second pick couldn’t find any more strings to snap to (adjacent strings were outside snapping distance) 
and so no more information panels popped up. Instead, a circle showed at the pick location to indicate that 
a ‘snap to the cursor’ location had occurred i.e. the only thing that 12d could find at the pick location was 
the cursor.

The above sequence will only happen this way if the snap settings are in their default setting i.e. points, 
line and cursor ON. See below for more about snap settings.

Now if you try to click LB again on the same string, you will only get the yellow circle indicating a cursor 
snap. This happens even if you try to pick it multiple times.

The reason for this is that 12d only ever gives you one chance to snap to a string in any one picking 
sequence. Any strings already rejected during the pick sequence will be ignored. The purpose of this 
behaviour is so that if there are (say) three lines one on top of the other, it is possible to sequentially snap to 
each one in turn by looking at the Information panel details as you perform each LB mouse click. The fact 
that we could only snap to one string confirms that there is only one string present at this location.

A quick method of restarting a pick sequence when a string is highlighted, is to move the mouse (i.e. 
cursor) a short distance from the last pick point. All strings can then be picked again. The next section 
shows how the mouse buttons can also be used to restart a pick sequence.

To terminate the String Inquire i.e. this pick sequence, click LB on Finish in the String Inquire panel.

In either case, an Information panel will pop up as shown at right 
(provided the Info tickbox is set ON - see Chapter 7.4 ’Snap Settings’). 
It advises such information as the name of the Model which contains the 
selected string (survey TOPO BANK TOP), the string name (TBR), the 
type of string (Super). The colour, line style and number of points in the 
line are also returned along with it’s length. 

The x and y coordinates are those of the cursor at the time of the string 
‘pick’. 

In this case the panel shows that the string was accessed via a ‘Point 
snap’.

If you haven’t moved the cursor very far and now pick with the LB 
again, you will notice that the Information panel changes, the string 
goes back to its original brown colour and the cursor is now replaced 
with a yellow (shown cyan) circle. 

This sequence may seem strange at first. 
What has happened is that the first pick 
located a string within snapping distance 
of the cursor so the string ‘highlighted’ in 
yellow and the Information panel for this 
string popped up. The pick location 
showed a diamond to indicate that a ‘snap 
to the nearest point’ had occurred. 12d is in 
effect asking you ‘Is this the string you 
want?’. To reject the currently highlighted 
string, without moving your mouse, 
simply pick with LB again.
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7.2 Use of Mouse Buttons and Enter Key when using Tentative Picking
The three mouse buttons and the Enter key all have a function when picking strings. Those functions are

LB - Left Button Select the nearest string

MB - Middle button Accept the current ‘highlighted’ string. This will also terminate the

current pick sequence.

RB - Right button Bring up the Pick Ops menu

Enter key Accept the current ‘highlighted’ string. This will also terminate the

current pick sequence. This is the same as MB and is very useful when

you only have a two-button mouse.

7.3 Pick Operations Menu via the Right Mouse Button
We will now focus on the use of the RB. Repeat the above picking sequence (From the Main menu, click 
LB on Strings) but now after getting the yellow square cursor (i.e. picking the string), click the RB and the 
Pick Ops menu will pop up

The Accept menu item needs special mention. During a picking sequence, once you have located the string 
you are after, you normally terminate the sequence by clicking the MB. This accepts the current string and 
terminates the pick sequence. 

The Accept menu item has the same function as clicking the MB during the pick sequence i.e. it is used to 
indicate to 12d that the string found is the one that you wanted. If you are using a 2-button mouse, this is 
another way around the lack of the middle button (using the Enter key for accepting was described in the 
previous section). You can accept a string by using the RB to put up the Pick Ops menu and click LB on 
Accept. If you have a 3-button mouse, it is easier to use the MB to accept the string directly.

The Info menu item also has a special function. The Information panel that pops up when a string 
highlights is transitory. If you move the mouse cursor out of the panel, the information panel will 
disappear. This occurs even of you don’t click any mouse buttons. The Info menu item is used to pop up 
the Information panel (again) of the currently highlighted string.

The Cancel menu item is used to terminate many of the operations that are recursive. For instance when 
creating a string, 12d assumes that it will involve multiple line segments so it stays in create mode after 
each segment is placed. After the last point on the string is placed, use the RB to pop up the Pick Ops menu 
and click LB on Cancel to terminate the creation.

Click with LB on Restart. This resets the pick sequence to start over as if the 
previous pick sequence had never occurred. 

If you now try to click on the string with LB, you will notice that the string can now 
be picked again with the LB. The lesson here is that if you ever get confused during a 
picking sequence, the safest way to get operational again is to put up the Pick Ops 
menu, select Restart and start over from the beginning.
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7.4 Snap Settings
In the context of String Inquire, the snap settings are used to selectively choose from 12d data sets when 
inquiring on existing items. The snap settings can be toggled on and off from the snaps toolbar.

The snap settings can also be set from the Snaps menu under Utilities on the Main menu. Click with LB on 
Snaps Ops to pin up the Snaps Ops menu

As you use 12d you need to access the snap settings frequently, so it is convenient to leave the snaps menu 
on display at all times. To minimise menu clutter, the Snaps toolbar and Snaps (Vertical) are merely 
abbreviated forms of the full Snaps menu. They take up less room on your screen and hence are useful to 
the experienced user.

At any one time each snap setting is toggled either ON or OFF. For the Snaps toolbar and the Vertical 
snaps menu, the snap setting is ON when the button is depressed or appears clear and OFF when the button 
appears raised or blue. The settings shown are the default settings when starting 12d.

snaps toolbar

You can select either Snaps or Snaps (Vert).

Point
Line
Text

The Snaps (Vertical) menu Grid
Cursor
Height
Tin
Segment
Info
Data tip
Fast pick
Fast accept

Fast snaps cad accept

Snaps toolbar
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If you are new to 12d, it is easiest to use the full snaps menu until you get use to the abbreviations in the 
Snaps toolbar.

From the Main menu, click with LB on Utilities=>Snaps=>Snaps. Move the Snaps menu to the bottom 
left corner of your screen to get it out of the way.

On the Snaps menu, at any one time each snap setting is toggled either ON or OFF. If a tick appears, the 
snap setting is toggled ON. The settings shown are the default settings when starting 12d.

To change a snap setting, click LB in the snap setting box or on the text describing the snap (e.g. P). The 
setting will toggle ON or OFF.

As shown above, it is possible to have multiple snap settings on simultaneously. For instance, if you want 
to be able to select a line on either ‘the line’ or it’s ‘end points’, you need both Point and Line snap ON.

You can generally leave Cursor snap ON. Most times, if all other snaps fail or are not set, you want the 
mouse cursor position returned. This is useful when freehanding into 12d strings that are not connected to 
existing features e.g. the centreline of a new road. If you don’t have Cursor Snap ON, you will get a ‘Failed 
Snap’ error message whenever all other snap settings fail.

At the bottom of the Snaps menu is an ‘Information’ tickbox labelled Info. If this box is NOT ticked, the 
Information panel will NOT pop up as each string is selected.

Near the bottom of the Snaps menu is the menu item Pt tolerance 10. This figure indicates the current 
point snap tolerance setting is 10. To change the snap setting, click on Pt tolerance 10 with LB and the 
following panel pops up

To change the tolerance, lock the cursor in the Tolerance field by highlighting (double clicking on) the 
existing text, press the Delete key and type a new Tolerance value. Click LB on Set to activate the new 
setting. Click on Finish to terminate the panel.

At this stage we will focus on 4 of the first 5 boxes: Point, Line, Grid and Cursor. 
Upon a successful snap, each snap type returns a unique appearance.

Point Snap - diamond 
Snaps to the nearest point or end of line

Line Snap - square 
Snaps to the nearest line

Grid Snap - circle 
Snaps to the nearest grid intersection point

Cursor Snap – circle
Snaps to the mouse cursor (x,y) position. This is used when drawing freehand.

The point snap tolerance is measured in screen pixels. In 
1024 resolution, a point snap tolerance of 10 represents about 
one hundredth of your screen width. If point snap is set, then 
the closest vertex within this distance of the cursor will be 
selected.
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Similarly for the Tolerance menu item - click on Tolerance and the Snap Tolerance panel pops up

NOTE - When Point snap is set on, any vertex of a string within the point snap tolerance box around the 
cursor when LB is clicked, is considered for selection before any other type of snap is considered. Centres 
of circles, centres of arcs and arc end points are considered to be vertices.

When Line snap is set on, the cursor only needs to be within the snap tolerance distance of any visible 
segment of a string when LB is clicked, and that string is considered for selection. Also arcs and circles are 
considered for selection.

In the area between the point snap box and the snap box, vertices and line snap positions are treated 
equally and the closest one to the cursor is selected.

To practice this further, do a Fit on your current View. Pick a feature in the view where lots of lines meet 
and without moving the mouse, do a series of ‘String Inquires’ by repeated use of the LB and observe how 
12d will snap to adjacent items near to the mouse cursor. Note the cursor shapes returned that indicate that 
sometimes you are getting a ‘Point snap’ and sometimes a ‘Line snap’.

Remember points are just a special type of string..

7.5 Models and Snap Settings
Whilst it may appear obvious, it is important to remember that you can only snap to data that is currently 
on display. Models that are currently turned off will not participate in the selection process during 
snapping. If you find that you are snapping to unwanted items, consider turning off models that are 
irrelevant to your current operations

7.6 Fast Picking
To fast pick a string, simply move the cursor near the string and click MB or type <enter>. The nearest 
string to the cursor satisfying the snap conditions is selected.

Hence using MB alone replaces a LB followed by an MB.

snap tolerance

point snap
tolerance

line snap position

this vertex is selected rather
than the line snap position
because it is inside the
point snap box

Point Snap Box and Snap Box
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7.7 Modifying the String Highlighting Colour
12d has various default parameters for the display of data including the string highlighting colour. This is 
the colour a string is changed to whilst it is selected. 

The default highlight colour is white but this is not be very useful if you want to draw strings in white, or if 
you use a white background colour. In either case, it is important to change the highlight colour to a colour 
other than the white.

To check the highlight colour for the project, we select from the main menu Project => Management => 
Defaults and the Defaults panel pops up.

From this panel, the user can change various parameters for this project that 12d uses for calculations, 
display and data handling.

To change the default highlight colour, select the Systems Settings tab by clicking LB on the ’Systems 
Settings’ tab.
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The following should appear:

Note that the Highlight colour is set to yellow.

To change this, LB click on the colour icon adjacent to the Highlight colour input box and select another 
colour such as cyan from the colour choice box. Then press Select on the colour choice box panel. Colours 
can more quickly be selected from the choice box by double clicking LB on the desired colour - the Select 
button is not required. 

To set the current values for the defaults press the Set button.

NOTE: When a new project is created, the values in the Defaults panel are loaded from the set-ups file 
defaults.4d which 12d Model looks for on start up in the standard 12d location (for more information on 
the search order, see Appendix J ’Set Ups’ in the on-line Reference manual). For an existing project, all the 
values in the Defaults panel are saved with the project so if any have been changed in the project after the 
project was first created, then the defaults for the project will differ from those in the defaults.4d file.

If you wish to keep the current defaults for a project to use as the initial defaults for future new projects, 
you can save the file defaults.4d to a suitable location by clicking on the Write button to bring up the 
Write Setup File "defaults.4d"panel. 
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Specify where you wish the defaults.4d file to be saved and then click on Write.  If you want the changes to 
apply to any new project you create be sure to save the changes to the ‘User folder’  as shown above.

Click on Finish  to close the Save Setup File  panel, and then Finish  on the Defaults  panel.
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8 Creating Strings with CAD
We will now investigate creating strings using the CAD options. We will create points (one point strings), a 2 
point line (single segment string) and a line string (multiple segments in the string).

First we will create a new plan view to work in.

From the main menu, click LB on Views=>New=>Plan. This will create View ’Plan 3’.

Maximise the view by clicking on the Maximise icon on the top right hand corner of the view or by double 
clicking on the plan view title area.

8.1 Creating Points

The CAD options to create points, lines etc. can be done by using the main menu system or by the use of the 
CAD toolbar, which is displayed on the left of the screen at start-up. Regardless of the method used to 
activate the CAD commands, the CAD controlbar as outlined on in Chapter 4.5 will be used to define the 
characteristics of the created elements. We will change the values in the controlbar as follows.

Click LB in the model field and type in ‘cad’. Click LB on the colour icon and choose the colour dark blue 
from the choice box by double clicking on dark blue in the pop-up list of colours. Enter ’20’ into the height 
box and leave the linestyle type as 1.

To create a point string (i.e. one vertex string) we will use the CAD toolbar flyout. Pick the points section of 
the toolbar by clicking LB over the create point symbol and keep LB depressed.

The points flyout menu is displayed which has all the options in the points section of the CAD creation tools. 
This is displayed as a horizontal bar consisting of all the icons that make up all the options in the points section 
of the CAD tools. Whilst holding down LB move the cursor over each of the icons and the tooltip function 
tells what each of the options does. 

     Minimise      Maximise

 Close

                                   model                                            height                                      weight              same

         name                                                     colour                                        linestyle                         tinability
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To select an option, keep the LB depressed until the cursor is placed over the specific option you want and 
then release the LB. We will select the ’Create Point’ option which is the first icon in the flyout .

On selecting the Create Point option, or any other CAD option, the user is prompted for the relevant data in 
the screen message box located on the bottom left hand corner of the 12d Model application window

The user can select a position with the mouse and on accepting that point (Middle mouse button or enter) 
the point is created at the selected position. The model, colour, height etc. are defined in the Cad 
Controlbar .

The snap mode will influence the mouse selection. For example if cursor snap is on, the user can choose a 
position not yet defined. If point snap is on and the selection snaps to an existing point, the option will 
place another point at that location. Ensure that the cursor snap is activated in the snaps toolbar. Click LB 
at a position roughly in the middle of the view. 

Click MB to accept that position. The point is then created with the model ‘cad’ elements’ being added to 
the view automatically.

Message area
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To see the height of the point we must toggle on the Z values. To do this click LB on the toggle button on 
the view menu to bring up the toggle menu. Then click LB on the ’Z values[n/a]’ position. Don’t walk 
right on the arrow near this position. This is to specify individual models to turn the Z values on or off. By 
clicking LB on the Toggle menu, you turn on (or off) all Z values in that view for all models.

The default colour for the height text is yellow. To change the colour of the height text so it clearer we can 
click LB on the menu icon from the view menu to bring up the plan view menu. From that menu we can 
click LB on Settings=>Z values=>Single to bring up the Z values For Plan View panel. From this panel, 
select the colour icon and then select the colour red by double clicking LB on the red colour. It should like 
as above:

Click LB over ’Z values’

The Z value is then shown near the point that we created. 
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Then press Set on the panel to set that colour. Finally press Finish to close the panel. 

The change is made only for view 3. Any other points added to the view will now have their height text 
shown in the red colour. 

There are various ways of selecting a position when creating a point. Specification of a position can also be 
done by the direct input of the xyz coordinate of the point by pressing the space bar to bring up the enter 
XYZ panel or by typing of the value to bring up the XYZ panel. The user then enters the X, Y and Z value 
into the box separated by a space. e.g. 200 150 40. As we have already set a Z value in the CAD 
controlbar, you only have to specify a X and Y value into the box. NOTE: The Z value will default to the 
value entered into the CAD controlbar whether or not it is specified in the XYZ box. If no height value 
exists in the CAD controlbar or the XYZ box, then a value will be interpolated if possible, otherwise a 0 
value will be assigned.

We will again create a point by using the CAD toolbar. 

Firstly, change the Z value in the CAD controlbar to ’50’. Then repeat the steps outlined above to choose 
the Create Point option. Instead of selecting a point with the mouse we will type in the coordinate values. 
To pop up the XYZ box, press the spacebar. Then type into the box, 200 100 and then press the enter key. 
We did not have to specify a Z value in XYZ box as it was already defined in the CAD controlbar. 
NOTE: A space must be placed between the X and Y values.

A new point is created. Click LB on the Fit icon on the view menu  to fit the data in the view.

It should now look like as shown below:
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8.2 Creating Two Point Lines
We will now create a simple one segment line. To do this we will use the CAD toolbar flyout. Pick the 
lines section of the toolbar by clicking LB over the create line symbol and keep LB depressed.

The lines flyout menu is displayed which has all the options in the lines section of the CAD creation tool. 
Select the ’Create Line’ option which is the first icon in the flyout .

On selecting the Create Line option, the user is prompted for the relevant data in the screen message box 
located on the bottom left hand corner of the 12d Model application window

We will pick a position with the mouse to define the start of the line. Pick a position with LB about 
halfway between the two existing points and then MB to accept. After accepting the start point, the user is 
told in the message area to pick the end of the line. You will also notice when you move the mouse around 
that a line is drawn ’rubber banding’ to the cursor position. We now select a point going south east to 
define the end of the string with LB and MB to accept. The created string will be shown given the 
parameters given in the CAD controlbar at the time of construction. 

Lines section
of CAD toolbar 

Message area
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8.3 Creating Line Strings
We will now create a multi-segment string. To do this, we will use the CAD menu from the main menu 
system rather than from the CAD toolbar 

From the main menu, click LB on Strings=>CAD=>Lines=>Line string. The Create Line String option 
will now be running. NOTE: These options have no panel assigned to them. 

The same option can be started from the CAD toolbar as we did for the Create Line option except we 
choose the Create Line String icon from the flyout. 

On selecting the Create Line String the user is prompted for the relevant data in the screen message box 
located on the bottom left hand corner of the 12d Model application window

We will pick a position with the mouse to define the start of the line. Pick a position with LB any where on 
the view and accept with MB. Then move the cursor to a new position and pick and accept a second point. 
Pick and accept a third point and so on. To finish the string simply press the Esc Key on the keyboard or 
alternatively RB and then select cancel from the Pick Ops menu. The string will be created using the 
parameters given in the CAD controlbar at the time of construction. 

This has given a small introduction to the use of the CAD options. For a more detailed explanation of these 
tools see Chapter 14 ’Strings’ in the on-line reference manual and follow the links to the CAD options.

We will now finish this section by deleting the current view. As the view is maximised, select View => 
Delete and select view ‘3’.  Alternatively, we could have restored the view and click LB on the ‘X’ icon at 
the top right of the view.  This should then leave two views, Plan 1 and Perspective 2. If either Plan 1 or 
Perspective 2 are left maximised, select the restore button on the top right hand side of that view to leave 
two views as at the start of this chapter.

Clear the value for the default height in the Cad Controlbar.  Leaving the height there mat create problems 
when creating strings at a later stage.  Also change the default model to one of the existing survey models 

Message area
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as deleting the current model is not recommended.

Finally, we will delete the ’cad’ model. To do this we click LB on the delete model option from the main 
menu Models=>Delete=>Delete a Model. This brings up the Delete Model panel

. 

Select the model icon with LB and then double click LB on ’cad elements’. Then click on the Delete 
button, and answer yes to any warnings (after reading them). This then deletes the model from the project. 



12d Model Getting Started and Training Manual

Page 96 February 2007



Chapter 9  Basic Road Design - Centreline String Creation and Editing

February 2007 Page 97

9 Basic Road Design - Centreline String Creation and 
Editing
We will now begin our first Road Design with 12d. Before we can begin, we need to review other 
techniques for getting data into 12d.

By use of the Snap settings, we have seen how to snap to existing points and lines. This is useful when 
inserting strings into your model that must exactly join other strings already present. There are times 
however when we wish to place a feature in the model exactly by absolute or relative coordinate entry. We 
do this by typed input.

9.1 Typed Input
In general, whenever 12d is prompting you for a cursor pick in a Plan view, you have the option of either

Clicking LB with the mouse to return the x and y coordinates OR

Typing the x, y (and maybe z) coordinates

To enter typed coordinates, you simply start typing, or click RB and select Typed Input from the pop up 
list. A ‘Typed Input’ panel will pop up as you begin typing.

If you wanted to enter the coordinates of the point (100,200,50.5) you would type

Just separate the values with a space between each item. Terminate the entry of data from the keyboard by 
pressing the Enter key. If you only supply two values and press Enter, 12d will assign a Z coordinate of 
zero.

If you ever accidentally touch a key when performing cursor input via the mouse, the ‘Typed Input’ panel 
will pop up. To remove it so that you can revert to cursor input, backspace over any digits that appear in the 
input window until the field is clear and press the Enter key. The panel will disappear.

Whilst there are also other ways of entering typed input e.g. by bearing-distance, relative xyz increments 
etc. we will not pursue these at this time.

9.2 Using a Grid to Assist in Coordinate Entry
It is possible to turn on a grid and with the appropriate grid snap setting, snap to only the grid points when 
entering points and strings. 

Before attempting to investigate the grid capability, let us clean up our display. 

From the View ‘Plan 1’, click LB on the Menu button in the View Button area (or click RB in the View 
Button Area) and the View menu will pop up. Click LB on Models=>Remove All Models. In the View 
Button Area, click LB on the ‘+’ sign button and select all survey models. 

Now let us set our grid settings so that they are suitable for grid snap purposes.  From the ‘Plan 1’ view, 
click LB on the Menu button in the View Button Area to pop up the View menu.Click LB on 
Settings=>Grid and the following panel pops up
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.

Tick on the ’grid draw’ box

Place the cursor on the choice button for the ‘grid mode’ 
field and click LB. You can set your grid to either ‘full 
lines’,  ‘crosses’, ‘marks’ or ‘marks and crosses’. Click LB 
on full lines.

Note the grid x setting. You can change this setting by 
placing the cursor into the ‘grid x’ field, press the Backspace 
key (or the Delete key and typing the required number). 
Repeat this with the ‘grid y’ field.

Place the cursor on the choice button for the ‘text x’ field 
and click LB. Click LB on text off. Repeat this with the 
‘text y’ field.

The other settings can be left as is.

Click LB on Set to activate the change.

To ensure that you snap to the grid, you need to set 
Grid snap ON. When creating new strings you would 

probably want Point and Line snap OFF so that you 
don’t inadvertently snap to features in the view.

Any of the Snaps menus or toolbar can be used to 
toggle Grid snap on

 If you want to use the Snaps menu and it is not already 
on display, click LB on Utilities=>Snaps=>Snaps 
from the Main menu.

If the grid is not already on display, in the View Button 
Area of  ‘Plan 1’, click LB on Toggle=>Grid to turn on 
the grid. The ‘Plan 1’ view will refresh as follows

Toggle Grid snap on

Snaps Toolbar

Snaps Menu
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If we were now to start creating strings, with each menu pick we would snap to a grid intersection. The 
purpose of introducing this here is to show you how to use the grid.

We will not use the grid at this time however as it is more important that you learn how to freehand in 
string data and use typed input.

You can turn the grid off by clicking LB on Toggle=>Grid or unticking the ‘grid draw’ tick box in the grid 
settings panel. Click LB on Finish to terminate the grid settings panel.

Also from the Snap Settings menu, turn Grid Snaps OFF.
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9.3 Horizontal Geometry (HG) Edit
From the Snap Settings menu, turn all Snaps OFF except Point, Line, Cursor and Information. 

In View ‘Plan 1’, click LB on Fit. Your view should look as follows

Now begin placing our new road centreline. From the Main menu, click LB on Strings=> Create=> 
Alignments=>Alignment. The Create Alignment String panel will appear.

Fill out the panel as shown. Put the cursor in the 
Name field and type ‘ROAD 1’. In the Model field 
type ‘ROAD CL’.

These settings tell 12d that our new road centreline is 
to be called ‘ROAD 1’ and it is to be placed in a new 
model called ‘ROAD CL’.

Click LB on Create and the Alignment Edit menu 
will pop up.
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It is suggested that you move the Alignment Edit menu to the left bottom of your 
screen to get it out of the way when creating your new centreline (Refer to the 
following screen as a guide). Click with LB somewhere over the words ‘Alignment 
Edit’  to pick up the menu, move the cursor and pin the menu down by releasing LB. 

We will initially define the horizontal alignment of the road in the View ‘Plan 1’. We 
need to tell 12d that we are defining Horizontal Intersection Points (HIPs). 

Click LB on Append=>HIPs   

12d is waiting for you to select the starting point of your road. You can choose to 
either (1) select an existing point (2) enter coordinates exactly or (3) freehand in the 
points

Type the X and Y coordinate in turn for the next two IP points:

          IP 2
X = 42697.941
Y = 37350.926

          IP 3
X = 42552.804
Y = 37099.542

We want to start by tying into the existing road so click at the intersection of the two roads in the top right of 
Plan 1.  Accept this point

. 
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Don’t put the Alignment Edit menu away yet as we will need it further. Just leave it in view at the lower 
left of the screen. Remember this menu is referring explicitly to the Alignment we are currently creating - 
‘ROAD 1 => ROAD CL’.

We will now put in some horizontal curves between the HIPs. We will insert a curve of radius 200 at HIP 
2 and a curve of radius 100 at HIP 3.

From the Alignment Edit menu, click LB on Curves=>Radius. The Screen Message Box area advises 

<Select point to change radius>[picks][][Menu]

Click with LB in the vicinity of HIP 2. The point will highlight and the Screen Message box advises

<Select point to change radius>[picks][accepts][Menu]”road cl->smith st”

12d is asking you to confirm that this is the HIP where you wish to insert the radius. Click the MB to 
accept the highlighted point. 

A panel will pop up prompting ‘New Radius’. The cursor should already be locked into the data field. 

HIP 2

HIP 3

HIP 4

HIP 1

TERMINATING  THE “RUBBER  BAND”

The last IP point is intersects back onto the existing road a the south east of plan 1.  Click on the 
intersection and accept the position. After the fourth HIP is defined, it will remain rubber banded to the 
cursor. Pressing the Esc key (<Esc>) terminates the String creation process and removes the rubber band. 
Your centreline should now comprise four points connected by three line segments.  

Your view should now look as shown below.  
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Backspace over the zero (or highlight the existing entry by double clicking LB), type 200 and then press 
the Enter key. Observe that a horizontal curve of radius 200 is now inserted and the tangents are removed. 
The IP is now marked with a magenta cross.

The insertion of curves is setup to handle multiple insertions. If you now position the cursor in the vicinity 
of HIP 3 and click with the LB, accept with MB, type 100 for the new radius and press Enter, a further 
radius will be inserted. 

To terminate the radius insertion process, press the <Esc> key (or click RB to pop up the Pick Ops menu 
and click LB on Cancel).

To make the road alignment easier to see, we will turn off all the survey models except the ‘survey ROAD 
CROWN’, ‘survey ROAD SEALED’ and ‘survey TOPO DTM BDY’.

Your plan view should now look as follows.

A feature of 12d at this time is the Information panel. This supplies you information about your string 
geometry. From the Alignment Edit menu, click LB on Info to pop up the Information Panel.

If necessary, move the panel away from your road centreline.

Move your cursor along the new road and you will see the information in the panel continuously changing. 
This panel shown was created by pointing at HIP 2. It gives you the coordinates of the HIP and the input 
and output tangent bearings. Point near the curve-tangent points and you will get further information about 
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those points.

Click LB on Info again to toggle the Information panel OFF.

9.4 Section Views
To complete our new road, we now need to define its vertical geometry. To do this we first need to create a 
new section view. 

From the Main menu, click LB on Views=>Create=>Section view. 

The new view will pop up as a window overlaying your other 12d windows.  Firstly, minimise the 
perspective view ‘2’.  Then click LB on the plan view title area and select Windows=>Tile Vertical

The view buttons on the Section view are:

The first Model to turn on in a section view is always the TIN. The reason for this is to establish the 
vertical geometry in the section view. Remember we gave the TIN a name called ‘GROUND’ and we 
placed it in a model called tin GROUND. Turn this model ON by clicking LB on the ‘+’ sign in the View 
Button Area of  ‘Section LS’. The screen will still appear blank at this stage.

A section view always has the chainage of the selected string as its horizontal axis and the height of the 
string as its vertical axis. We need to tell 12d that we wish to construct a section view along our new road 
centreline ‘ROAD 1’. We do this by selecting a string to profile as shown below. 12d then does a section 
through the TIN i.e. using the x and y coordinates of the selected string, it calculates z values from the 
TIN. 12d then uses the z values (heights) from the TIN and the string’s chainage to construct the Section 
view. 

For advanced users: If multiple TINs are present, any TINs in models added to the view are also sectioned 
as the string is profiled. Also the section view has a ‘corridor width’ so any other strings crossing the 
corridor will also appear provided their various models are turned on.

When the panel appears, highlight the current entry in the 
view name field by double clicking the LB, and type ‘LS’ 
for Long Section. Click LB on Create to create the view.

Menu

Zoom

Shrink

Toggle

Refresh

Plot

Add
  Remove

 Previous

 Exaggeration

  Profile
Previous

Next

 Regenerate

Fit
Pan

string

string



Chapter 9  Basic Road Design - Centreline String Creation and Editing

February 2007 Page 105

Sometimes the Information panel appears to ‘get in the way’ of your picking process. 

At any time it can be toggled off to get it out of the way for the duration of a set of pick operations. You do 
this by unticking the ‘Info’ or ‘I’ tick box on the Snaps menu. 

Alternatively, if you leave it turned on, moving the cursor out of the panel is the easiest way of removing it 
after each pick. At any time, the Information panel can be moved out of the way permanently in the normal 
manner. See Chapter 4.4 for more information on moving menus and panels. 

Once the Information panel is moved, subsequent uses of the panel will pop up at the new location during 
this selection set only. Now back to profiling.

Use the name and model in the Information panel to confirm that you indeed have highlighted the correct 
string. The Screen Message Box advises

 <Profile>[picks][accepts][Menu]”ROAD CL->ROAD 1”

Click MB to accept the highlighted string. The section view will now be refreshed and will contain a green 
line corresponding to where your new road centreline cuts the TIN as defined in model tin GROUND

Your ‘Section LS’ view should now look as follows

The figures of 200 and 100 in the view correspond to the radii of the two horizontal curves defined along 
the centreline. The arrows show the extents of the curves in the section view. 

When we defined the string in the Plan view, we defined it in order starting near the top of the view and 
proceeded towards the bottom so by default, this is the direction of increasing chainage along the string. 
The negative sign in the radius indicates that a curve goes to the ‘left’ when going along the string in the 

From the ‘Section LS’ View Button Area, click LB on Profile icon.          

The Screen message Box advises

<Profile>[picks][][Menu]

12d is asking you which string you wish to profile. In the view ‘Plan 1’, click 
with LB on the magenta road centreline string. Provided your snap settings have 
at least ‘line snap’ ON, the string will highlight in yellow and the Information 
panel will display (see left). 

Hints on the use of the Information Panel:

If you move the cursor outside of the Information panel after it has popped up, 
the Information panel will disappear. To get it back again, click RB whilst the 
string is still highlighted to put up the Pick ops menu. Click LB on Info and the 
Information panel will redisplay.
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direction of increasing chainage. Positive curves go to the ‘right’.

We will now observe some of the advanced features of 12d. 

When the cursor is in the ‘Plan 1’ view you will notice that the View Coordinates Box at the bottom of the 
desktop shows the x and y coordinates of the cursor.

When the cursor is placed in the ‘Section LS’ view, the View Coordinates Box displays the chainage (ch) 
and height (ht) of the profiled string. The chainage has defaulted to start at zero at HIP 1, our starting point 
when we defined our road centreline.

If you place the cursor in the ‘Section LS’ view and move the cursor backward and forward laterally via 
the mouse, you will see a yellow cross moving along the centreline in the ‘Plan 1’ view. 12d recognises 
that the same string is appearing in both views and links the information in the views accordingly. The 
yellow cross is positioned in the ‘Plan 1’ view based on the chainage (i.e. the position of the cursor 
laterally) along the string in the ‘Section LS’ view. 

From the View Button Area, click LB on Fit to fill the view at the new scale. Your overall screen should 
now appear as follows

Section Views default to a vertical exaggeration of 10 to 1.  You can change the 
exaggeration at any time by clicking on the ‘View exaggeration’ icon and selecting 
the required exaggeration.

If you require an exaggeration other than those listed, you can click on 
Exaggeration from the list and type in the reuired value. 



Chapter 9  Basic Road Design - Centreline String Creation and Editing

February 2007 Page 107

9.5 Vertical Geometry (VG) Edit
We will now define our road’s vertical geometry. We do this by defining Vertical Intersection Points (VIPs) 
and then placing vertical curves between the VIPs. As before, the Alignment Editor for our road centreline 
is still active.

To ensure that the complete road centreline, as defined in the Plan view, is also defined in elevation, and 
matches neatly with the existing roads, then we also need to turn on the ‘survey ROAD CROWN’ model 
in the section view.

From the Alignment Edit menu, click LB on Append=>VIPs. 

12d is asking you where you want to place the first VIP. Select and accept the intersection point in the 
‘survey ROAD CROWN’ model.  Your first pick will not necessarily be the ROAD CROWN so be sure 
to cycle through the picks until you have the right point.   The line will rubber band from the previously 
placed VIP.  Now select and accept the end of the existing road  in the ‘survey ROAD CROWN’ model.   
We have now placed 2  IP points which exactly match the existing road at the start of our design. 

We will now add in two more IP points before tying into the existing road at the end of our design in a 
similar fashion. 

Tie the last two IP points into the existing road at the end of the design in the same manner as we did 
previously with the start of the design.

After the sixth point is placed, press <Esc> to terminate the rubber band (or click RB to pop up the Pick 
Ups menu and click LB on Cancel). Click LB on the Refresh button in the View Button Area to refresh the 
view. 

As the VIPs were placed, 12d has annotated the view showing the grades defined.

12d has many facilities to accurately place vertical geometry including typed input of grades and 
chainages. We are now going to insert a new IP point on the same grade as VIP 2 but 40 m from the 
intersection to allow us enough room to place a vertical curve.  To do this we click on  Utilities => Grade 
Insert in the Alignment Edit  panel.  

Type the chainage and level in turn for the next two IP points, the 
same as we did with the X and Y coordinates of the HIP’s

:
      IP 3
Ch = 412
Rl = 49.667

      IP 4
Ch = 600
Rl = 66.333

VIP 1

VIP 2

VIP 3

VIP 4

VIP 6

VIP 5
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We will now insert another VIP  to once again allow enough room to insert a vertical curve before 
finishing on the existing road at the end of our design.  This time we will intersect two grades from existing 
VIP points.  Click in Utilities => Grades intersect.

As we wish to extend the 
grade from VIP 1 through 
VIP 2 our starting VIP # will 
be 2.

The grade will be the grade 
between VIP 1 and VIP 2 
which we can read from the 
section view as -0.681

The distance as stated 
above will be 40m

The Mode will be 
‘distance’ as we want the 
new VIP to be 40m from 
the end of the existing road 
to allow enough room to 
add a vertical curve.

Your view should now have an extra VIP as shown below
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As we have inserted two new VIP’s on the same grade as existing VIP’s we end up with redundant VIP’s 
which can now be deleted.  Click on Delete and select and accept VIP 2.  12d will of course renumber the 
remaining VIP’s and hence the second point to be deleted will be VIP 6.

We will now place some vertical curves in the design. We will use parabolas to define the vertical curves 
and place them via their length.

From the Alignment Edit menu, click LB on Parabolas=>Length. The Screen Message Box advises

<Select point to change length>[picks][][Menu]

Click with LB on VIP 2 and confirm it with MB. A panel will pop up prompting ‘New Length’. 

Note: A feature of Windows is that you can double click on any existing entry to highlight it. As you begin 
typing, the old entry will be replaced.

Observe that a vertical parabola of length 50 is now inserted and the tangents are removed. The VIP is now 
marked with a red cross.

The insertion of vertical parabolas is setup to handle multiple insertions. If you now point in the vicinity of 
VIP 3 and click with the LB, accept with MB, type 150 for the new length and press Enter, a further 
parabola will be inserted.  You can inset the remaining parabolas in the same fashion with VIP 4 having a 
length of 200m and VIP 5 a length of 100m.

To terminate the parabola insertion process, press the Esc key or click RB to pop up the Pick Ops menu 
and click LB on Cancel. Click LB on the Refresh button in the View Button Area to refresh the view and 

This time we will be starting 
from VIP 5

The second intersection 
will be using the grade of 
the existing road or the 
grade between VIP 6 and 7

And the grade will be -5%

Your view should now have an extra VIP as shown below

Our mode for the first intersection 
will be by inputting a grade

Select Insert, then Finish 
to create the new VIP.

Position the cursor in the data field, press the Backspace key to 
remove any previous number, type 50 and then press the Enter key. 
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revise the annotation.

Your ‘Section LS’ view should now look as follows.

Note that the extent of the Vertical curves is annotated on the Section view.

We can now use the Information panel to show the details of our vertical geometry. From the Alignment 
Edit menu, click LB on Info to pop up the Information Panel.

If necessary, move the panel away from your Section view.

Move the cursor in the Section View along the Road centreline string. The data in the Information panel 
changes dynamically as the cursor is moved. 

Observe the information. It shows grade in, grade out, grade difference and the chainage and height of the 
Sag point. It also shows the length and ‘k factor’ associated with this curve.

This panel results from placing the 
cursor near the first Vertical tangent to 
curve point, just to the left of VIP 2. 
Note that the chainage of the VTC is 
calculated.
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We have now finished defining our horizontal and vertical geometry and wish to exit from the Alignment 
Editor. To do so, select Save & Finish from the bottom of the Alignment Edit menu and then Yes from the 
Finish Edit panel.

 WARNING: Do not select Quit from the Alignment Editor. Quit will throw away all the changes made to 
the string since the Alignment Editor was started.

NOTE: We don’t have to exit from the Alignment Editor for the string "ROAD 1". We could simply leave 
the Alignment Edit menu on the screen and return to it later.
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9.6 Editing an Existing String
Now that we have left the Alignment editor, we need to know how to go back into the editor to make future 
modifications to the alignment string. In fact, what we now do applies to editing any existing string, not 
just an alignment string.

To edit an existing string, simply click LB on the option Strings =>Editor which brings up the Edit String 
panel. Now pick and accept the string you want to edit, in this case, the string "ROAD 1". The appropriate 
editor for the selected string will then be started.

The Alignment Edit panel will then reopen and 
you can modify the alignment as necessary.
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10 Road Templates
The road design is calculated by passing a template along the alignment. The interface between the new
template and the existing terrain will also be calculated. 

This is the simplest way that 12d can perform a road design. 

12d has the concept of a basic road template. Templates are always defined for half of the road. When used
on the left, the template is applied on the left hand side of the road. When used on the right, the template is
applied to the right hand side of the road.

Each template has various parts to it. There is a fixed part that is always used in applying the template.
Then there is a Cut/Fill part that is variable. As many links in this part are used as is necessary to reach the
intersection with the natural surface. If after using all of the Cut/Fill links, the road profile still has not
intersected with the surface, a final Cut/Fill slope is used to try to calculate the intersection. All parts of the
template are optional.

10.1 Creation of Basic Templates
Template creation is a mechanical process of filling widths and slopes into panels. Template data is stored
in files. A typical use of templates files is to store standard templates as required by a particular road
authority. These can then be read in and modified to suit each particular job as required - quicker than
starting from scratch each time.

For the purpose of the tutorial, we will use an existing template to save time. Previously stored template
values will be read in from file ‘ROAD TEMPLATES.tpl’. This is one of the files supplied on the tutorial
disk.

From the Main menu, click LB on File I/O=>Templates input. The Read Templates panel pops up. 

Our Template file contains two templates, called FULL LEFT and FULL RIGHT. The various parts of
the template just read will now be displayed. These are just arbitrary names that have been assigned to
these particular templates. There can be many templates in just one file, and in general any template can be
applied either side of the centreline. In this case we will use the convention to have ‘left’ and ‘right’
suffixes "l" and "r" in the names and to use these templates on the left and right respectively. 

An alternative to creating a left and right template is discussed in Chapter 10.3.

Place the cursor on the folder icon for the ‘File’ field and 
click LB to pop up a list of template files. Double click LB 
on ROAD TEMPLATES.tpl in the User Library 

Click LB on Read to read in the template file. Click LB on 
Finish to terminate the panel.
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We will now investigate template FULL LEFT.

From the Main menu, click LB on Design=>Templates=>Create/edit. 

Each template has up to five parts. We will only use Fixed, Cut and Final Cut/Fill. This means that in a 
fill situation, the final fill batter will join onto the fixed part of the road template since we are not defining 
a variable fill template. If a template panel contains blank fields, 12d will ignore such fields in its 
processing of the various template parts.

Fixed Part of Template

From the Template Create/Edit panel, click LB on Fixed and the fixed template panel pops up.

A large amount of links can be defined. We will use just five. 

Note that each link in the ‘left’ template has been assigned a suffix ‘l’. 

The template defines a carriage way width of 3.5 metres at 3% crossfall to the kerb line ‘lokl’. This is 
followed by a kerb and channel, ‘iokl’, ‘tokl’ and ‘bokl’ and then out to the back of the footpath ‘bofpl’. 
The sign convention is +ve is up and -ve is down. Each width defines a link from the previous link so the 
order is important i.e. links are defined relative to one another, not from the template centreline. As you 

In the template panel that 
pops up, place the cursor 
on the    button for the 
‘template name’ field and click the 
LB to pop up a list of templates. 

Double click LB on 
FULL LEFT
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will see later, this is one of the features that makes 12d so powerful - the ability to use string handling to 
automatically perform total road redesign after any geometry or template link changes.

These template link values could now be changed. At completion click LB on Apply to test out any 
changes. Click LB on OK to implement and terminate the panel.

Variable Part of Template

Note that the links in the ‘variable’ part of the template connect onto the ‘fixed’ part i.e. the first variable
link follows immediately after and connects to the last fixed link. The fixed part always appears so it is
normal to put kerbing etc. in the fixed part. 

The variable ‘cut’ part only appears if the fixed part of the template ends in a ‘cut’ region. Thus it is normal
to put benching in the variable part of the template when battering is required.

Similar rules apply to the variable ‘fill’ part of the template.

Variable Cut Template 

From the Template Create/Edit panel, click LB on Cut and the Variable ‘cut’ template panel pops up.

These values could now be changed. At completion click LB on Draw to preview the template. Click LB 
on Apply to test out any changes. Click LB on OK to implement any changes or Finish to terminate the 
panel.

Variable Fill Template

Whilst we are not using one here, this section is included to define the rules of usage. 

By leaving the panel blank, 12d understands that the variable fill template feature is not to be used.

The sign convention for slope in a Fill template is +ve is downwards

Again a large amount 
of links can be 
defined here. We will 
use six to define our 
battered slope. 

Slopes are defined by 
giving a horizontal 
width x where the slope 
is 1 vertical in x 
horizontal.

The sign convention 
for slope in a cut 
template is +ve is 
upwards

Unique names are 
given for each link in 
the template. Note the 
"l" suffix in each link 
name 
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Final Cut/Fill Template

From the Template Create/Edit panel, click LB on Final Cut/Fill and the Final Cut/Fill template panel 
pops up

.

These values could now be changed. At completion click LB on Apply to test out any changes. Click LB 
on OK to implement any changes and terminate the panel.

In the Template Create/Edit panel, click LB on Finish to terminate the panel.

Note that apart from the suffix l or r, the FULL RIGHT template is identical to FULL LEFT. 

After the variable part of the template, 
12d will use the final cut and fill slopes 
defined to calculate the intersection with 
the natural surface. This only occurs if 
the variable part hasn’t yet reached the 
natural surface. 12d will examine a 
corridor up to 100 metres from the 
previous link to achieve this. An 
interface string named ‘intl’ will be 
placed on the TIN at the intersection. 
Again note the suffix "l" 

The links in the left and right 
templates are identical except that 
links in the FULL LEFT template 
have a suffix of ‘l’ and those on the 
FULL RIGHT template have a 
suffix of ‘r’.

This ensures that links on either side 
of the centreline have unique names 
– essential for string modifiers and  
applying boxing as we shall see later
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Variable Cuts 
for right side 
have suffix ‘r’.

The interface name intr has 
suffix ‘r’.
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10.2 Applying Templates
Before we apply the template to the road centreline, let us rearrange our views so that we can see what is 
happening more clearly.

The design can be applied in two ways. 

The simplest way is to create an Apply function which uses the templates for the length of the alignment 
without any modifications such as widening or superelevation. This is also useful for users who don’t have 
the Alignment module.

The other more typical way for most design applications is to create an ‘MTF’ file (Many Template File) 
which allocates and allows modifications of templates. This is then processed using the Apply Many 
Function. 

 Chapter 19 "Many Template Files" deals with the use of the ‘MTF File’.
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We will now create an Apply function to apply the template to the road centreline. 

From the Main menu, click LB on Design=>Apply=>Apply. 

The Apply Template Function panel pops up.

The only other data we need to supply is to indicate to 12d the road centreline (i.e. the reference string) 
along which the chainage is defined and where we want to apply our template. Return to the Main and 
click on the Reference button. 

The Screen Message Box advises

<Select reference string>[picks][][Menu]

In any of the views, click LB on the magenta road centreline string. It is easiest to do this in the ‘Plan 1’  
view. Click MB to confirm the pick.

Explanatory Note: 12d permits the chainage of a road to be defined by a string called the Reference string. 
The template is always applied at right angles to the Reference string. To cater for complex projects, the 
centreline of the template is not necessarily located on the Reference string. Another string called the 
Hinge string is used for this purpose. The Hinge string and the Reference string do not necessarily 
coincide.

In simple projects such as our new road, the Reference string and the Hinge string coincide. By default, 

 Fill in the panel as shown.

A function name is needed so that the process of 
applying this particular template to this piece of 
centreline can be referred to later in any redesign. In the 
‘Function name’ field, type ROAD 1 APPLY and then 
press Enter. On the Models tab the Model names will be 
automatically filled in after you press Enter.  This is  
based on the function name.  In the ‘Tin’ field, click LB 
on the tin icon to pop up a list of available TINs. Double 
click LB on GROUND

In the Left and Right template fields, click LB on  
button to pop up a list of templates. Double click LB on 
FULL LEFT and FULL RIGHT respectively.

As we already have existing road at the start and end of 
our design we do not want to start and end the template 
at the beginning or end of the alignment string.  Type in 
the chainages shown to ensure the design matches up 
with the existing road surface.

The default ‘Section separation’ is 10 metres. For the 
purposes of the tutorial, set this to 5.  For the Practise 

Version use a section separation of 50.

Click on the Models tab and note that the model names 
are already filed in.  If they are not go back to the Main 
tab and press Enter after the ‘Function name’.

The other tabs we don’t need to worry about at this 
stage.

Note: If desired, use the shorthand suffix notation of ,1 
after each model name to force View 1 to be updated 
automatically as the template is applied. If this is not 
done, the strings and sections will still be updated but 
will not be on view. In such case they can be turned ON 
manually from the View Button area with the ‘+’ sign 
button after the template is applied.
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12d assumes the Hinge string defaults to the Reference string so we do not need to click the Hinge button 
in this case.

When the panel is complete, apply the template by clicking LB on Apply

There is now a short delay whilst 12d performs the calculation. The message box at the base of the panel 
will advise the current chainage as the template is applied. As the calculation completes, the view 1 will be 
updated with the new road strings and cross sections.

The panel message box now displays the cut, fill and balance volumes resulting from the application of the 
template. The default convention is negative for cut and positive for fill. Interpret these as follows

Clearly we have too much cut at this stage. We will subsequently improve the design to minimise this.

Click LB on Finish to terminate the panel.

c   -35312.231- cubic meters of cut
f     7403.846- cubic metres of fill
b    -27908.355- balance in cubic metres showing 

surplus of cut over fill 
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10.3 Alternative template creation
12d can use just the one template for both sides of the road. The templates would be set up with no suffix 
after the link names

From the Main menu, click LB on Design=>Templates=>Create/edit

Type in the template name FULL.

Select Fixed

Type in the values as 
shown in the table on 
the left.

Note no suffix "l" or "r"

Select Draw

Select OK to 
implement any changes 
and finish panel 
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Select Cut

Type in the values as shown 
in the table on the left.

Note no suffix "l" or "r"

Select Draw

Select OK to implement 
any changes and finish 
panel 

Select Final Cut/Fill

One template is defined

Note no suffix "l" or "r"

Select OK to implement any 
changes and finish panel 
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From the Main menu, click LB on Design=>Apply=>Apply. The Apply Template Function panel pops 
up.

This action will suffix all road string names with *l for the left side strings and *r for the right side strings

The advantage of this method is the reduction in number of templates created.

The advantage of the previous system is the ability to pick strings from the view to match names which is 
useful when modifying templates and boxing

Each method has its own merits and the user can adopt either system with the same end results

 The panel is filled in the same as shown in
chapter 10.2 with the exception of the ‘left’ and
‘right’ template names which are both FULL
and the entry of the ‘LHS prefix’ *l and the
‘RHS prefix’ *r
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11 Viewing and Assessing the Design
Turn off all models excapt ‘survey ROAD CROWN’ and ‘survey ROAD SEALED’ in the perspective 
view.

We can now turn on the new design models ROAD 1 APPLY Strs and ROAD 1 APPLY Sects in the plan 
and perspective views. The centreline model ROAD CL should be also turned on in the perspective view

Set the screen up as per the example below

.

To begin assessing the design, click LB on Zoom in the ‘Plan 1’ view as shown below

ZoomPanFit
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Note that the interface strings between the road template and the existing terrain are coloured red in cut 
areas and green in areas of fill. This can be confirmed by placing the cursor in the ‘LS’ view and moving 
the cursor backwards and forwards across the view (to change the chainage of the cursor). Observe the 
corresponding movement of the yellow cross in both the ‘Plan 1’ view and the ‘Perspective OpenGL 2’ 
view. 

Also note the various coloured strings that have been inserted in ‘Plan 1’. From the main menu, click LB 
on Strings => Inquire and do inquiries on the various strings in ‘Plan 1’. Make sure that your Point and 
Line snaps are set ON. Place the cursor in an area near the road, click LB repeatedly and observe what 
happens. With each click a new string is selected. As the information panel pops up each time, note the 
various string names and the fact that each one now has a profile chainage (prof ch) and profile Z 
coordinate (prof z). These are now three dimensional strings and can be observed in the ‘Perspective 
OpenGL 2’ view.

You will observe that the cross sections are also strings with their own unique names that are used when 
referring to cross sectional views. For instance ‘design 130’ refers to the section string at chainage 130.0

Whilst the View is zoomed try panning along the road to assess the interaction of the template with the 
existing terrain. From the ‘Plan 1’ View Button Area, click LB on the Pan button. Position the cursor on 
the centreline of the road near one edge of the view and press LB down. Drag the cursor across the view 
and the image will pan with the cursor until LB is released. Keep positioning the cursor on the road 
centreline each time and press clicking LB down and move down the road whilst in the zoomed state. Press 
the <Esc> key or RB to cancel Pan.
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11.1 Perspective View Operations
In Chapter 6.8 we saw how the Orbit panel could be used to orientate your eye in relation to your data in a 
perspective view. We will now use this facility again to observe our design.

The Orbit panel is accessed by clicking LB on Orbit in the View Button Area of ‘Perspective Open GL 2’. 

If necessary, move the panel away from the perspective view so that all of ‘Perspective Open GL 2’ is in 
view. Make sure that models ‘ROAD 1 APPLY Strs’, ‘ROAD 1 APPLY Sects’ and the ’survey ROAD 
CROWN and SEALED’ are turned on.

You will notice that this facility gives you a good feel for the design you have created. You will see 
perspective views similar to that shown above.

Try clicking LB in the perspective view and using the mouse wheel 
roatate the image and zoom in and out to get a view of the intersection at 
the end of the design
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11.2 String Drive
String Drive allows you to nominate a string and a speed with which to drive down the road and 12d will 
automate the process. We will drive down the centre of the road with our eye height 10.0 metres above the 
road.

Note that when 12d asks you to select a string, it can be picked from any view without consequence.

Click LB on Drive to begin the string drive process. The image in ‘Perspective Open GL 2’ will now 
change to that at chainage zero, looking down the centreline. 

The image will repaint automatically multiple times as the drive proceeds. Each image will be calculated 
such that the viewer appears to be travelling down the road at 100 kph. The following are two typical 
images.

Observe the green cross on the centreline in both these views. This represents the ‘target’ point which in 
our case is 40 metres distant. This is also present in all other views. Observe its location in the ‘Section LS’ 
view. The ‘eye point’ is shown with a red cross and the ‘target point’ with a green cross. These points 
move as the drive progresses.

The string drive facility is accessed from the 
Perspective view. In the View Button Area of 
‘Perspective OpenGL 2’, click LB on the Drive button 
and the String Drive panel will pop up.

Set the ‘Eye height’ to 10 metres. The default values 
for the other items are OK. Note that the speed is set 
for 100 kph.

To repeat the drive once the end of the string is reached 
tick on the ‘Repeat’ check box

Click LB on the String to drive along icon and then 
click LB on the centreline of the road. The easiest way 
to do this is to pick it from the ‘Section LS’ view. Click 
MB to confirm the selected string. 
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You can stop the drive at any time by pressing the ESC (Escape) key. To resume the drive click LB on 
Drive.

Once the drive has finished, you can replay it again by resetting the chainage to 0 (or any legitimate value 
along the road) and clicking LB on Drive again. Note that both the eye and target points must be on the 
string at all times for the Drive to work.

It is possible to enter negative values for both the ‘Target distance’ and ‘Speed’. A negative ‘Target 
distance’ (-40) is equivalent to ‘looking out the back window of the truck as you drive down the road’. Set 
the chainage to 40 to start.

Similarly, a negative ‘Speed’ (-100) can be used to drive back up the road in the opposite direction (i.e. in 
the direction of decreasing chainage). To do this you need to set the ‘Chainage’ to somewhere near the end 
of the road (say 870) before you start the drive and also set the ‘Target distance’ to -40. 

Click LB on Finish to terminate the string drive.
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11.3 Defining a New Perspective View using Eye and Target points
Sometimes it is desirable to locate your perspective view exactly. For example, you wish to locate your eye 
at a particular point and look in a particular direction.

To do this, click LB on the Eye button in the View Button Area of ‘Perspective Open GL 2’ and the 
Perspective View panel pops up.

12d then prompts you for the second point on the view line. Click LB approximately in the centre of the 
road as shown. Confirm with MB. This time when the ‘Enter height’ panel pops up, just press the Enter 
key to accept the value.

Ignore the current values in the panel. They 
are left over from our string drive.

Click LB on Eye Target. 12d asks you to 
locate your first point on the view line. Make 
sure that your Point and Line snaps are ON.

In ‘Plan 1’ click LB on Fit to fill the view. 
Select the first point by clicking LB on the 
intersection of the existing road at the end 
of our design. Confirm the point with MB.

An ‘Enter height’ panel will pop up with a 
value in it corresponding to the existing 
terrain (around 60). Since we wish to look 
down slightly on the design we will enter a 
higher z value. 

Double click on the existing entry to 
highlight it and type 95. Press the Enter 
key.
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Your ‘Perspective Open GL 2’ should now look as shown below.

Now we will zoom in for a closer 
look along this view line. 

In the Perspective View panel, lock the 
cursor in the Move distance field by double 
clicking the existing entry with the LB and 
type 50. 

Now every time that you click LB on View, 
the view will be advanced 50 metres along 
the view line. If you zoom in five times you 
will see a view like the one below.

Clearly this facility gives you the opportunity to orientate your eye point accurately in any perspective view.

Click LB on Finish to terminate the panel.

That completes a brief look at some of the facilities in 12d that can be used to verify your design parameters 
visually using perspectives. We will now look at more traditional ways of displaying design data - long sections 
and cross sections
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12 Design Long Sections

12.1 Section Profiles
We will now focus on the sectioning facilities available in 12d. As we already have our Section LS view 
displaying our road centreline, there are also many other ways in which information can be viewed. 

In subsequent operations we will be picking strings. To help make this easier from our Plan 1 view we 
need to zoom it as before. Zoom in on the area shown so that each string is visible in the Plan view. 

We will now section a series of strings that were created during our road design.

In the Section LS View Button Area, click LB on the Menu button to bring up the View menu. Walk right 
on Profile=>Many strings. 

(Note: This option can also be selected by clicking RB on the Profile button to bring up the Profiling 
menu. Click LB on Many strings.)

The Screen Message Box advises

<Profile>[picks][][Menu]

12d is asking you which string you wish to profile. In the zoomed Plan 1 
view, click with LB on the cyan string just above the magenta centreline. 
The string should highlight and the Information panel will display (see 
right). Click MB to confirm the string selected.
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The string will now appear in the Section 4 view.

The Screen Message Box is immediately prompting you for another string.

<Profile>[picks][][Menu]

In the ’Plan 1’ view click LB on the intr interface string between the road formation and the existing 
terrain. This is the red-green string (shown highlighted below). Click MB to confirm the selected string.

The Section 4 view will refresh as below.
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With this technique you can rapidly look at the profiles of any string in the view.

To terminate the Profile=>Many strings feature, press the <Esc> key or click RB whilst the cursor is 
anywhere in the Section LS view to bring up the Pick Ops menu and click LB on Cancel.

Whilst the various strings have been profiled, clearly they are being scaled to fit the size of the Section 
view. To begin to get a feel for the scale of these strings, we can turn on a grid.
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Firstly, let us make sure our grid settings are suitable. From the Section LS view, click LB on the Menu 
button in the View Button Area to pop up the View menu. Click LB on Settings=>Grid and the following 
panel pops up

The Section 4 view will refresh as follows

Depending upon what other information you wanted to display or create in this sectional view, the vertical 

Click LB on the ’grid draw’ field to tick the tick box. This 
activates the grid. 

Note the grid y setting. If it is set to 100, move the cursor 
into the grid y field by clicking with the LB at the right 
end of the ’100’, press the Backspace key followed by 
Enter (or double click with LB anywhere on the 100 and 
type 10 and Enter).

Click LB on Set to activate the change. 

Click LB on Finish to terminate the panel.

Note that you can turn the grid on with the above tick box 
or alternatively in the View Button Area of Section 4, you 
could have clicked LB on Toggle=>Grid
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scale may be too great. There are a variety of ways of changing the vertical scale. 

The default vertical scale uses an exaggeration of 10 to 1. This can readily be changed by clicking LB on 
Toggle from the View Button Area to pop up the Togge menu.

Click LB on 5x to change the vertical exaggeration 5 to 1. In the View Button 
Area, click LB on Fit to fill the view.
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13 Design Cross Sections
12d has many facilities for displaying and plotting design cross sections. We will look at one of these 
called Model profiles. This name is derived from the fact that when we passed the template down our road, 
we created and stored our cross sections in a model. Model profile allows us to display this data by 
profiling the cross sections one at a time.

We now need a Section view in which to display the cross sections. As we still need our existing ‘Section 
LS’ view for our long sections, we will create another Section view. 

From the Main menu, click LB on Views=>Create=>Section view. When the ‘New Section View’ panel 
appears, place the cursor in the View name field, press the Delete key and type ‘XS’. Click LB on Create 
to create a view which will now be referred to as ‘Section XS’.

As before, you need to drag the border to resize the view. Stretch the Section view out so that it is 
approximately the same size as the ‘Section LS’ view we created earlier. Click and hold LB over the name 
‘Section XS’ and drag the view to the bottom right of your desktop as shown below. Pin it by releasing the 
LB. The View will initially be blank as no models are turned on.

Make sure that Point and Line snaps are set ON. Your overall desktop layout should now look something 
like this.
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13.1 Model Profiles
In the ‘Section XS’ View Button Area, click LB on the Menu button to put up the View menu. Click LB on 
Profile=>Model strings. The Profile Model panel will display.

If necessary, move the panel away from your ‘Section XS’ view so that it does not obstruct the view.

Your ‘Section XS’ view will look as follows

This is the cross section through your road at chainage 21.861 (the first section along our design). 

Now each time you click LB on Next, the next cross section along the road will be displayed. Try doing 
this a few times and observe what happens. Observe that the view is refreshed each time so that the cross 
section fully fills the window.

Try clicking LB on the Highlight tick box to turn highlighting OFF. You will notice that the cross section 
string displays its normal colour (cyan) rather than the highlighted colour (red). If you refresh your 
‘Section XS’ view, the string will temporarily display red even if highlighting is ON.

The Item no. field in the Profile Model panel just gives the item number in the model of the profiled 
string. It will increment/decrement as the Next and Previous buttons are selected. Be aware that you can 
overtype the ‘item no.’ field in the Profile Model panel, clicking on Next/Previous will increment/
decrement that number and jump directly to the cross section that is that item number in the model.

As we asked for cross sections at 5 metre intervals when we generated the road, that is the increment that 
will be used. There will also be additional cross sections at tangent points etc.

We will now improve the legibility of our view. From the View Button Area of ‘Section XS’, click LB on 
Toggle. Move and pin the menu to one side so that it stays visible.

Place the cursor on the model icon for the Model 
field and click LB. A list of available models will 
pop up. Double click LB on ROAD 1 APPLY 
Sects.

Now click LB on Next and observe the ‘Section 
XS’ view. The first design cross section will now 
be on display and highlighted (red). 
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Your view should now look as follows

Zoom in on the text area to see it more clearly. When finished click LB on Fit to return to the normal scale.

From the ‘Profile Model on Section XS’ panel, try clicking LB on Next multiple times and observe your 
road sections. 

If preferred, you can ‘untick’ the Fit View tick box in the Profile Model panel and the scale will remain as 
set as you go from section to section. This can be useful when you have the grid turned on. If your sections 
are on a longitudinal slope, the sections may ‘walk’ off the view as you go from section to section. 
Normally you will want the Fit View tick box turned on so leave it that way when finished. 

Note that the various views are still linked. To see this properly, you will need to turn off unnecessary 
models in your ‘Plan 1’ view. In the View Button Area of ‘Plan 1’, click LB on ‘-‘ and click LB on ROAD 
1 APPLY Strs. 

Put the cursor back in your ‘Section XS’ view and move the cursor backwards and forwards laterally. You 
will see a red cross in the plan view moving along the section string of the section you are currently 
viewing in ‘Section XS’.

Another way of selecting the model of strings and the first string to profile for the Profile Model on Section 
panel is to actually pick the string. This is what the Pick button is for on the panel.   To try it, in the Profile 
Model panel click LB on Pick. Then move the cursor to the ‘Perspective 2’ view and click LB on any one 
of the cyan cross section strings. Click MB to accept the string chosen. The ‘Section XS’ view will refresh 
with the chosen cross section and the model containing the selected string is written to the Model field on 
the panel.

You can combine Prev and Next commands with Picks to move around your sections.

Click LB on Finish to terminate the Profile Model panel.

Click LB on Grid to turn the grid on. The spacing of the grid will default to 100 
in both x and y directions. Set the grid x spacing to 3 and the y spacing to 0.5 
metre. (See the previous (Chapter 12.1) in ‘Section Profiles’ for how to access 
and change your grid settings).

Click LB on 5x to change your vertical exaggeration to 5 to 1.

Click LB on Grades to annotate the section. 

From the View Button Area of ‘Section XS’, click LB on the ‘+’  sign button and 
turn on model tin GROUND . This will display the natural surface (the green 
string) on the cross section. The cross section string is red.
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13.2 Quick Model Profile for the Section View
There is also a quick method for profiling model strings.

If a string is profiled using the standard Profile button in the View Button Area, the model containing the 
profiled string is automatically recorded.

Clicking LB on the Previous String and the Next String buttons in the View Button Area of the section 
view then profiles the previous/next string in the model in the same away s the Prev and Next buttons on 
the Profile Model on Section panel. The profile sections are automatically fitted to the section view but are 
not highlighted.

13.3 Extend the Profile in the Section View
It is possible to see more of your natural surface than is currently on display. To see how this works we will 
extend our view 2 metres on the left and 3 metres on the right.

In the ‘Section XS’ View Button Area, click LB on the Menu button to bring up the View menu. Click LB 
on Settings=>Extend. The Section Profile Extend panel will pop up.

To see the new settings in action click LB on Fit in the View Button Area. As shown below, the view now 
extends beyond the extremes of the road profile. This can be useful in checking how the new design 
encroaches on other existing constraints. Remember that it is possible to turn on any other models in this 
view and 12d will show where the strings in these models cross this particular section. We will investigate 
this further in the next Chapter.

Previous string Next stringProfile string

Place the cursor in the Extend Left field and type 2 and 
press the <Enter> key. Then type 3 for the right 
extension.

Click LB on Set to activate the settings. Click LB on 
Finish to terminate the panel.
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14 Services Interference
12d provides facilities that permit you to check for interference between existing constraints such as 
underground services and your new road design. Any underground pipes or cabling for instance can be 
included as strings in your overall terrain model. It is then possible to check the clearances in any of the 
12d views.

14.1 Addition of Services to the Terrain
Most of the breaklines and points that we imported at the start of our design were on the natural surface, 
however there was also some underground features, namely two strings that represent a 100 mm water 
pipe and a 300mm diameter underground sewer.

These strings are mapped as super strings with an associated diameter when we import them into 12d, 
however they could be converted to pipe strings inside 12d . 

To check the diameter of each string go to Strings => 
Inquire and select one of the pipe string segments.  The 
information panel pops up, but it gives us no information 
about the diameter.  To see the diameter information, click 
the RB anywhere on the screen. Walkright on the Segment 
menu and the diameter of the string is shown.  You can click 
on this or any of the other options to make changes to the 
string properties.

In plan view ‘1’, turn on the models 
‘survey SEWER PIPE 300’ and ‘survey 
WATER PIPE’.  Turn off the road 
sections model ‘ROAD 1 APPLY 
Sects’.

The cyan line is the 100 mm water pipe 
and the orange line is the 300mm sewer. 

.
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14.2 Profiling the Services
It is possible to get a quick picture of the services just imported by profiling them as we saw earlier. 

From the View Button Area in ‘Section LS’ click LB on Profile. Put the cursor over the cyan 100 mm pipe 
string in the ‘Plan 1’ view and click LB. Then click MB to accept the highlighted string. Your ‘Section LS’ 
view will appear as follows.

This is a longitudinal section through the pipe showing the depth below natural surface.  If we turn on the 
design strings, ROAD 1 APPLY Strs, in the section view, we can instantly see that we have a problem. 

The points on the screen represent the design strings at right angles to the profiled water pipe and hence we 
can see that the water pipe is above the road design.
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14.3 View Services in Cross Section
We will now look at our underground services in cross section in the ‘Section XS’ view. 

First we need to modify our ‘Plan 1’ view to make it more usable. Click LB on the ‘+’  sign button in ‘Plan 
1’ and turn on ROAD 1 APPLT Sects. Then Zoom in on ‘Plan 1’ view so that we can pick cross section 
strings in the vicinity of where the underground services cross our new road. Zoom in on the area shown. 
You will notice that the pipe strings now appear as two parallel lines i.e. they have a diameter in Plan.

Design 180

Design 220

Now we need to set up ‘Section XS’ to display the appropriate cross 
section. 

In the View Button Area of ‘Section XS’, click LB on Profile and point 
to the cross section string in the ‘Plan 1’ view that is closest to where the 
cyan string crosses the road centreline. This is section design 180. Look 
for the name ‘design 180’ in the pop up Information panel (shown at 
right). Click MB to accept the highlighted string. The ‘Section XS’ view 
will be refreshed with the new profiled cross section.

Now turn on the models survey SEWER PIPE 300 and survey 
WATER PIPE  You should now see a small cyan dot on the view at level 
64. This is where the 100 mm water pipe crosses the section.

Note that in ‘Plan 1’ the water pipe has been given a linestyle and 
hence does not show as a "pipe" in the plan.  This was simply 
controlled by the linestyle given in the Map File when we imported 
that data.
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Your ‘Section LS’ view should now look as follows:

100mm water pipe

Zooming in closer 
the pipe is shown
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14.4 Viewing Interference with Services in Long Section
We can also check for interference in the long section. The invert of kerb string is the lowest point in the 
fixed portion of our road cross section.  We will now profile this string and look where the services appear 
in our long section to check for interference.  Turn on the model ‘ROAD 1 APPLY Strs’ in plan view 1.

From the View Button Area in ‘Section LS’ click LB on Profile. Put the cursor over the dark blue ‘iokr’ 
string in the ‘Plan 1’ view and click LB. Unless you zoom right in, you may need to press the LB several 
times to cycle through the selections until you get the ‘iokr’ string.  Remember to keep looking in the info 
panel to ensure you have the correct string, then click MB to accept the highlighted string. 

In the same section view, click LB on the ‘+’ sign button and add the models survey SEWER PIPE 300 
and survey WATER PIPE to your view. You should see some orange and cyan dots added to the section 
view as it refreshes.

Your overall screen should now look something like
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To see how the services appear in cross section, zoom in on that area as shown below.

First note that the ‘pipes’ appear in the section views. The reason that they appear as ovals and not circles 
is that we have a vertical exaggeration of 5 to 1 set on the view.
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14.5 Setting Corridors
Rather than seeing just a ‘thin slice’ where the pipe crosses the section, 12d has the concept of setting a 
corridor width along a profiled string. Then whenever you profile a string in a section view, everything that 
appears within the corridor width will be included in the view. We will set a corridor width of 20 metres 
either side of the string being profiled to see this more clearly. 

In the ‘Section LS’ View Button Area, click LB on the Menu button to pop up the View menu. Click LB on 
Settings=>Corridor and the Section Corridor panel will pop up.

Double click the LB in the Width Left field and type 20. Press the Tab key to go down a field and type 20 
for the Width Right. This has now defined a corridor 40 metres wide.

Click LB on Set and the view will be updated. Click LB on Finish to terminate the panel.

The ‘Section LS’ view should now look as follows.

Whilst it may not appear obvious, the cyan string now appears in the view as a tube. This is because much 
of the pipe appears in the 40 metre corridor is shown in the view. Sections are shown on the pipe 
corresponding to where the various cross section batter strings project onto the pipe. Try Zooming in on 
the pipe for a closer view. Click Fit when finished Zooming.

Remember that once a corridor for a view is set, it continues to remain set until changed, regardless of 
which strings are subsequently profiled. 
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15 Modification of Design Parameters
We will now perform a typical redesign operation and see how efficiently 12d handles such tasks. We will 
modify the vertical geometry of our road centreline to pass over rather than through our services. To do 
this we first need to rearrange the information on display in our views.

Minimise all views except ‘Plan 1’ and ‘Section LS’ then tile them vertically. In the ’Plan 1’ view, ensure 
that the ROAD 1 APPLY Sects and Strs are turned on. In ‘Section LS’ ensure that the alignment string is 
profiled and that the survey SEWER PIPE 300 and survey WATER PIPE models are turned on.  

Your overall screen layout should now look something like this

If the ‘Alignment Edit’ menu is not on display you need to reactivate it. Remember at any one time this 
menu is only active with one alignment. The Alignment we are editing here is called ROAD 1. If the 
Alignment Edit menu is already on display you can skip this next step. To get the Alignment Edit menu on 
display and active with our road centreline, move to the Main menu, click LB on Strings=>Editor or press 
function key 6 (F6).

The Edit String panel will then pop up asking you to select the string to be edited. In the ‘Plan 1’ view, 
click LB on the magenta string corresponding to our road centreline. The string will highlight and the 
Information panel will pop up. Click MB to accept the highlighted string and the Alignment Edit menu 
will pop up. Move the Alignment Edit menu to the lower left area by clicking and holding LB over the 
words Alignment Edit, moving the cursor and pinning it down by releasing the LB.
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15.1 Modify Vertical Geometry
We are now ready to begin modifying the road geometry. We will raise the level of the road in the vicinity 
of the pipes by inserting a new VIP into the alignment.

From the Alignment Edit menu click LB on Utilities => Grade insert. 

The ‘Section 2’ view should now look as follows

We will now insert a curve at this new VIP X. 

From the Alignment Edit menu click LB on Parabolas=>Length. Point to VIP X and click LB and 
confirm it with MB. A panel will pop up prompting ‘New length’. Type in the value shown.

As VIP 2 is on grade between VIP 1 and VIP 3 it is not needed and hence we can delete it from the section 
view.  Click on Delete in the ‘Alignment Edit’ panel and select VIP 2. The ‘Section LS’ view should now 
look as follows

Fill in the panel as shown

We will insert a new VIP on the same grade as VIP1 
to VIP 2 and at a chainage of 202.

Click on Insert once you have filled in the panel.

 VIP X

 VIP 2

 VIP 1

Press the Enter key to terminate data entry. A vertical curve will 
appear in the view. Click LB on Fit to ensure that all information in 
the view is updated.
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15.2 Recalc after Modifying Vertical Geometry
We will investigate one of the most powerful features of 12d. You will remember that earlier we defined a 
template to be passed down our road centreline. When we filled in the template panel we gave the template 
function a name - we called it ‘ROAD 1 APPLY’. The purpose of that name will now be shown.

We can now refer to the template function by name and get it to reprocess the series of steps it needed to 
calculate the road geometry from a single menu click!

From the main menu, click LB on Utilities=>Recalc=>Recalc=>ROAD 1 APPLY.  You can also walk 
right on Recalc in the Recalc Panel and select the function ‘ROAD 1 APPLY’.

You will notice that 12d goes into a heavy compute operation. After a few seconds, the various plan and 
perspective views are all updated and now display the redesigned road. At the end of the calculation, the 
Apply Template panel will pop up

Click LB on OK to remove the panel.

If we now repeated any of the operations we did earlier such as the ‘string drive’ down the road or the 
profiling of sections, we would be looking at the revised data. It is strongly suggested you try this in your 
own time to convince yourself that all of the data have in fact changed!

During a recalc, you will notice that the view ‘Section XS’ has gone blank. This is intentional as the data 
that was displayed became obsolete. If you want to see the new data, simply repeat the steps we did earlier 
to profile any of the cross section strings. Note that the views only go blank when you place the cursor in 
the view. This is a reminder that the data on display was obsolete and can no longer be displayed 
(depending upon the changes you made prior to the recalc, the strings being profiled may no longer exist!).

It is worth noting that if we had used multiple templates and restricted each template application by 
chainage to only part of the road, we may have needed multiple template functions to achieve our full road 
design. This is more typical of what happens in a real world situation. In such case, it is possible to process 
all template application functions in sequence with a single menu click.

You would do this from the Main menu by clicking LB on Utilities=>Recalc=>Recalc all or click on 
Recalc all in the Recalc Panel.

12d advises you of the new cut and fill 
volumes associated with this 
recalculation.
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Important: Each time you perform a recalc, all of the string data that is calculated by 12d is automatically 
deleted and replaced by new data. This is unlike most other processes in 12d where if you repeat an 
operation such as importing a string or creating a string manually, you end up with multiple copies of 
coincident strings. 

We saw above how we can modify vertical geometry and get 12d to automatically recalculate our revised 
road design. We can also change the horizontal geometry and get 12d to update our section view. We will 
now perform a series of more complex changes that are typical of the redesign steps required in a real 
world situation
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15.3 Inserting Spiral Transition Curves into the Horizontal Alignment
Spiral transition curves are inserted after normal constant radius curves have already been inserted i.e. the 
IP must have a non-zero radius before a spiral can be inserted at the tangent point.

The main horizontal curve at HIP 3 is currently a constant radius curve of 100m radius connecting 
adjoining tangents. We will introduce clothoid spiral transition curves at either end of the constant radius 
curve to allow the introduction of superelevation into the pavement surface. 

Turn of the ROAD 1 Apply sections and strings.

From the Alignment Edit menu, click LB on Curves=>Spiral and the Screen message box advises 

<Select point to change length>[picks][][Menu]

Place the cursor near Tangent-Curve point 
TC 3 and click LB. Click MB to confirm 
the selection. Press the Enter key and a 
box will pop up asking for the length of 
spiral to be inserted. 

Type the value shown followed by the 
Enter key.

Place the cursor near Curve-Tangent point 
CT 3 and click LB. Click MB to confirm 
the selection. Enter the same spiral length 
as before

 TC 3

 HIP 3

 CT 3
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The modified geometry should now look as follows

15.4 Changing the Annotations
We need to see the impact of our new Horizontal alignment in profile. 

To update the ‘Section LS’ view to reflect the changes to our horizontal alignment, from the View menu 
click LB on Regen. 

The green ‘natural surface’ line corresponding to the revised centreline will change

.

Observe that in the Horizontal geometry annotation at the base of the view, a letter R has been appended to 
the -100 to show that it is a Radius and the Spirals have an L appended to the 50 to indicate Length.

From the Alignment Edit menu click LB on 
Info to put up the Information panel. Move 
the cursor near the points at either end of the 
spiral curves and observe the data displayed. 

Note the various new points that have been 
created to replace the Tangent-Curve TC 3 
and Curve-Tangent CT 3 points shown above. 

The new points are

Tangent-Spiral TS 3

Spiral-Curve SC 3

Curve-Spiral CS 3

Spiral-Tangent ST 3

Click LB on Info again to toggle off the 
Information panel.

 SC 3

 TS 3

 CS 3

 ST 3

 VIP 5

 VIP 4
 VIP 2

 VIP 3
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You will note that as we are adding more detail and text to the Section View, the various items of text in the 
annotation now overlap. You can make the annotation more readable by reducing your text height. From 
the View menu of ‘Section 2’, click LB on Settings=>Geom annot.

Place the cursor in the ‘view text height’ 
field and change the height from 10 
pixels to 8.

In this manual I have set the colour to 
black, but you can use any colour.

I have also changed the arrows to red, 
but once again you can use any colour.

Click LB on Set to activate the change.

Click LB on Finish to terminate the 
panel.

The annotations in the section view should now look as shown below



12d Model Getting Started and Training Manual

Page 158 February 2007

15.5 Modifying a Vertical curve by Moving the Tangent Points
We will now look at how we can pick up points with the cursor and use the mouse to visually place curves. 
First Zoom in on the area shown in the above view.

VCT 2

From the Alignment Edit menu click LB on Move. Place the cursor on point VCT 2 (Vertical Curve to 
Tangent point) as shown above and click LB. Click MB to confirm the selection. Then move the cursor to 
the left and right and observe what happens. Through excessive movement of the cursor it is possible to 
create a vertical curve that interferes with its adjoining vertical curve. Whilst 12d will permit you to make 
such a change, the template function will not proceed when you attempt to create the road. To ensure that 
the template function can work, it is essential that your vertical geometry is meaningful. 

Move the cursor to the right slightly to minimise the length of tangent between adjoining curves i.e. 
minimise the distance from VCT 2 to VTC 3 (Vertical Tangent to Curve point). Pin the tangent point down 
by clicking LB. Click LB on Fit to fill the view. 

View ‘Section 2’ should now look similar to this

 VTC 3

 VCT 2
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Note that in our case the length of the vertical curve is now 77.667. Your case need not be exactly the same 
since the mouse is being used to ‘eyeball’ in the tangent point. You can pick up the tangent point and move 
it multiple times if need be.

Hint: After practising moving TP’s with the mouse, you should reset your VC so that it exactly matches the 
above settings. Click LB on Parabolas=>Length from the Alignment menu, click LB on the curve you 
just modified and MB to confirm the selection. 

Important: It is desirable that you have both the horizontal and vertical geometry defined exactly as shown 
above as this information is used in the Advanced Road Design (Template modifiers) function later in the 
tutorial.

15.6 Increasing the Width of Pavement and Introducing a Table Drain
The following steps are designed to show you how to modify template values and how to introduce new 
links in a template. We will make a copy of your existing templates and then edit the copies to make the 
template changes. This way your original templates are left unchanged should you need them again

PERFORMING TEMPLATE CHANGES MANUALLY

From the main menu, click LB on Design=>Templates=>Copy and the Template Copy panel will pop up.

Type ‘77.667’ and press Enter. Click LB on Fit to refresh the view.

In the Copy Template panel, click on the Old 
template icon and select the FULL LEFT 
template.

In the New template name field type the name 
‘FULL LEFT W TABLE DRAIN’. Click LB on 
Copy.

Repeat the process and copy FULL RIGHT to 
‘FULL RIGHT W TABLE DRAIN’. Click LB on 
Finish to terminate the Copy Template panel.

From the main menu, click LB on 
Design=>Templates=>Create/Edit and the 
Template panel will pop up.

In the template panel that pops up, click on the icon and select 
the FULL LEFT W TABLE DRAIN template.
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We will confine our changes to the fixed part of the template. Click LB on Fixed.

The Fixed Template panel pops up. The panel displays the template links we used earlier in the tutorial.

We will now modify the template by inserting a table drain at the back of the footpath

The finished panel should look as follows - remember to add the suffix ‘l’ to the invert of drain name.

We now need to repeat the above changes for the template on the right side of the road.

The changes you need to make on the right are identical to those on the left except that all link names have 
a suffix of r (for right) instead of l (for left). Thus the invert of drain link will have the suffix ‘r’.

That completes the changes to our templates.  Click on Finish to close the Template Create/Edit panel.

Position the cursor over 
the ‘Width’ entry on line 5 
and click LB to lock the 
cursor into the field. 
decrease the footpath 
width from 4.16 to 3.5 
metres. 

Press on the Enter key 5 
times so that a new line 
appears in the template.

Click LB on Draw to 
preview the changes. Click 
LB on Apply to test the 
changed settings. If you 
have made any syntax 
errors, they will appear in 
the message line at the 
base of the panel (where it 
shows valid colour)

Click LB on OK to 
implement the settings and 
terminate the Fixed 
Template panel.
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15.7 Recalc after Modifying the Template and Other Geometry Changes
Clearly we have now made significant design changes to the template and to the geometry of the road 
centreline. We need to get 12d to update the views to reflect these changes. Regardless of how complex the 
changes are, all we have to do normally to perform a complete redesign is run the recalc function. 

Since we have changed the names of our templates however, we must make minor edits to our apply 
function to point to the new templates.

Before recalculating the changes, turn on the ROAD 1 APPLY Sects and Strs models in ‘Plan 1’ view.

From the main menu, click LB on Utilities=>Recalc=>Editor=>ROAD 1 APPLY 

The Apply Templates panel will pop up with the values in each field already filled in. 12d remembers the 
values you entered earlier. You can now make any required changes.

This time the cut and fill volumes are smaller and more closely balanced.

Note how the entire lower end of the road has now moved in ‘Plan 1’. Also in the ‘Perspective 2’, you will 
now see the open channel v drain running through the areas of cut.  In the areas of fill, the drain will blend 
into the final fill slope.

At the end of the calculation, the revised cut, fill and balance volumes appear in the message line.

In the ‘Left template’ field select the FULL 
LEFT W TABLE DRAIN template.

In the ‘Right template’ selct the FULL RIGHT 
W TABLE DRAIN templete

As we have modified the length of the road by 
makes the various changes, we need to update 
the End Chainage.  You can either type the 
new chainage in or use the measure icon to pick 
the new chainge from the plan view.

When complete, reapply the function with the 
new templates by clicking LB on Apply then 
Finish
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Your overall screen layout should now look as follows

Now profile the invert of kerb string to confirm that the road now lies above the services.

From the View Button Area of ‘Section LS’, click LB on Profile and LB on the iokr string from ‘Plan 1’ 
view. You may have to zoom to pick the right string 

Clearly the road now lies above the services.

Finally click LB on Save & Finish in the Alignment Edit panel. Click LB on ‘Yes’ to confirm
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16 Using 12d on Typical Projects Involving Volume Calcs 

16.1 General Cut and Fill Calculations
12d has many features that enable accurate cut and fill calculations to be performed. The easiest way to
manipulate data for volume calculations is via surfaces (i.e. TINs). For instance, a simple way to calculate
the cut and fill volumes on an earthworks project is to create a TIN of the natural surface and a TIN of the
finished design surface and get 12d to calculate the volume between the TINs.

We will now demonstrate how to do this with a practical example - designing a pad footing for a
commercial building.

16.2 Pad Footing Design Prerequisites
Note that if you are jumping to this Chapter of the Training manual rather than working through it
sequentially, the only prerequisite for this Chapter is that the TIN ‘natural surface’ must already exist. This
TIN was created in Chapter 6.3. All other data related to Pad Footing design is created from scratch.

Alternatively, you can import the 12da ascii file Chapter 16.12da  which contains all the models, strings
and tins created to date.

16.3 Pad footing Design using the Interface Function
The Interface function is the simplest form of geometry construction within 12d Model. Generally, it is
applicable whenever the batter lines are at a constant slope from top to bottom (no benching) and the
constant slope applies in all directions (i.e. a constant batter slope at right angles to the alignment string).

The definition of our pad footing is started in a similar manner to our earlier road design, by constructing
an alignment string corresponding to the shape of our pad footing. We will begin with a pad footing shaped
in plan as shown below.

9.999 40

15

20

30

25

40

A B

CD

EF

G H

We will generate this string in order 
A,B,C,…H. The reason we do not start 
at a corner r is so that we can insert 
curves at the corner IPs later. Curves can 
only fit between adjacent tangents.

Also to avoid confusion when snapping 
to the start and end points, we will leave 
a small gap of 0.001m between points H 
and A.
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Begin generating the pad footing outline from the Main menu by clicking LB on

Strings=>Create=>Alignment=>Alignment

The Create Alignment String panel will appear.

You have just entered a valid point in space corresponding to point A on our pad footing outline. Note that
a red rubber band is now connected to the cursor. We could now enter the next point via the mouse or
several other means.

We will supply the remaining coordinates of each point on the pad footing outline by entering relative 
movements (to the last point placed). To enter the second point just start typing ‘r 40 0 0 as shown below. 
Alternatively, we need to tell 12d we are using typed input again. Place the cursor anywhere in the ‘Plan 1’ 
view and press the RB. From the ‘Pick Ops’ menu that pops up, click LB on ‘Typed input’ again.

This is a relative movement from the last point of 40 in X, zero in Y and Z. 

Don’t be concerned about the rubber band joined to your cursor whilst you are doing this. It may appear to 
be in the wrong place at times whilst you are selecting items from menus etc.

Fill out the panel as shown.

These settings tell 12d that the pad footing outline is
be called ‘footing edge’ and is to be placed in a new
model called ‘BUILDING PAD’.

Click LB on Create and the Alignment Edit menu
will pop up. Move it out of the way if necessary.

We will initially define the horizontal geometry of the pad footing. From
the Alignment Edit menu, click LB on Append=>HIPs.

Now place the cursor anywhere in the ‘Plan 1’ view
and start typing as shown below. Alternatively, you can
press the RB to pop up the ‘Pick Ops’ menu and click
LB on ‘Typed input’.

Note the XYZ entry panel pops up with the cursor already locked into
the data entry field.

Type the following coordinates with a space between each
number. Terminate data entry by pressing the Enter key.

Type the numbers shown, each separated by a space, followed by 
the Enter key.
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We need to repeat this sequence multiple times. Remember to terminate each line by pressing the Enter 
key.

r 0 -15 0

r -20 0 0

r 0 -25 0

r -30 0 0

r 0 40 0

r 9.999 0 0

After the last line is entered, press <Esc> to terminate the creation process (or click RB to pop up the ‘Pick 
Ops’ menu and click LB on Cancel).

To see the string you just created zoom in on the pad footing area as shown below.

We will now insert small radii at each IP to ensure smooth curves between tangents. This will ensure that 
the finished earthworks have a satisfactory appearance.

From the Alignment Edit menu, click LB on Curves=>Radius

Click LB on any one of the six corner IPs and confirm the selection with the MB. In the ‘New radius’ panel 
that pops up, place the cursor in the data entry field, type the value 3 and then press the Enter key. This will 
insert a radius of 3m between the tangents that meet at the intersection point.

The screen Message box is still advising

<Select point to change radius>[picks][][Menu]”

Now just repeat the process by clicking LB on each of the other five points in turn, clicking MB to confirm 
the selection and typing the radius of 3, or by using fast picking, clicking MB on each of the other five 
points in turn and typing the radius of 3.

You do not need to leave the Alignment editor after you have completed this operation. 

If you do terminate the editor, you need to click LB on Finish to make your changes permanent or click LB 
on Quit to cancel any changes that have been made.

If after leaving the Alignment Editor you need to reactivate it, you can quickly start the Editor again by 
picking function key 6 (F6) to bring up the panel ’Edit String’ (or by clicking LB on Strings=>Editor), 
pointing to the alignment string and clicking LB to select and MB to confirm the selection.
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The curves you just entered should now appear as shown below

.

Now place the cursor in the ‘Plan 1’ view inside the pad footing and note that the Z values range from 
about 63 to 67. To roughly balance cut and fill let us make an initial guess to set the pad footing at height 
Z=64. 

Click LB on Finish to terminate the Tin Height Inquire panel.

We now need to select a Section view for the purpose of displaying our pad footing string in profile. We 
will use our ‘Section LS’ view. From the View menu of ‘Section LS’, click LB on Profile and then click 
LB on the red string in Plan 1 corresponding to our pad footing outline. Click MB to accept the highlighted 
string

.

Note that the ‘Plan 1’ and ‘Section LS’ views are now linked. If you move the cursor left-right in the 

We now need to define the vertical 
geometry of our pad footing. Firstly, 
we need to get an idea of the 
approximate Z values to be used for 
our pad footing elevation.

From the Main menu, click LB on 
Tins=>Inquire=>Height and the following panel pops 
up. 

Click RB in the ‘Tin’ field and click LB on GROUND 
from the pop up list.
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‘Section LS’ view the corresponding position in the ‘Plan 1’ view is marked with a yellow cross. 

Also observe the View Coordinates Box at the bottom of the screen. When the cursor is in the ‘Section LS’ 
view, the message box shows chainage and height (e.g. ch=72.541 ht=64.929). 

Note that the extremes of the profiled string range from chainage 0 to about 172. Thus to ensure that the 
entire string has defined vertical geometry, we will start at chainage -10 and finish at chainage 180. Seeing 
as the whole string is to be set horizontally at Z=65, we only need two points to define the vertical 
geometry.

From the Alignment edit menu, click LB on Append=>VIPs.

Place the cursor anywhere in the ‘Section LS’ view and start typing.

This should have placed a point at chainage -10 (i.e. before the start of your ‘footing edge’ string) and it 
should now be rubber banded to your cursor. To place the final point place the cursor anywhere in the 
‘Section LS’ view and start typing 

To terminate the string entry process, press <Esc> (or click RB to pop up the ‘Pick Ops’ menu and click 
LB on Cancel). 

Refresh the ‘Section LS’ view by clicking MB in the View Button Area. You should now see a red 
horizontal line on your Section view.

You should already have your grid lines turned on to assist in the evaluation of your decision making.  
However we need to change the horizontal spacing to get a better idea of the vertical geometry.

Type the numbers shown separated by a space, followed by the 
Enter key.

Type the numbers shown. Again terminate data entry with the 
Enter key.
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Your ‘Section LS’ view should now look as follows. The red line corresponds to your ‘footing edge’ 
string.

In the ‘Section LS’ View Button Area click LB on Menu to 
put up the View menu. Click LB on Settings=>Grid. The 
Grid settings panel will appear

Click LB in the ‘grid draw’ tick box to turn the grid ON.

The current ‘grid y’ setting is 10. Lock the cursor into the 
‘grid y’ field with LB and use the Backspace key to set the 
value to 1.

Click LB on Set to activate the new setting. 

Click LB on Finish to terminate the panel.
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To see how the pad footing aligns with the natural surface, click LB on the ‘+’ sign button in the ‘Plan 1’ 
view and double click LB on tin GROUND. From the View menu for ‘Plan 1’, click LB on Toggle=>Tin 
contours. Your view should now look as follows

From the Alignment Edit menu, click LB on Save & Finish and Yes to confirm the completion of all edit 
operations.

From the Main menu, click LB on Utilities=>H-Z=>Rotate. The Rotate Model panel will appear.

Let us assume that it is important to have 
side BG aligned as closely as possible with 
the natural surface contours. 

To achieve this we will rotate our pad 
footing clockwise by 40 degrees about 
point B (top right corner) so that side BG 
is close to parallel with the natural surface 
contours in the vicinity of point B.

It is important to note that we must 
shutdown the Alignment Editor before we 
can perform the rotation (the Alignment 
Editor locks the strings open in the 
database. We need to shut the open 
database before we can perform any 
operation on it such as a string rotation). 

 Point B Point G

Click LB on the string data source icon 
then select the building pad string from 
the view.

Click LB on the Rotation Centre 
icon and select point B

Set the rotation angle to 40 degrees 
clockwise

Click on the Replace existing data target 
icon 

Click LB on Rotate to activate the 
rotation.

Click LB on Finish to terminate the panel.
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Your ‘footing edge’ string should now appear rotated. 

To centralise the pad footing in the ‘Plan 1’ view, click LB on Pan and press down LB in the centre of the 
building pad and drag it to the centre of the view. Release LB and press <Esc> to terminate the Pan.

Your revised ‘Plan 1’ view should look as follows

We will now translate the ‘footing edge’ string +20m in the X direction and -30m in the Y direction to get 
our pad footing away from the valley and more onto the ridge of the natural surface contours.

From the Main menu, click LB on Utilities=>H-Z=>Translate. The Translate Model panel will appear.

We could select the string as the Data Source in the Translate panel as we did in the Rotate example but 
this time we’ll use the model Data Source to demonstrate how it works.

Click LB on the String data source icon. 
Pick and accept the footing edge string.

Type in the ‘Delta X’ of 20

Type in the ‘Delta Y’ of -30

Type in the ‘Delta Z’ of 0

Click on the Replace existing data target 
icon 

Click LB on Translate to activate the 
settings. 

Click LB on Finish to terminate the panel.
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Your ‘footing edge’ string should now have moved downwards and to the right. 

To centralise the pad footing in the ‘Plan 1’ view, click LB on Pan and depress LB in the centre of the 
building pad and then drag the image to the middle of the screen. Release LB Click LB. 

Your ‘Section LS’ view should now look as follows.

Your revised ‘Plan 1’ view should look as 
follows.

To update your ‘Section LS’ view to reflect 
the revised geometry all you need do is 

click LB on Regen icon
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We can now have our first trial run to see how well our pad footing fits in with the existing natural surface.

From the Main menu, click LB on Design=>Apply=>Interface

The Interface Function panel appears.

Finally supply the name PAD INTERFACE to the “Model for interface’ field. The interface string 
corresponding to where our batter lines meet the GROUND TIN are placed in model PAD INTERFACE. 
(Optional) Slope lines are placed in model PAD SLOPE LINES.

To cause the interface string to be calculated click LB on Interface.  After a short delay, the panel message 
box advises ‘finished interface’. Click LB on Finish to terminate the panel.

We will now observe a very powerful design feature of 12d Model. We will make some major changes to 
our pad footing and see how quickly 12d can redo its calculations with a minimum of effort.

First, we will change the shape of our alignment. Remember that we rotated our pad footing 40 degrees. 
We will now change point D by moving it 10m towards point C. Because of the rotation, line D-C is at a 
bearing of 130 degrees.

We need to give our interface function a name so that we 
can refer to it later. Type in the name PAD1.

Select the pad string as the ‘String Interface’

The default ‘Section separation’ is 10 metres. Set this to 
2 metres.

As our pad ‘footing edge’ string has been generated in a 
clockwise manner (from starting point A to B to C etc.), 
we are looking to calculate the intersection of our batter 
lines with the GROUND TIN on the left of the string 
(left as we proceed in a positive direction along the 
string. Positive direction is always in the direction of 
increasing chainage).

Click LB on the ‘Tin’ button and double click LB on 
GROUND from the popup list.

You will not see any immediate change in 
your ‘Plan 1’ view until you turn on the 
appropriate models that have been created 
by the interface function.

To see the interface that has been 
calculated, click LB on the ‘+’ sign button 
in the ‘Plan 1’ view to pop up a list of 
models. Double click LB on models PAD 
INTERFACE and PAD SLOPE LINES.
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We need to get the Alignment editor up again. From the Main menu, click LB on Strings=>Editor or just 
push F6. Place the cursor over the red alignment ‘footing edge’ string and click LB to select and MB to 
confirm the selection. The Alignment Edit menu appears

Note that the information in the ‘Plan 1’ view now shows the ‘new’ position of the ‘footing edge’ 
alignment string but still displays outdated versions of the batter strings and the interface string. 

To update these strings so that the view is correct, we need to reapply our interface function.

The easiest way to do this is to go to Utilities => Recalc =>  Recalc => PAD1.  12d will now recalc the 
pad interface using the same properties set in the Interface Function panel previously.

Click LB on Move and place the cursor over Point D and select it with LB. 
Confirm the selection with MB.

You will notice that the point is now attached to the cursor and can be readily 
moved via the mouse. 

To position the point exactly we will use a special version of typed input to 
define the new location of Point D. Place the cursor anywhere in the ‘Plan 1’ 
view and press the RB. From the ‘Pick Ops’ menu that pops up, click LB on 
‘Typed input’.

Type in the following values 
followed by the Enter key. 

This defines the movement in terms of 
‘bearing and distance’. In plan, we are 
moving the point (relative to its existing 
location) 10.0m along a bearing of 130 
degrees whilst maintaining a Z value of 
65.0. For a more full description of this 
data entry facility, see ‘X Y Z Typed 
Input Box’ in the Tools and Concepts 
chapter in the 12d Reference manual.

It is important at this stage to shut down 
the Alignment Editor as one of the 
subsequent move operations requires 
the database to be closed. 

From the Alignment Edit menu, click 
LB on Save & Finish to close edit 
operations on the ‘footing edge’ string. 
The ‘footing edge’ string should now 
look as shown at left. 
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You should now see your ‘Plan 1’ view updated as shown below.

To update your ‘Section LS’ view again to reflect the revised geometry all you need do is click LB on 
Regen icon. Your ‘Section LS’ view should now look as follows.

Note the ‘red’ line, the profiled string, is at Z=65.

For the next operation to succeed, it is essential that the string database is closed. If the Alignment Editor is 
still operational, i.e. the Alignment Edit panel is still visible, click LB on Save & Finish to shut it down.
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By reference to the ‘Plan 1’ view, it is apparent that our first guess at Z=65 for our footing is a little too 
high. Let us now lower this to say Z=64.5 to increase our cut and reduce our fill at the site. To do this, we 
only need do the following.

We can use the Translate option as before using Utilities=>H-Z=>Translate

or from the Main menu, click LB on Strings=>Strings Edit=>Translate

Place the cursor over the ‘footing edge’ string and select it with LB. Confirm the selection with MB. The 
entire string is now translated to be at height Z=64.5.

The Translate String panel appears.

Click LB in the ‘Move/Copy mode’ choice icon and 
click LB on Move.

Place the cursor in the ‘Translate mode’ field and click 
LB on the choice icon to popup a list of modes. Click 
LB on Typed dx dy dz.

Place the cursor in the ‘x y z’ field and type 0 0  -0.5 

Click LB on Start. 
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To update your ‘Section LS’ view again to reflect the revised geometry all you need do is click LB on 
Regen. Your ‘Section LS’ view should now look as follows.

To recalculate our interface string (again), we reapply our interface function as before.  Rerun the function 
PAD1 from the Recalc menu (see Utilities=>Recalc)

You should now see your ‘Plan 1’ view 
updated as shown at left.

Note that the area of cut (red) is now 
increased and the area of fill (green) is 
reduced. 
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16.4 Volume Calculations from Surfaces Created with the Interface Function.
Now that we have batter, alignment and interface strings, it is a simple matter to create TINs of our 
finished design surface and subsequently calculate volumes.

16.5 Creating a TIN of the Finished Quick Pad Footing Surface
To ensure that only the correct strings are used in the creation of our finished TIN, the first step is to turn 
OFF all models and then selectively turn ON the appropriate pad footing strings and sections models.

The fastest way to do this is to click LB on the Menu button in the View Button Area of the ‘Plan 1’ view 
to popup the View menu and click LB on Models=>Remove all models. Then place the cursor over the 
‘+’ sign button in the ‘Plan 1’ view and double click LB on BUILDING PAD, PAD INTERFACE and 
PAD SLOPELINES. 

Since these are the only models on display in View ‘Plan 1’, we can confidently build our TIN by 
triangulating the view.

From the main menu, click LB on Tins=>Create=>Triangulate data

Give the triangulation the function name tin PAD

Position the cursor in the ‘New tin name’ field and 
type in ‘PAD’ and press the Enter key. This name 
will also be used to fill in the ‘Model for tin’ field 
but with the prefix ‘tin ’. 

Click LB on the colour icon and select ’orange’.

Click on the Data tab and set the ‘Data to 
triangulate’ to View 1.

Click on the Nulling tab. To ensure that the pad 
TIN is restricted to within the bounds of the 
interface string defining where our pad footing 
intercepts the natural surface, click LB on the ‘Null 
polygon’ button and select with LB the red-green 
closed ‘interface string’ surrounding the pad 
footing. 
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16.6 Volume Calculations Between Surfaces
Now that as we now have two TINS, ‘GROUND’ and ‘PAD’, we can get 12d to calculate the volume 
between the TIN surfaces. 12d provides two methods of calculating such volumes:

End Area: Here parallel sections are taken at a constant user defined angle from the X axis (angles are 
measured anticlockwise from the X axis) with sections a user defined distance apart. When calculating end 
area volumes, the quality of the answer is highly dependant on the values chosen for the angle of the 
sections and the distance between sections.

Exact: In this method exact volumes are calculated by summing the volumes of the various ‘prisms’ 
between the triangulated surfaces. This method is ‘exact’ in that it is as accurate as the TINs themselves. 
Depending upon the overlap between ‘triangles’ in each TIN, each triangle may be split up into multiple 
prisms. All prisms are accounted for hence the term ‘exact’.

We will use both methods and compare any differences.

Make sure that the string you select has the correct string name ‘interface’ 
and is of type ‘interface’ as shown in the panel at left. If necessary, keep 
clicking LB until you get this string. Once you have it, click MB to confirm 
the selection.

Then click LB on Triangulate to create the TIN.

To display the TIN, click LB on the ‘+’ sign button in the ‘Plan 1’ view and 
double click LB on tin PAD from the pop up list.

The TIN on the view will currently be displayed with contours and not 
triangles

To see the triangles, click on the toggle icon and turn off ’Tin contours’. 

The finished TIN should appear as shown below. 

Note that by using the ‘Null 
polygon’ feature, any 
triangles that might have 
formed outside the interface 
polygon have been ‘nulled’ 
(effectively removed) from 
the TIN. Whilst such 
triangles may or may not 
exist, they are of no 
consequence to the user. 
Only those triangles on 
display will participate in any 
subsequent TIN or volume 
calculations.
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16.7 End Area Volume Calculations
To enable string selection to be easier, first turn off Pad TIN. Click LB on the ‘-’ sign button in the ‘Plan 1’ 
view and double click LB on tin PAD from the pop up list.

To calculate volumes between TINs using end areas, from the Main menu, click LB on 
Design=>Volumes=>End Area=>Tin to tin

 A closed polygon can be defined to restrict the extents within which the calculations will be performed. If 
a string is selected that is not closed then the first and last points of the string are automatically joined to 
form a closed polygon.

We can use the ‘interface polygon’ for this purpose i.e.use the string which is the intersection of the pad 
footing with the existing ground. Click LB on the Poly icon then select the string icon. Select the red-green 
interface polygon in the ‘Plan 1’ view with LB. Confirm the selection with MB.

By entering a name in the ‘Report file’ field, a report can be created showing the details of the end area 
volumes. Enter PAD VOLUME and press return. The suffix .rpt is appended by 12d. Set the report mode 
to summary as we don’t need to see the volumes for each section. This would only be used if an alignment 
is used for the section creation. 

Click LB on Volume to cause the end area volumes to be calculated. 

If a name is entered in the ‘Report file’ field, 12d will immediately jump to the Editor and display the 
report. A sample report is shown on the following page. Click LB on File=>Exit to terminate the Editor 
and return to 12d.

Note that once the calculation is finished, the Cut, Fill and Balance volumes are displayed in the Panel’s 
message line. 

Click LB on Finish to terminate the panel.

Fill the panel in as shown. Place the 
cursor on the tin icon for the ‘Original tin’ 
field and click LB to popup a list of the 
available TINs. Double click LB on 
GROUND.  Repeat the process for ‘New 
tin’ and set it to PAD

Leave the angle for sections at 90 degrees. 
This will make the sections at 90 degrees 
to the X axis i.e. parallel to the Y axis.

Set the ‘Distance between sections’ to 2m 
as this is a relatively small site.

Enter three new model names - XS 
GROUND, XS PAD and XS DIFF for 
‘Original’, ’New’ and ‘Difference’ 
sections respectively. The cross sections 
corresponding to each of these profiles 
will then be stored. Entering a name in the 
‘Difference model’ causes a series of 
sections to be created that correspond to 
the difference between the Original and 
Final cross sections. Note that all these 
model fields are optional.

Set the Difference colour to magenta.

Tick the checkbox to clean out the section 
models before running the option
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NOTE: We used a polygon for the End Area volumes but a polygon does not have to be used. If no 
polygon is used then the volume calculations are restricted to the regions where both TINS exist.

It is possible to view the sections that were calculated during the end area calculations. 

From the View Button Area of the ‘Plan 1’ 
view, click LB on the ‘-’ sign button and 
turn off model tin PAD and then click LB 
on the ‘+’ sign button and turn on model 
XS GROUND.

Note that the various cross section strings 
display in green.

We can now profile any of these cross 
section strings. We will use view ‘Section 
XS’ for this purpose. 

Section 23 
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From the View Button Area for the ‘Section XS’ view, click LB on Profile and then click LB on section 
‘23’ as shown. Click MB to confirm the selection. 

The following view shows the profile of cross section no ‘23’. 

In this view the XS PAD model has also been turned on. Hence the section shows both the original 
sections (from TIN ‘GROUND’) and final sections (from TIN ‘PAD’). The area between these two 
strings is a typical section used in the end area calculations. Note that it has both cut and fill.

The view has been created with a vertical exaggeration of ‘5’. A grid (10m horizontal by 1m vertical) has 
been overlaid on the view to assist interpretation. This section will now be used to demonstrate what the 
difference model is. Observe the typical Z values.

Place the cursor in view ‘Section XS’ and note the chainage and height values displayed. The Z values 
shown are the real world values. At any one chainage across the section it is possible to subtract the Z 
value of the ‘PAD’ TIN from the Z value of the ‘GROUND’ TIN. If the resulting Z difference was plotted 
on the same section, a view as shown below results. This is the ‘difference model’ of sections. 

The following view was created by turning on model XS DIFF in the ‘Plan 1’ view and profiling the 
difference sections string at section ‘23’ from the ‘Section XS’ view. Note that when doing this it is best 
to turn off all models in the view ‘Section XS’. Click LB on Fit to fill the view.

Note that the grid now displays the difference model Z values. If you now place the cursor in the ‘Section 
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XS’ view and observe the typical chainage and height values displayed in the XYZ message bar, the values 
are centred around Z=0. Thus in a Section view it is not meaningful or possible to display the model of 
difference sections together with either the original sections or final sections models. 

The ‘difference model’ is a cross section schematic where a positive Z ordinate represents cut and a 
negative Z ordinate represents fill. The datum for change from cut to fill is at Z=0.

16.8 Exact Volume Calculations
Now go back to the ‘Plan 1’ view and turn off the model XS DIFF.

 The only models that should be turned on in the ‘Plan 1’ view are BUILDING PAD, PAD SLOPE 
LINES and PAD INTERFACE. Click LB on Fit to fill the view.

To calculate exact volumes between TINs, from the Main menu, click LB on 
Design=>Volumes=>Exact=>Tin to tin

Fill the panel in as shown. Place the cursor 
on the tin icon for the ‘Original tin’ field and 
click LB to popup a list of the available 
TINs. Double click LB on GROUND. 
Repeat the process for ‘New tin’ and set it to 
PAD.

By entering a name in the ‘Report file’ field, 
a report can be created showing the details of 
the end area calculations. Enter PAD 
EXACT and press enter. The suffix .rpt is 
appended by 12d. 

Click LB on the Poly icon and then select 
String icon. Select the red-green interface 
polygon in the ‘Plan 1’ view with LB. 
Confirm the selection with MB.

Click LB on Volume to initiate the 
calculation. The report will be calculated and 
immediately display. The following is a 
typical report
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Note the cut, fill and balance volumes display at the base of the panel.

Click LB on Finish to terminate the panel.

We used a polygon for the exact volumes but like the End Area volumes, a polygon does not have to be 
used. If no polygon is used then the volume calculations are restricted to the regions where both TINS 
exist.

16.9 Displaying ‘depths’ of Cut and Fill using Colour Shading
If the above exact volumes calculation is repeated but this time the panel is filled in as shown, it is possible 
to get the plan view to shade in with different colours corresponding to different depths of cut and fill. Set 
the TIN fields as shown
.

Now as the volumes are calculated, the ‘Plan 1’ view will have its various faces coloured in.

The red area displays cut and the green area displays fill. The darker shades show areas of greatest cut and 
fill.

Place the cursor on the folder icon for the 
‘Range file’ field and click LB to pop up a list 
of range files. Double click LB on 
depthroad.drf in the User Lib folder.

The ‘Plan view to paint’ should be set to 1

Enter the new model name DEPTH FACES 
in the ‘Model for faces’ field.

Click LB on Volume to recalculate the 
volumes. 
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This image can be exported or plotted as desired. When the data is transferred to AutoCAD, Microstation 
or another rendering package, the face data will be retained and hence can be manipulated further if 
required.

The quality of the finished image is a function of the number of ranges specified in the depthroad.drf file. 
Each range has a colour associated with it. This file is a normal ASCII file and can be edited with a text 
editor or from within 12d Model using the Depth Range File panel.

If you place the cursor near the name depthroad.drf, in the ‘Exact Volumes Between Tins’ panel, click LB 
on the folder icon to pop up the list of names again and then select [Open], the Depth Range File panel will 
pop up with the file displayed ready for editing.

The file can also be edited in the system text editor. If you place the cursor near the name depthroad.drf, 
in the ‘Exact Volumes Between Tins’ panel, click LB on the folder icon to pop up the list of names again 
and then select [Edit file], the 12d text editor will pop up with the file displayed ready for editing.

If you refresh the view you will notice that 
the shaded image disappears and the view 
reverts to whatever models you had turned 
on prior to performing the volume 
calculation.

As required, you can turn on model 
DEPTH FACES where you now have a 
permanent copy of the shaded faces. This 
model can be manipulated just like any 
other model in 12d.

The "From’ field is the ‘starting depth’ and 
the ’To’ field is the ’finishing depth’.

 Cut depths are negative.

If any modifications are made, then the file 
must be written out by clicking LB on the 
Write button.
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Important Notes:

1. If a depth range file is used then the reported volumes only included specified in the depth range file. 
So if the depth range file does not cover the entire range for the two tins, then the reported volumes will 
not equal be the total volumes between the two tins.

2. The depth faces do not have to be created. The plan view will still be coloured as the volumes are 
calculated but the colours will disappear when any part of the view is refreshed.

3. For the practise and smaller versions of 12d Model, the faces will need to be deleted before saving the 
project.

The format is ‘starting depth’, ’finishing depth’, 
’colour’. Cut depths are negative. Any colour can be 
used. For a full list of the colours available, see the 
colours.4d file. This file also is user definable. 
Terminate the edit session by shutting the Window [X] 
or choosing File=>Exit from the pull down menu. then 
click ‘finish’ to terminate the panel.
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16.10 Displaying ‘depth contours’ of Cut and Fill
To ensure that we can see the depth contours clearly after they are created, begin by turning OFF all 
models. Click LB on the Menu button in the View Button Area of the ‘Plan 1’ view to pop up the View 
menu and click LB on Models=>Remove all models. 

To calculate depth contours between the TINs, from the Main menu, click LB on 
Tins=>Contour=>Depth contours

Fill the panel in as shown. Click LB on the tin icon for 
the ‘Original tin’ field to popup a list of the available 
TINs. Double click LB on GROUND. Repeat the 
process for ‘New tin’ and set it to PAD.

Use the colour icon to pop up lists of colours and 
select the colours as shown. These colours are 
recommended since they are consistent with the depth 
ranges used above.

Set the contour interval to 0.25m

Click LB on Calculate to produce the depth contours. 
Click LB on Finish to terminate the panel.

To see the contours, from the View 
Button Area of the ‘Plan 1’ view, click 
LB on the ‘+’ add model button and 
turn on models DEPTH STRINGS, 
BUILDING PAD and PAD 
INTERFACE

These contours are valid 2d strings just 
like any other contours created by 12d 
Model and hence can be used further by 
12d, plotted or exported to a CAD 
system as required.
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16.11 Comparison of ‘End Area’ verses ‘Exact’ Volume Calculations
In the above models, the end area calculation for balance of volumes was 317.535 m3 verses 317.742 m3 
for the exact calculation, a negligible difference.

On a large site, you may notice a significant discrepancy between your answers from both these methods. 
Clearly, the end area calculations are the more important if you have to allow for mass haul considerations. 
In such case, try performing your end area calculations with a smaller ‘distance between sections’. Also try 
to orientate your sections at right angles to the major direction of cut/fill movement. These steps will 
minimise errors inherent in the end area method.

Finally it is possible to perform end area calculations such that all sections are at right angles to an 
arbitrary string, just as you would with template generated sections in normal road design. See 
Design=>Volumes=>End Area=>String Tin to tin for how to do this.

16.12 Sign Conventions for Cut and Fill
The entire tutorial on volume calculations so far has been performed assuming the convention that Cut 
volumes are negative. This is a user definable convention however.  If preferred, Cut volumes can be made 
positive.

This convention is set from the Main menu. Click LB 
on Project => Management => Defaults

Note the field near the bottom of the panel. 

Place the cursor on the choice icon for the ‘Cut volume 
sign’ field and click LB to pop up a list of alternatives. 
Click LB on either positive or negative. At this time, 
leave the value negative.

Click LB on Set to activate any changes.

Click LB on Finish to terminate the panel.
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16.13 Traps to be Wary of When Designing Footings
1. Treatment at corners when radii are NOT being used

The example above used a fillet radius at each corner point on the ‘footing edge’ alignment string. If you 
don’t use a radius at each IP point that involves a change in direction (such as at a corner), the interface 
string created during the template application will, by default, not generate any extra points at the change 
in direction. 

This causes the following effect at a 
corner point (section strings are shown).

This situation can be changed by 
specifying a ‘corner angle’. If say a corner 
angle of 15 degrees is used, you will get 6 
facets at a right angular change in 
direction rather than 1.

The corner angle value is set from the 
main menu by clicking LB on Project => 
Management => Defaults (Default 
Settings tab). See fifth item from the 
bottom of the panel.

Change the ‘Corner angle’ to 15 degrees as shown. It 
normally defaults to zero. 

If the Interface was recalced, the corner would now 
appear as below
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2. Internal angles

The solution to this problem is to choose appropriate batter slopes and return angles such that this does not 
happen. 

Alternatively, before you create your TIN you may have to edit the offending strings and take out the 
overlapping portions and also delete the incorrect sections.

When an alignment string suffers 
excessive changes in direction such as 
when the internal angle gets to be less than 
90 degrees, it is sometimes possible to get 
the situation where batters ‘cross’ over 
one another. 

Observe the shape of the interface string - 
beware of this effect. If you calculate 
volumes from such strings, you will 
clearly get erroneous answers.
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17  Plotting

17.1 Overview
This chapter is arranged so that relevant sections appear in blocks for easy reference.

The layout of this chapter is as follows:

Chapter 17.10 relates to long section plotting.

Chapter 17.12 relates to cross section plotting.

Chapter 17.14 relates to plan plotting using plot frames.

For user convenience, each plotting section is self contained (requiring some duplication).

The data used for the plotting has been built up by working through the Getting Started manual. If you 
have not worked through the Getting Started Manual to this point then, you can import the 12d Ascii file 
Chapter 17.12da, which will bring you up to this point.

17.2 Triangulating the Road

Create the TIN ‘DESIGN’ for the road by 
turning all the models off the view ’Plan 1’ 
and adding just the ROAD 1 APPLY Sects 
and Strs models.

Create the TIN ’DESIGN’  using 
Tins=>Create=>Triangulate data with data 
source View and view ’Plan 1’.  When you 
create the road design using the Apply 
function, 12d also creates a number of 
polygons that capture the various elements. 
You could use the polygon that encases the 
road as your ‘Null polygon’ or alternatively 
you can set the 'Length’ field to 1m and 12d 
will null out all the triangles outside the 
interface strings. 

In order to calculate the volumes and display the quantities in the long section plots we need to create a 
surface of the road. 

PRACTISE VERSION: To keep the number of points below 5,000, the road data has been created with 
sections at a 25m interval rather than 5m. This means that the pictures are not exactly as they appear in the 
manual when running with the Practise version.
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17.3 Plot devices
12d can generate plots to various devices. Firstly, it supports a full interface to Windows so it can create 
plots on any device that is supported by Microsoft Windows. 

Finally, we also talk about ‘plotting to a model’ so one of the plot device types is ‘model’. This is a 
technique for previewing a plot. See Chapter 17.6 below for more information on ‘Previewing plots’.

All of this customisation of the available ‘plotter types’ is implemented via the plotters.4d file which is 
documented in the 12d Reference manual in Appendix N, ’Plotters and Plotting’. 

12d also supports various popular plotting devices in their 
native format so it can plot directly to Hewlett Packard pen, 
inkjet and laserjet printers/plotters. 12d supports Postscript, 
HPGL2 and PCL5 plotters directly and plotters that emulate 
these devices.

We also talk about the concept of ‘plotting to CAD’ where we 
treat CAD as just another plot device. This process generates a 
native CAD file which can subsequently be read in by your 
CAD system, manipulated further if required and then plotted 
from your CAD system. We can plot to AutoCAD 2007 (DWG, 
DXF or DXB) or Microstation V8 (DGN).

The list on the left shows the standard ‘plotter types’ available 
for 12d users. 

When selecting a device type to plot to, the popup list of 
‘plotter types’ available is customisable so the list can include 
line items such as ‘Mary’s inkjet – 2nd floor’. You could 
remove line items or plotter types that are irrelevant to your 
organisation. 

When transferring your 12d data to CAD, the list can also have 
multiple line items that further customise the transfer. For 
instance, when you pick ‘DXF 2007’ (the default transfer 
mechanism), data is transferred to AutoCAD such that colour 
numbers are maintained. As colour 2 in 12d is green but colour 
2 in AutoCAD is yellow for instance, you will see colour 
changes when you transfer data to AutoCAD without 
customisation. 

One of the line options typically implemented is ‘DXF 2007 
ACD colours’ so that green in 12d stays as green when 
transferred to AutoCAD, etc. 

Another line item might be ‘DXF 2007 Check plot’ so that all 
colours in 12d transfer to AutoCAD with one colour (for one 
pen).

Another line item could be ‘DXF 2007 Customised transfer’. 
This is where you decide that red lines in 12d such as cross 
sections are always to become green lines in AutoCAD because 
your current CAD standard is that green lines always plots as a 
0.25 pen and you want your cross sections to always appear 
0.25 wide.
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17.4 General Plotting Issues
Plot parameters:

The appearance of finished plots is user definable. There are a large number of plot parameters that govern 
what is included on the plot and how it appears. Plots are created from plot parameter files (known as ppf 
files). Each parameter has a default value so that even if you perform a plot without supplying a ppf, you 
will still get a plot. Part of the customisation of 12d is deciding which parameters you require to achieve 
your drawing standard. Once the standard is achieved you will find that you can use the same ppf files 
from job to job with minimal or no changes. One advantage of this approach is that regardless of the skills 
of the operator, a common presentation standard of plotted documentation is achieved.

The training data gives you samples of typical ppf’s to achieve common engineering standards for plan, 
long and cross section plots. It is recommended that users new to 12d take a copy of these and use them as 
a starting point for their own customisation. 

Text:

Whilst some plotting in 12d is (What you see is what you get), 12d will in general adopt final sizes for text 
that are different from what you see on your screen. Text that is just large enough to be read on your screen 
would be much too large when plotted on say an A1 sheet. Thus all text on the screen has a default size and 
probably a different default size when plotted to a device. The size of plotted text is typically set in a ppf 
file as discussed above. Once this is set for a particular users corporate standard and sheet size, it rarely 
needs changing so is largely transparent to the user.

For screen text that has no plot parameter equivalent defining it’s plotted size, there is an overall governing 
parameter that relates screen text to plotted text. This parameter is set from Plot => Plotting Setup => 
Pixels to mm. You can set this as you require. The default value is 0.5. This means that screen text that is 
say 10 pixels high will plot at 5 mm high.

Text that is created in paper units don’t require any editing prior to plotting. To ensure the text appears at 
the same size as the proposed plot we change the Plot scale to the required value to match the final plot

To set the plot scale select the Menu icon in the relevant view and then select Settings=>Plotting scale

When plotting direct from 12d to a plot device such as an inkjet printer, it is possible to map 12d colours to 
pen (line thickness) size. 

Fonts:

12d supports most AutoCAD .shp files as well as Windows True Type fonts. The standard install supplies 
you with sufficient fonts to get started – typically ISO, ISOEQ, GOTHIC, HELV, HELVL, MONO, 
ITALICC, SCRIPT, ROMANC and ROMANS. See files textstyl.4d and fonts.4d for more information.

Type in the plot scale required
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Plot files and queues:

In general, whenever 12d creates a finished plot file for a hard copy device, it will only place the file in the 
local project folder (one level up from the .project folder). The exception to this is when plotting to the 
Microsoft Windows interface. In such case Windows takes over the control of the file and sends it to the 
device automatically. 

Thus in general, plot files are not automatically submitted to any plot queue. It is the users responsibility to 
then place the plot in an appropriate queue, decide when it will be plotted, decide on the number of copies 
etc. 

It is possible to have Windows run a background batch file that will automatically place any plot files in a 
plot queue.

Similarly, when the plot device is a CAD system, the CAD file will be written to the local project folder. 
After writing the CAD file, the user can then issues an Alt-Tab command to transfer Windows control from 
12d to their CAD system, and then opens the file.

17.5 Windows Based Plotting
In the list of ‘plotter types’ shown above, there is windows and windows_mono. These devices interface 
directly with Microsoft Windows (version 98 onwards). This allows you to plot direct to any Windows 
device on the network. All plot queue issues are handled direct by Windows. The plot file is deleted at the 
end of the plot.

17.6 Previewing Plots
To save wasting paper, we strongly recommend that all plots be previewed before sending them to their 
final device. 

We do this by writing the plot file to a model which is stored in the normal 12d database just like any other 
string data. As plot files are simple 2d files in an X-Y plane, such data is readily displayed in any plan 
view. We can then preview the plot in any Plan view by turning on the model of plotted data. The units 
used for plot files in 12d are the industry standard units for plotting - millimetres. For this reason it is 
important that you turn all other models off when previewing plot files. If you don’t, your plot may well be 
mixed in with real world coordinate data. This will make the plot appear very small and probably in the 
extreme lower left corner of your screen, near the origin.

It is possible to do a ‘plot of a plot’. This is sometimes useful when you want to make minor changes to 
(say) a long section plot, maybe add some new text. Remember that all plots are in millimetres so that if 
you add text to such a plot, you do it at full size. Create text 5 high if you want it to plot at 5 mm on the 
finished sheet.

After doing such changes, you then click LB on Plot=>Plot from the View Title Area. In the Scale 1: field, 
type in 1000. This will keep your second plot in millimetres. If you then preview the second plot, you 
should see the final plot with the changes implemented. To then reissue the final plot, simply change the 
Plotter type to the desired device and reclick the Plot button.

If after doing a plot, you decide that you need to change something and redo the plot, it is important that 
you clean out the old plot before you reissue the plot command again. The reason for this is that 12d just 
treats plot data like any other data in the database. Plots can be cleaned by simply ticking the relevant 
check box at the time of creating the plot. See Chapter 17.12.2 and Chapter 17.14.4 for managing 
previewed plots for cross and plan plots respectively.
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17.7 Overview of Plotting
We will look at six of the many types of plots available.

1. Quick Plan plots

2. Quick Section plots

3. Quick Perspective plots

4. Sheets of Long Sections

5. Sheets of Cross Sections

6. Sheets of Plan plot frames

Each of these plot types will now be discussed in detail.

Apart from these six plot types, there are also others such as Drainage plots, Sewer plots and Pipeline plots 
which will not be discussed in this Chapter.

To preview our plots in 12d Model we need a Plan view that is not displaying any data. Before continuing, 
create a new one with the name ’Preview’ using View=>Create=>Plan view.

We will use view ‘Plan Preview’ for the purpose of previewing plots.

17.8 Quick plots
The key purpose of these type of plots are for occasions where the scale of the plot is less important than 
the contents. For example, if you needed to table a drawing at a meeting showing a certain detail, all that is 
needed is that you get the detail up on your screen and zoom in on it until you see the extents of your area 
of interest. You then create a plot and you will get exactly what you saw on the screen.

17.8.1 Quick Plan Plots
Before we start we need to get some standard data up on display. 

Ensure that in View ‘Plan 1’ just the models shown below are in the view:
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Your ‘Plan 1’ view should look as shown below. 

Zoom in on the intersection area as 
shown. Let us assume that this is our 
area of interest.

We will now plot the zoomed data on 
display in View ‘Plan 1’.

If you want the finished plot to assume 
the general shape of say, an A1 sheet, 
drag the edges of your view until the 
height/width ratio of the screen 
resembles the sheet i.e. wider then it is 
high.

From the View Button Area for View 
‘Plan 1’, click LB on the printer icon in
the view buttons area and select Plot. 
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Now go to View ‘Plan Preview’ and use the ‘+’ sign to turn on model preview quick plot.

Your finished plot should look as shown.

Firstly, ensure your POINT snap is ON. If you do a string inquire (F2) on the cyan string at the bottom left 
corner of the plot, observe the X and Y coordinates returned. The bottom left corner of the plot is at the 

Fill in the panel as shown. Make sure that the plotter 
type is model so that we can preview the plot.

Type in preview quick plot for the model name

Select prompt for clean as clean model mode

In the scale field, type 1000 and press the Enter key. The 
aspect ratio of the ‘Plan 1’ view will determine the sheet 
width and height returned. It is possible to type in any 
one of these three numbers and 12d will calculate the 
other two. For instance to fill an A1 sheet where you are 
not interested in the scale of the plot, type in a width of 
841. The easiest method is to use the rectangle option at 
the bottom of the panel to draw a rectangle around the 
data. Try to keep the proportions as close to a sheet of 
paper as possible.

By default, a simple title and border are created. Leave 
the box ticked and type in two lines of text as shown. 
These lines will appear at the bottom left of the plot, in 
the title box area.

Click LB on the Plot button.
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origin X=0 and Y=0. 

The point to note is that the plots are in millimetre units but when they are plotted to a model to preview 
and work with inside 12d Model, the plot data has been multiplied by 1000.0. Hence the 40mm title block 
was of size 40 units in the plan view, not 0.040 as you would first think.

.

17.8.2 Quick Section Plots
This is very similar to the Quick Plan plot we have just finished. 

We will investigate this facility by profiling our ‘ROAD 1’ centreline string in view ‘Section LS’. From 
the View Title Area of view ‘Section LS’, click LB on the Profile button and select the magenta centreline 
string on display in view ‘Plan 1’. Make sure you select the alignment string and not a 3d string. It can 
often be easier to pick the IP points rather than the string itself.

If you turn on the models for the pipes, survey SEWER PIPE 300 and survey WATER PIPE and ensure 
that your grid is still toggled on, then your section view should be as shown below.

Zoom in on the portion of the profile where the services cross under the road.
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You should now see the following. Note the services under the road. Also note that even though we asked 
for the vertical grid to be 1 m apart, the grid will only display in full at this separation when the view is 
uncluttered. If 12d thinks the view will be too cluttered when you are Zoomed out, it will only display 
some of the requested grid lines as seen above.

From the View Title Area of view ‘Section LS’, click LB on Menu=>Settings=>Geom annot

services

Note that you can set the screen text height 
in pixels independently of how the same text 
will appear in height on the finished plot.

Click LB on Set and Finish.
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We will now create the Section view plot. From the View Button Area for View ‘Section LS’, click LB on 
Plot=>Plot

Fill in the panel as shown. Make sure that the plotter type is model so that we can preview the plot.

Now go to View ‘Plan Preview’ and use the ‘-’ sign to turn OFF model preview quick plot and then turn 
ON model preview quick section.

Note that whilst the plot is in general, the plotted text may have a different height to that in the Section 
view.

Fill in the panel as shown. Make sure that the plotter 
type is model so that we can preview the plot.

Type in preview quick section for the model name

Select prompt for clean as clean model mode

In the scale field, type 500 and press the Enter key. 
The aspect ratio of the ‘Section LS’ view will 
determine the sheet width and height returned. It is 
possible to type in any one of these three numbers 
and 12d will calculate the other two. For instance to 
fill an A1 sheet where you are not interested in the 
scale of the plot, type in a width of 841.

By default, a simple title and border are created. 
Leave the box ticked. This time leave the Title lines 
blank.

We can set the textstyle to ISO to get the title text to 
appear with that font.

Click LB on the Plot button.
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If the plot is satisfactory, the user can send the plot to a device. Simply select an appropriate device from 
the plotter icon and then Click LB on the Plot button.

17.8.3  Quick Perspective Plots
This is very similar to the Plan and Section plots above. The Orbit, Joystick, String Drive or String Walk 
options can be used together with the Zoom options to establish the extents of what you can see. To get a 
plot of this is very similar to the above except with regard to the plot size. The plot size can only be 
established by trial and error.

To start off, just use any of the above tools to get some data on display in your ‘Perspective OpenGL 2’ 
view. In our case we turned on tin ‘DESIGN’ after doing a String Drive. Let us assume that this is the data 
we wish to plot
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.

Click LB on Plot=>Plot from the View Button Area of View ‘Perspective OpenGL 2’. 

Now go to View ‘Plan Preview’ and turn OFF model preview quick section and turn ON model preview 
quick perspective. Your previewed plot should look as follows.

In the ‘Plot file’ field, type in preview quick perspective.

Select prompt for clear as clean model mode

Note that the sheet width and height are already returned.

If your plot is too large, you need to reduce the physical 
width and height of your ‘Perspective OpenGL 2’ Window 
to make the plot smaller. Drag the margins of the view as 
appropriate.

After you have changed the size of the view, place the cursor 
in the ‘View’ field (after the 2) and press the Enter key. The 
sheet size will be updated.

Click LB on the Plot button to generate the plot.
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In view ‘Perspective OpenGL 2’ Toggle=>Shade. Your view should now look as shown.

If the plot was repeated, shading will now appear in the finished plot. In view ‘Perspective OpenGL 2’, use 
Toggle=>Shade again to toggle it OFF when finished. 

If the plot is satisfactory, the user can send the plot to a device. Simply select an appropriate device from 
the plotter icon and then Click LB on the Plot button.
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17.8.4  Quick Hidden Line Perspective
This is very similar to the Perspective plot above. This facility just allows you to create a hidden line 
perspective plot of any information that sits on the selected TIN.

From the View Button Area of View ‘Perspective OpenGL 2’, click LB on Menu=>Settings=>Hide.

Click LB on Plot=>Plot from the View Button Area of View ‘Hidden_perspective 3’ and repeat the 
process explained above to generate the plot. Instead of name preview quick perspective use preview 
quick hide as the name of the model. 

Select TIN DESIGN and tick the ‘Hide view’ tick box.

Click LB on Set and Finish.



12d Model Getting Started and Training Manual

Page 206 February 2007

Now go to View ‘Plan Preview’ and turn OFF model preview quick perspective and turn ON model 
preview quick hide. Your previewed plot should look as follows.

NOTE: Although we have only plotted the TIN on the hidden line view, we can actually add any data that 
sits on the TIN and hidden lines will be removed. The TIN itself does not have to be on the view.
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17.9 Plotting Using Plot Parameters
Often a higher quality plot is required than what the plots already described can produce.

This is especially true for long sections and cross section plots where many pages of plots are required and 
the layout includes large amounts of additional information such as the labelling of chainages, heights, 
depths, alignment geometry and services.

In early versions of 12d Model, the way more complex plots could be produced was controlled using text 
files called plot parameter files (ppf’s for short).

PPF’s consist of a large number of parameters and values which gives the user tremendous flexibility on 
the way the plots look but the disadvantage was that the PPF’s could only be created and modified using a 
text editor.

Since the release of 12d Model V6.0, new interactive PPF editors were introduced to allow the user to 
create and modify the plot parameters without needing a text editor.

This made the use of plot parameters more accessible to all users.

The interactive PPF editors store and edit information in a binary format which can’t be read by a text 
editor. 

17.10 Plotting sheets of Long sections
First you need a Section view. We will use view ‘Section LS’ to illustrate the plotting of long sections that 
involve multiple sheets. 

In your chosen view you need to profile the Alignment string that you wish to plot. Make sure that view 
‘Section LS’ has the ‘ROAD 1’ string profiled.

Also make sure that the vertical exaggeration of view ‘Section LS’ is set to [2]. 

In the View Title Area of view ‘Section LS’, click LB on Toggle=>Grid to turn the grid OFF. 

To run the ‘Long Section Plot PPF Editor’ either click LB on the Printer icon in view ‘Section LS’ 

Select Long plot
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Or by clicking LB on the Main menu option Plot=>Plot and PPF editors=>Long Sections. If this method 
is chosen then the Section view number is not be automatically filled in and must be given by the user.
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In the Plot parameter file box located at the top of the panel, LB click on the folder icon to bring up the 
folder choice box. 

Walk right on the User Library menu ([User Lib]) and select the 
file Long Sections.lplotppf by double clicking LB on the file name 
in the choice box. This file is a binary PPF file. Complete the 
sequence by pressing the Read button adjacent to the Plot 
parameter file box. This loads all the plot parameters into the 
current panel. 

Select the section view from which the plot is to be generated from by LB click on the view icon button 
adjacent to the View to load details from box near the top of the panel. Select view LS. Note: If a value is 
typed then the user must then press the enter key to accept the view. 

The parameters can be edited by moving through the various levels of the PPF editor by using the tree 
structure shown on the left of the panel. The tree structure can be expanded by LB click on a + symbol 
(node) to show underlying levels which may consist of various other nodes. To shrink underlying levels, 
LB click on the - symbol. 
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LB click on the Section Long Plot node (+ symbol) to expand the tree. Then LB click on the Title block 
node (+ symbol) to expand to the User title info level. Once expanded, the user can go from one level to 
another by simply LB click on the level they require (i.e. the text heading of the level). Going from level to 
level you we see the relevant parameters for that level. The User title info level should be selected which 
will look as follows.

The parameters on the right of the panel include the user title block parameters. The title file given in the 
ppf file has been read into the grid with the names of the title user text shown in the name column, and the 
value column shown blank. If valid values are entered into the grid, they will be automatically substituted 
into the title block at the time of plotting.

This panel can be resized by moving the mouse to the extremities of the panel and whilst holding down the 
LB near the edge, moving the outline to the required size just like resizing any view. Resize the panel in 
both the horizontal and vertical so that it takes up most of the screen. Note Like any panel it can be 
minimised by using the standard windows minimise button.

We will enter a few values into the grid to show how the user text will be substituted into the title box at the 
time of plotting. LB click in the value filed adjacent to the Main Title 1 name field, then type some data. 
As the default size for the column has been set to the width of the column heading, it will be necessary to 
resize the column to see all of the typed text. To do this, move the cursor over the vertical dividing line of 
the grid, near the right hand end of the ’Value’ column heading. You will see a resizing arrow appear. 
Double click LB whilst this arrow appears and the column will be resized to show all the text. 
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Complete the rest of the grid as follows:

Note that all the value fields do not have to be filled out. 

At any stage of the editing process, the user can write a binary PPF file that can be read into a panel at a 
later time. This is helpful if you want to close the Long plot and PPF editor panel but want to save the 
changes. Simply type a file name into the Plot Parameter File box at the top of the Long plot and PPF 
editor and press the enter key. This assigns the relevant file extension. Then press the Write button at the 
top of the panel.

To read an existing PPF file, the user can choose the file from the Plot Parameter File box, then press the 
Read button. This loads any existing parameters into the grid.

Double click LB when the resizing 
arrow appears.

The column is resized to the 
width of largest value in the 
column
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As you often need to plot your drawings several times before you get it right, 12d allows the plot models to 
be automatically cleaned prior to creating the new plots

To add a Plan plot to out Long Section click on the ‘Plan Plotting’ near the bottom of the main listing

Now select Plot to create the plot models. 

12d will realise that it needs four sheets to complete the job. The supplied plot file name was preview lx. 
Since Pagination was turned ON, 12d will create sheets preview lx 1, preview lx 2........ As we plotted to a 
‘Model’, we will get models preview lx 1, preview lx 2........ etc. If we plotted to DXF, we would get files 
preview lx 1.dxf, preview lx 2.dxf........ etc.

Select prompt for clean as the choice 
for ‘Clean models before hand’. This 
gives the user the option to clean at the 
time of creating the plot

Return to ‘Section long plot ’ part of the panel

Click LB on Plan Plotting

Select view icon then select view 1
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In view ‘Plan Preview’, turn OFF model preview quick hidden and turn on model preview lx 1. Your first 
sheet should appear as shown below. Zoom in on the area where the services appear.

Note that 12d has automatically worked out where these services cross under the road centreline and drawn 
the pipe to scale (the pipes appear sections, because we have a wide corridor set for View ‘Section LS’), 
and annotated each pipe. All of this happens automatically by turning on the appropriate models of 
services in view ‘Section LS’. The ppfs recognise reserved names assigned to the services.

In view ‘Plan Preview’, turn OFF model preview lx 1 and turn ON model preview lx 2. Your second sheet 
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should appear as shown below.

Zoom in on the low point of the road as shown above.

Note the sag point has been annotated automatically. Also note the labels in the boxes area and the 
Horizontal and Vertical geometry annotation. All of this is completely user definable.
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If you Pan around to the centre of the Title block, you will notice that 12d has automatically calculated and 
inserted text showing the chainage range appearing on each sheet. It has also substituted the user text 
values entered into the Long Plot and PPF editor panel into the appropriate places in the title block.
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In general, the text in the Title block is entered in a panel once per project. It can be entered for long-
section plots and reused for cross-section and plan plots. 

If you Pan to the right-hand end of the title block, you will observe that 12d has inserted such items as 
Drawing numbers (which automatically increment with each sheet), Job numbers, Company Logos and 
Plot date. 

All of this has happened automatically during the generation of the plot.

You are now in a position to make changes to your plot parameters and repeat the plot.

If the plot is satisfactory, the user can send the plot to a device. Simply select an appropriate device from 
the plotter icon and then Click LB on the Plot button.



Chapter 17  Plotting

February 2007 Page 217

17.10.1Automatic Labelling of Crossing Services on Long Sections
In the above plots you will notice that services appeared on the long section wherever the services were in 
the road corridor and labelled when the services crossed the profiled string, in our case the road centreline. 
We will now look at what plot parameters caused this labelling to happen. With the plot parameter files 
supplied with the training data, the following models contain the services.

survey SEWER PIPE 300
survey WATER PIPE

This is a user defined convention only. You can have any names you like for this purpose.

When 12d creates a long section plot, it will search for any strings in the above models. Masks (optionally 
using wild cards) can be used in the match on the string name so that only certain strings in the model are 
recognised. 

To view the parameters that control the plotting of crossing services, go to the cuts section of the Long 
Plot and PPF editor):

The top level of the cuts section defines multiple sets 
of model/mask combinations. The user can select a 
whole model or certain strings from that model by 
specifying a mask. In this example, any strings from 
the EXISTING SERVICES STORMWATER model 
that end in ’drain’ will be included in the cuts 
plotting.
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The levels under the cuts section relate to the chainage, height, label and symbol information that is to be 
placed on the plot.

The user defined standard for symbol labelling services (as defined above) is to place a green cross at the 
invert point of the pipe and place a label alongside this (as defined above).

In our case, view ‘Section LS’ contained the profile of the Long section we want to plot. Because we 
turned on the above service models in view ‘Section LS’, the finished plot also included the actual pipe 
strings as well. If you have a Vertical Exaggeration on the view other than 1, the pipe will appear as an 
ellipse rather than a circle.
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17.11 Miscellaneous Long Section Plotting 
The example we have used had a user defined title file. However, the user can select not to plot the user 
defined title block and use the standard 12d model title block. You may also elect not to use any.

Simply select the title 
block you require, by 
clicking on the 
checkbox.
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17.12 Plotting Sheets of Cross Sections
In your view ‘Section XS’, profile any valid cross section from the model of cross sections called ROAD 1 
APPLY Sects. From the View Title Area for view ‘Section XS’, click LB on the Profile button and click 
LB on any cyan cross section string you can see in any view. Confirm the selection with MB. 

Also make sure that the vertical exaggeration of view ‘Section XS’ is set to [5]. The large range of cut and 
fill in the training data files will reduce the number of sections per sheet if you have the vertical 
exaggeration set any larger than 1.

To run the ‘Section X Plot PPF Editor’, from the View Button Area for View ’Section XS’ click LB on 
Printer Icon and select ‘X plot ’

Alternatively you can click on option Plot=>Plot and PPF editors=>Cross Sections. 

Select x plot
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Select the section view from which the plot is to be generated from by LB click on the view icon button 
adjacent to the View to load details from box near the top of the panel. Select view XS. Note: If a value is 
typed then the user must then press the enter key to accept the view. 

In the Plot parameter file 
box located at the top of the 
panel, LB click on the folder 
icon to bring up the folder 
choice box. 

Walk right on the User Library menu ([User Lib]) and 
select the file Cross Sections.xplotppf by double clicking 
LB on the file name in the choice box. This file is a binary 
PPF file. Complete the sequence by pressing the Read 
button adjacent to the Plot parameter file box. This loads 
all the plot parameters into the current panel. 
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Go to the User title info level by navigating the tree control as described previously. The level should be 
selected which will look as follows.

The parameters on the right of the panel include the user title block parameters. The title file given in the 
ppf file, has been read into the grid with the names of the title user text shown in the name column, and the 
value column shown blank. If valid values are entered into the grid, they will be substituted into the title 
block at the time of plotting automatically.

This panel can be resized by moving the mouse to the extremities of the panel and whilst holding down the 
LB near the edge, moving the outline to the required size just like resizing any view. Resize the panel in 
both the horizontal and vertical so that it takes up most of the screen. Note Like any panel it can be 
minimised by using the standard windows minimise button.

We will enter a few values into the grid to show how the user text will be substituted into the title box at the 
time of plotting. LB click in the value filed adjacent to the Main Title 1 name field, then type some data. 
As the default size for the column has been set to the width of the column heading, it will be necessary to 
resize the column to see all of the typed text. To do this, move the cursor over the vertical dividing line of 
the grid, near the right hand end of the ’Value’ column heading. You will see a resizing arrow appear. 
Double click LB whilst this arrow appears and the column will be resized to show all the text. 
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Complete the rest of the grid as follows:

Note that all the value fields do not have to be filled out.

At any stage of the editing process, the user can write a binary PPF file that can be read into a panel at a 
later time. This is helpful if you want to close the Section X plot and PPF editor panel but want to save 
the changes. Simply type a file name into the Plot Parameter File box at the top of the Section X plot and 
PPF editor and press the enter key. This assigns the relevant file extension. Then press the Write button at 
the top of the panel.

To read an existing PPF file, the user can choose the file from the Plot Parameter File box, then press the 
Read button. This loads any existing parameters into the grid.

Double click LB when the resizing 
arrow appears.

The column is resized to the 
width of largest value in the 
column
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Prior to plotting 

To generate a plot simply press the Plot button at the bottom of the panel. 

Select Yes to confirm cleaning any existing plot models

12d will realise that it needs multiple sheets to complete the job. We supplied the plot file stem xs. 12d will 
automatically create as many sheets as it needs to in the sequence As we plotted to a ‘Model’, we will get 
models preview xs 1, preview xs 2 etc. If we plotted to DXF, we would get files preview xs 1.dxf, 
preview xs 2.dxf etc.

In view ‘Plan Preview’, turn OFF all models then turn on the model preview xs 1. You’ll notice round 
objects below the road as shown below.

Zoom in as shown on the one of the cross section.

Note the annotation in the boxes area. This is all user definable via plot parameters. Note the water string 
being labelled automatically where it crosses the road cross section. 

Select prompt for clean as the choice for 
‘Clean models before hand’. This gives the user 
the option to clean at the time of creating the 
plot

Return to ‘Section X Plot ’ part of the panel
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You will notice that 12d starts each sheet by assembling cross sections in the bottom left corner and 
working upwards. When it can no longer fit more sections in that ‘column’, it will move to the right and, 
starting at the bottom of the sheet work upwards again. When it fills a sheet, it will automatically go to the 
next sheet. All cross sections are presented in increasing chainage order.

Now Zoom in on the road surface at the same x section and note the labelling of the grades.
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Finally, Zoom in at the base of the sheet and observe the Title block text

12d knew that it could only fit a certain chainage range of cross sections on the sheet and so it 
automatically included the start and end chainages for the sheet in the title block.

The other sheets will contain similar sections.

17.12.1Extending the Natural Surface Beyond the Cross Section
Note that 12d uses the extend concepts when plotting. 

When plotting cross sections, 12d uses some of the parameters of the Section View where the cross section 
is being profiled. For instance the vertical exaggeration of the ‘Section XS’ view determines the vertical 
scale of the finished plot. 

View ‘Section XS’ has an extend parameter that determines the extent of what you see on the screen. This 
parameter is however not used for plotting. The amount of the extend required in final plots is set 
separately in the Section X Plot PPF Editor panel under Plot sheet layout
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If you were to set the LHS extension to 30 m, you get the following type of cross section plot. 

This technique can be useful at times, particularly at locating services away from the cross section.

17.12.2Previewing Cross section and Managing Cross Section Plot Files
To preview a plot, just turn on the model containing the previewed plot in view ‘Plan Preview’. It is highly 
likely that you will need to change some of your plot parameters and repeat the plot and preview process 
several times before your plots are as you want them.

You can make changes to your plot parameters and repeat the plot as many times as necessary.

Once the plot is satisfactory, the user can send the plot to a device. Simply select an appropriate device 
from the plotter icon and then Click LB on the Plot button.

17.12.3Automatic Labelling of Crossing Services on Cross Sections
The “Automatic Labelling of Crossing Services on Long Sections” on page 217 also applies to automatic 
labelling of crossing services on Cross sections in an identical manner. Examples of this are seen in the 
above Cross section plots.

With the plot parameter files supplied with the training data, the following models are used for services.

survey SEWER PIPE 300
survey WATER PIPE

This is a user defined convention only. You can use any names you like for this purpose.

When 12d creates a long section plot, it will search for any strings in the above models. Masks (optionally 
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using wild cards) can be used in the match on the string name so that only certain strings in the model are 
recognised. 

To view the parameters that control the service plotting, go to the cuts section of the X Plot and PPF 
editor):

The top level of the cuts section defines multiple sets of model/mask combinations. The user can stipulate 
a whole model or certain strings from that model by specifying a mask.
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The levels under the cuts section relate to the offsets, height, label and symbol information that is to be 
placed on the plot.

The user defined standard for symbol labelling services (as defined above) is to place a cross at the invert 
point of the pipe and place a label alongside this (as defined above).

In our case, view ‘Section XS’ contained the model of sections we want to plot. If we turn on the above 
service models in view ‘Section XS’, the finished plot will also include the actual pipe strings as well. If 
you have a Vertical Exaggeration on the view other than 1, the pipe will appear as an ellipse rather than a 
circle.
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17.13 Miscellaneous Cross Section Plotting 
The example we have used had a user defined title file. However, the user can select not to plot the user 
defined title block and use the standard 12d model title block. You may also elect not to use any.

17.14 Plan Plotting Using Plot Frames
Plot frames are a set of tools within 12d that permit a series of plan plots to be readily generated and 
regenerated as required. The plot frames are superimposed over data in that view and the various frames 
‘plotted’. All plots are clipped to size by the plot frames and will contain only the data that is on display in 
the plan view being processed. The user decides to plot one or more frames individually or plot a complete 
set.

We now need to assemble the data we want to plot in a view. We will use view ‘Plan 1’ for this purpose. 
Make sure that the following models are turned on in view ‘Plan 1’.
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17.14.1Creating Plot Frames
We will create our first plot frame.

User defined plot frames can be placed over the data in the view. These frames show both the sheet size 
and plot area borders.

From the ‘Plot Frames’ menu Plot =>Plot frames=>Create
From the User Library, choose the title file Plan Plot.TPs and the panel will be filled out as follows:

Your view ‘Plan 1’ should look as follows.

We want to create plot frames that encompass 
the various roads in the view. We will probably 
need more than one plot frame. In our case, 
each plot frame will represent an A1 sheet.

Click LB on the Origin icon  
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Then select the Create button. 

12d will transform the panel into the ‘New Plot Frame Edit’ panel (so that you only get one chance at 
creating that plot frame). It can be edited later if there is an error.

Make sure that your Point 
and Line snaps are OFF and 
select a point in the bottom 
left of the view as shown by 
the cyan circle. 

Confirm the selection with 
MB. The X and Y 
coordinates should appear 
in the field.

You will notice that the Edit panel is very similar to 
the Create panel.
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To see our plot frame, you need to use the ‘+’ in the ‘Plan 1’ view to turn on model pfplanplot. Do a Fit on 
the view.

Clearly our first guess at the 
scale is incorrect. We need to 
scale down our plot frame.

In the ‘New Plot Frame 
Edit’ panel, opposite the 
‘Scale 1:’ field, change the 
1000 to 500 and click LB 
on the Set button.

Click LB on Fit to fill the 
view.
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For the next operation, make sure that your Point and Line snaps are OFF as we don’t want to snap to 
anything.

In the ‘Plot Frame Edit’ panel, click LB on Rotate. Move the cursor into the ‘Plan 1’ view and notice that 
you can rotate the plot frame about it’s insertion point. When you have the cursor positioned appropriately, 
click LB and MB to confirm the selection.

Similarly, click LB on the Translate button and move the plot frame in view ‘Plan 1’. You will notice that 
the rotation angle is maintained as you move the cursor. When you have the cursor positioned 
appropriately, click LB and MB to confirm the selection.

The final position of your plot frame pf1 should look as shown below.

Now make sure that your Point snaps are ON (so that we can pick a plot frame at it’s corner).

You are trying to arrange the sheet to 
maximise the amount of information 
shown on it i.e. minimise the number 
of sheets.

Notice that the rotation angle and origin now have 
non-zero values.

That finishes the development of our first plot 
frame. 

Click LB on Set and Finish.
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Click LB on Plot =>Plot frames=>Create again. 

12d will transform the panel into the ‘Plot Frame Edit’ panel

For the next operation, make sure that your Point and Line snaps are OFF as we don’t want to snap to 
anything.

The panel will initially come up blank. 

Click LB on the Same as button, position the cursor 
near any one of the corners of the ‘pfplanplot’ plot 
frame and click LB to select it. When it highlights, 
click MB to confirm the selection.

Change pfplanplot to pfplanplot2

Change the Colour from red to green

Click LB on the Create button.

As before, click LB on Rotate. Move the cursor into 
the ‘Plan 1’ view and rotate the plot frame about it’s 
insertion point. When you have the cursor positioned 
appropriately, click LB and MB to confirm the 
selection.

Then click LB on the Translate button and move the 
plot frame in view ‘Plan 1’. You will notice that the 
rotation angle is maintained as you move the cursor. 
When you have the cursor positioned appropriately, 
click LB and MB to confirm the selection.

Click LB on Set and Finish.

You will need to do the same thing one more time to create a third plot frame.
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17.14.2Using the Plot Frame Editor
If you ever want to make changes to one of your plot frames and the panel is not currently on display, you 
can use the Plot Frame editor to do this. Make sure that your Point snaps are ON (so that you can pick a 
plot frame at it’s corner).

Click LB on Plot =>Plot frames=>Editor

Position the cursor near any one of the corners of the plot frame you wish to edit and click LB to select it. 
When it highlights, click MB to confirm the selection. The ‘Plot Frame Edit’ panel will appear as seen 
earlier.

To shut down the ‘New Plot Frame Edit’ panel click LB on Finish.

17.14.3Create Plot using Plot Frame PPF Editor
Plotting using the plot frame ppf editor can be started using the plan view plotting icon

This brings up the View Plotting panel

This then brings up the Plot frame PPF Editor panel.

The finished position of 
your plot frames should 
look as shown.

LB click on plotting icon

                LB click on Plot frames
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This panel has a tree structure, much like the Windows explorer type functionality. The + symbol near the 
"Plot Frame" text in the left of the panel indicates that there are levels below. To access lower levels, 
simply LB click on the + symbol to expand the tree. Expand the tree so there are no more + symbols and 
every level is shown.

To go from one level to another, simply LB click on the text headings on the tree structure. Click LB on the 



12d Model Getting Started and Training Manual

Page 238 February 2007

"Plot Frame" level. Fill the fields to the right of the tree using the relevant icon buttons where possible e.g. 
select the model pfplanplot from the model choice box. The fields should look as follows:

The plotter type to select is model, as we want to inspect the plot before sending it to the actual plotter.

In our example, we want to plot more than one Plot frame so we have chosen the Model of plot frames 
method. If we wanted to plot a single plot frame, we can select the frame using the Single plot frame 
selection tool.

Type in "preview plan" as the plot file stem. The plot stem specified will form the prefix for the plot name. 
This is important for plotting of a number of plot frames. For this example we have 3 plot frames so the 3 
plot files produced will be "preview plan 1", "preview plan 2" and "preview plan 3".

Click LB on the "Title block" heading. Tick the Use title file checkbox as follows. This specifies that a 
Title file will be used for the plotting.

Click LB on the "User title info" heading. From the User Library choose the Plan Plot.tbf file.
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Once selected, a valid title file will populate the grid with user defined title file aliases. These are prompts 
for title box text and once filled out, will be substituted into the title block. Fill out the value part of the 
grid as follows. Fill out the form to suit your requirements.

This panel can be resized by moving the mouse to the extremities of the panel and whilst holding down the 
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LB near the edge, moving the outline to the required size just like resizing any view. Resize the panel in 
both the horizontal and vertical so that it takes up most of the screen. Note Like any panel it can be 
minimised by using the standard windows minimise button.

Note that all the value fields do not have to be filled out.

At any stage of the editing process, the user can write a binary PPF file that can be read into a panel at a 
later time. This is helpful if you want to close the Plot frame PPF Editor panel but want to save the 
changes. Simply type a file name into the Plot Parameter File box at the top of the Plot frame PPF Editor 
and press the enter key. This assigns the relevant file extension. Then press the Write button at the top of 
the panel.

To read an existing PPF file, the user can choose the file from the Plot Parameter File box, then press the 
Read button. This loads any existing parameters into the grid.

Prior to plotting 

To generate a plot press the Plot button at the bottom of the panel followed by pressing Yes to confirm 
cleaning the plot models.

In view ‘Plan Preview’, turn OFF all models then turn on the model preview plan 1.

Select prompt for clean as the choice 
for ‘Clean models before hand’. This 
gives the user the option to clean at the 
time of creating the plot

Return to ‘Plot frame’ part of the panel
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17.14.4Previewing Plan plots and Managing Plan Plot Files
To preview a plot, just turn on the model containing the previewed plot in view ‘Plan 1’ e.g preview plan 
1. It is highly likely that you will need to change some of your plot parameters and repeat the plot and 
preview process several times before your plots are as you want them.

You are now in a position to make changes to your plot parameters and repeat the plot(s).

When you are happy with the plot, you can change the plotter option in the Plot Frame PPf editor to the 
desired plotter. Double click on the appropriate plotter to select.

 

Selection of the windows plotter options will 
utilise the current printers/plotter set up in 
windows.

Press the plot button to send the plot file to the selected device.
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17.15 Miscellaneous Plot Frame Plotting 
The example we have used had a user defined title file. However, the user can select not to plot the user 
defined title block and use the standard 12d model title block. You may also elect not to use any.

17.15.1Saving PPF files for use with other projects
For a particular company or organisation, various styles/specifications may have to be consistent for all 
plots. If a standard PPF is created for a company this can be saved to the User_lib directory for easy access 
for any project. Then for more specific changes, such as the user text (that is substituted into a title file) the 
new value can be entered and a PPF saved again. e.g. The designers name may be changed and the PPF 
saved with a filename "designers_name" for example.

At any stage of the editing process, the user can write a binary PPF file that can be read into a panel at a 
later time. This is helpful if you want to close the panel but want to save the changes. Simply type a file 
name into the Plot Parameter File box at the top of the editor and press the enter key. This assigns the 
relevant file extension. Then press the Write button at the top of the panel. The write process will by 
default put the file produced into the current project folder

.

If the user wants to save 
it to a User_Lib 
directory for example, 
they must click on 
[User_lib] to open that 
folder
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17.16 Continuing with the Tutorials
This concludes the tutorials covered by the Getting Started manual.

However, there is an Advanced Alignment Design manual which follows on from the Getting Started 
manual.

The training tutorials in the Advanced Alignment Design manual cover design for intersections, detailed 
roads, cul-de-sacs etc. using advanced techniques such as Apply Many, MTFs and Kerb Returns.

The Advanced Alignment Design manual is distributed as a PDF file on the 12d Model Installation CD.

There is also a Getting Started for Surveyors manual which covers material relevant to a Surveyor.

The Getting Started for Surveyors manual is also distributed as a PDF file on the 12d Model Installation 
CD.

Type in the file name Plan plot 

Select Open

The file name is placed in the ‘Plot parameter file’ text box.

Select Write to save the file
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18 Geometry Summary to Date
This tutorial continues on from the Getting Started Manual.

For the next stage of the tutorial it is important that your data accurately matches the road defined in the 
previous 17 chapters as we will be importing data to interact with the existing design.  To ensure this we 
have created a new project called Stage 2 found in the C:\12djobs\8.00\Training\Design\Getting Started 
Advanced directory.

You will need to start this project in order to continue with this manual.

This project has already followed the steps of the Getting Started manual to create the triangulation, the 
horizontal and vertical alignment and the templates.

18.1 Verifying your Manually Entered Road Centreline Data
The final road centreline definition is repeated here so that you can verify your data if necessary.

HIP 1HIP 2

HIP 3

HIP 4
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The following has been extracted from a standard 12d report using option Report => Strings => Coord/
Brg-Dst

.

Project:      Stage 1
User:         Philip Davies
Organization: 12d Solutions
Date:         Wed Jan 24 13:52:16 2007
Report File:  ROAD 1.rpt

Horizontal Alignment Report for string <ROAD 1> in model <ROAD CL>

   IP           IP  Coordinates              Radius      Leading     Trailing
 Number        X               Y                         Spiral      Spiral

Click LB on String icon

Click LB on alignment string 
in view ‘Plan 1’ then MB to 
accept

Type in the report file name 
ROAD 1 [Enter]. The 
extension .rpt will appear 
after the name

Tick the check box for 
Separation for Alignment

Type in separation of 0. This 
will only report on the tangent 
points

Click LB on Report to 
proceed. Click LB on Finish 
to terminate the panel. 
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   1      42988.6880      37445.3950
   2      42697.9410      37350.9260      -200.0000
   3      42552.8040      37099.5420      -100.0000      50.0000      50.0000
   4      42922.9470      36919.0110

   --- IP Details ---

IP 1

  coordinate =      42988.6880      37445.3950
  chainage   =          0.0000

IP 2

  coordinate      =      42697.9410      37350.9260
  centre          =      42832.7595      37184.4386
  radius          =       -200.0000
  length          =        146.6077
  intersect angle =       42°00'00"

  start tangent

    coordinate =      42770.9563      37374.6500
    length     =         76.7728
    chainage   =        228.9365
    bearing    =      252°00'00"

  end tangent

    coordinate =      42659.5545      37284.4388
    length     =         76.7728
    chainage   =        375.5442
    bearing    =      210°00'00"

IP 3

  coordinate      =      42552.8040      37099.5420
  total length    =        214.0610
  intersect angle =       94°00'00"

  leading spiral

    length          =         50.0000
    TS coordinate   =      42619.4539      37214.9827
    TS chainage     =        455.7453
    SC coordinate   =      42598.2020      37169.8772
    SC chainage     =        505.7453
    bearing         =      210°00'00"
    long  tangent   =        133.2995
    short tangent   =         64.1399
    long  tangent 2 =         33.4431
    short tangent 2 =         16.7665
    shift           =          1.0393
    K               =         24.9480

  arc
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    centre          =      42694.4824      37142.8573
    radius          =       -100.0000
    length          =        114.0610
    intersect angle =       65°21'08"

  trailing spiral

    length          =         50.0000
    ST coordinate   =      42672.6128      37041.1073
    ST chainage     =        669.8063
    CS coordinate   =      42629.7716      37066.6176
    CS chainage     =        619.8063
    bearing         =      116°00'00"
    long  tangent   =        133.2995
    short tangent   =         64.1399
    long  tangent 2 =         33.4431
    short tangent 2 =         16.7665
    shift           =          1.0393
    K               =         24.9480

IP 4

  coordinate =      42922.9470      36919.0110
  chainage   =        948.3287

 Vertical Alignment Report for string <ROAD 1> in model <ROAD CL>

                Chainage            Level              VC
                                                      Length

     1           -0.0000           68.8510
     2          202.0000           67.4752           77.6672  parabola
     3          412.0000           49.6670          150.0000  parabola
     4          600.0000           66.3330          200.0000  parabola
     5          772.6020           57.7029          100.0000  parabola
     6          950.4539           60.4740
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18.2 Open the Final Road Design Project 
As an alternative to proceeding through the tutorial in sequence exactly as specified to get to this point, we 
have created a new project called Stage 2 with the road design already setup for you. 

Restart 12d and select Stage 2 from the C:\12djobs\8.00\ Training\Design\Getting Started Advanced 
directory.

You will not be able to select the Project from the box and will need to browse to the correct directory using 
the Folder icon.

You should now be ready to start the more advanced design functions inside 12d
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19 Many Template Files

19.1 Importing String Data in 12D ASCII Format 
Subsequent sections of the tutorial rely on the presence of certain strings adjoining or near to our existing 
road centreline. Rather than entering these manually, we will read them in from files. The three files are 
supplied on the 12d tutorial CD in 12d ASCII format. Please refer to the previous chapter for more 
information on the 12d ASCII format.

The first string to be imported is called ‘busbay’. 

Click LB on Read to proceed. 

Repeat the sequence with files roadwidening.12da and resheeting.12da. Click LB on Finish to terminate 
the panel. 

To see these various strings, from the ‘Plan 1’ view, click LB on the ‘+’ sign button and double click LB 
on each model name in turn. See the table below for a list of the model names that you must turn on.

The details of the strings and their model names is as follows

Click LB on 

File I/O=>Data Input=>12d/4d data

from the main menu.

Use LB on the folder icon for the Ascii file 
field to pop up a list of files to import. Click 
LB on  busbay.12da

File Name Model Colour String type Purpose

resheeting.12da existing edge resheeting green 3d Edge of existing pavement

busbay.12da lip of kerb busbay brown alignment Busbay kerb

roadwidening.12da invert of culvert roadwidening orange 2d Limit Road widening
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From the ‘Plan 1’ View, Zoom in for a closer look at these strings as shown below. 

Note that the .12da format already contained the string colour, model name etc. i.e the data was predefined. 
All we had to do was supply the filename.

For the moment we do not need any of these strings on display. They will be used later as our template 
application skills improve.

From the ‘Plan 1’ view, click LB on the ‘-‘ sign and click LB on model busbay to turn it OFF. Repeat this 
for models roadwidening and resheeting. 

Sidenote: As well as reading the .12da format, 12d permits the writing out of any string in .12da format. 
You do this with File I/O=>Data Output=>12d/4d data. This facility enables you to exchange and 
backup complex string data in an open documented manner. The 12D ASCII format caters for all 12d 
Model string types including 2d, 3d, 4d, pipe, pipeline, alignment and super strings. 

Bus bay

Existing edge 
for resheeting

Road widening
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19.2 Template Modifiers
To cater for the multiple template configurations required in complex road design, 12d offers a number of 
powerful features. Firstly, an unlimited number of templates may be used in any one alignment with each 
template applying over a predefined chainage interval. 12d then permits each template to be altered via 
commands, hence the concept of template modifiers. 

The basic template facilities we have used in the tutorial to date are fine for designing rural roads in non-
congested areas. However many roads must be designed to align within and match to existing constraints. 

The template modifier facility was created to cater for road design where templates are continually varying 
and templates need to be stopped and restarted to step around constraints such as intersections and slip 
roads. Template modifiers also cater for most road widening situations such as bus bays and traffic islands 
and permit left and right templates to be manipulated independently.

The facilities to modify a template by instruction are extremely flexible. Remember, each template is made 
up of four basic parts - a fixed portion, variable cut, variable fill and final cut/fill. The fixed and variable 
parts of the template are defined in terms of links i.e. offset distances between adjoining strings. This 
makes it particularly easy to increase the width of any one link. An example of a link might be the ‘width 
of pavement’. A very important feature of 12d is that whenever a link is changed, for instance to widen a 
kerb line, the kerb string and all strings outside of the kerb line move with the revised width. Each link in 
the template can be modified independently by changing the width or changing the slope. 

In the case of width adjustment, the width can be defined as relative (added to the current width) or 
absolute. Between any two chainages, widths can vary in a linear or cubic manner. Widths can also be 
varied by extending out to an existing string or having the width taken as the distance between two existing 
strings. This facility permits 12d to efficiently manage redesign to match existing road surfaces. The 
region between any two template definitions is always linearly interpolated. Gaps are permitted.

A similar set of facilities is permitted to change slopes between chainages. This permits for instance, the 
introduction of superelevation on curves.

The facility in 12d to use template modifiers is known as Apply Many i.e. the application of many 
templates.
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19.3 The Many Template File (mtf)
Template modifiers is a concept that begins by taking a basic template and, through a series of instructions, 
modifies the template at each appropriate chainage.

There are two ways of creating template modifier instructions. They can be specified interactively from 
inside 12d Model typically by pointing using the mouse cursor, or supplied to 12d in the form of 
commands in an ASCII file. The file of commands is known as the ‘Many Templates File’ or mtf file for 
short. Even if the instructions are given interactively, they are still saved as an ASCII mtf file.

An existing mtf file can be modified either interactively or by editing the ASCII mtf file. You decide at the 
time which is the best method for what you are about to do.

The approach of saving the commands readily permits reruns as the final design evolves through iteration 
which is important since a detailed design is rarely correct on the first try.

The mtf file also has the benefit that it can be printed out and used as a hard copy audit trail of the 
commands used to create the design.

The rest of this chapter goes through in detail the steps of creating and editing an mtf file using the 12d 
interactive editor. We will focus only on the use of the 12d interactive editor as this is the preferred method 
for new users. 

Initially, we will only make sufficient changes to make our ‘many templates file’ match our earlier design 
where we applied a single template. See the chapter ‘Modification of Design Parameters’ for our most 
recent single template rerun. We should be able to match that run exactly even though we are now using a 
completely different approach.

19.4 Creating the Apply Many Template Function
Whilst 12d gives you a lot of flexibility in the order in which you do things, it is best to create an MTF file 
before creating your function that ‘applies’ the same MTF file. Certainly it is essential to have the MTF 
file of commands saved to memory before you can run the function.

To create a brand new ‘many templates file’, from the Main menu, click LB on Design=>MTF=>Create. 

The following panel will pop up

Place the cursor in the MTF File field and type ‘ROAD 1’ 
and press Enter. The suffix .mtf will be added to the name 
entered.

click LB on the ‘Centreline’ pick icon the click LB on the 
alignment string in any of the views. Click MB to accept

This option links the mtf file to the alignment string prior to 
creating the design function. When picking a chainage the 
cursor automatically knows which alignment string to 
measure from, which simplifies the command 

Click LB on Create and the 12d interactive MTF editor will pop up for your new 
.mtf file. Move and pin this menu at the bottom left hand corner of your screen.

We’ll now systematically work through the various MTF commands.

Firstly, for both sides of the road, we need to specify the names of the templates to be 
used and the chainages over which the templates are to be applied. 

From the MTF Edit menu, click LB on Templates=>Left Side
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The Left Side Templates panel pops up with all fields blank. 

This tells 12d that on the left side of the road we wish to apply this template starting at chainage 21.8605. 
Leave the rest of line 1 blank.

To create the second line for entry click LB in the ‘Comment’ cell and [Enter] twice to create a new row

On line 2 we now need to specify the chainage at which the template on the left side is to stop. If we knew 
the chainage, we can lock the cursor in the field with the LB and type the value. More likely however is 
that we do not necessarily know the exact chainage. We can do a string inquire from 12d, snap to the end of 
the existing road that our design will tie into, note down the chainage and then type it in.

However, the better way is to repeat what we did when establishing the starting chainage. 

If you missed it in the starting chainge then we will explain it in more detail here.

First we need to lock the cursor into 
the Chainage field on line 1 by 
clicking LB over the field. Next hit the 
RB, this then takes the template panel 
into the measure chainage application 
and is asking you to measure the 
starting chainage of your template.  
When you move into the plan view a 
dynamic measure line is activated.  
Select the end of the existing road 
pavement at the start of our design.  
You should have a chainage of 
21.8605

In the ‘Template 1’ field, click RB then 
select ‘Browse’. Double click LB on 
FULL LEFT W TABLE DRAIN.

Make sure that your point snaps are ON 
and line snaps OFF (we want to snap 
right onto the end of the line).

Click RB in the Chainage cell. When 
you move the cursor in to the plan view 
a dynamic measure line is activated. 
Simply click LB on the end point of the 
existing road on the left of our design 
then click MB to accept.  You may need 
to zoom in further to better be able to 
see the end of the existing road. 
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You should now see the number 926.5046 in the chainage field. 12d has typed it in for us!

In summary, the above layout tells 12d that on the left side of the road we wish to apply template ‘FULL 
LEFT W TABLE DRAIN’ starting at chainage 21.8605 and ending at chainage 926.5046. Note that the 
‘Template 1’ field on line 2 must be blank to achieve this. 

Note that if you were to enter a template name on line 2, 12d would interpret this as the template to be 
applied starting at chainage 926.5046. We do not want this.

Click LB on Apply to test our template commands and check for syntax errors. Any errors are reported in 
the message line at the base of the panel. Click LB on OK to terminate the panel.

A similar set of instructions is required on the right hand side of our road. From the MTF Edit menu, click 
LB on Templates=>Right Side

Note that the right side template is basically the same geometry as the left side. The reason we use two 
templates is so that the string names generated on each side of the road are unique. This is important later 
when applying boxing.

To apply the many templates file to our road centreline, we need to create a new function. This is very 
similar to how we applied our earlier single template.

As the ‘Apply Many’ function panel has a large amount of user input we can set up a default file to 
automate the filling in of the panel

Your completed panel should look 
as shown. 

If any of the data is not fully 
readable, you can click LB on the 
gap between the headings and then 
double click LB.

Repeat the procedure for the 
right side of the road. Note that 
on the right side of the road we 
use template ‘FULL RIGHT 
W TABLE DRAIN’. 

As before, click LB on Apply 
and OK to terminate the panel.

That is all the edits we wish to 
make at this stage so from the 
MTF Edit menu, click LB on 
Save. 

We leave the MTF Editor open 
for the following options

Note: If the chainage in line 2 above is greater than the end chainage of the string, the 
apply simply stops at the end of the string. Thus it is possible to just type in a very large 
chainage (99999) rather than the exact end chainage shown above if you want your 
template to end at the end of the design string.
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To do this select option Design=>Apply=>Apply Many Defaults
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On the Main Tab ensure that the LHS and RHS prefix has no value in the field.  If there is a character 
showing, delete it.  This is only used if we are using the same template on both the left and right hand 
side of the road.  However, we have created unique templates for the left and right with individual 
link names in each template.

On the Models Tab ensure that the Road and Boxing sections and strings are setup as shown. 

Click LB on Write.  You will be asked where you want to write the file to, it is best to add the 
file to the User Library so that it is used with every project.  Select the User folder radio button 
and click Write and Finish.



12d Model Training Manual

Page  260 February 2007

From the Main menu, click LB on Design=>Apply=>Apply Many and the following panel will pop up

A unique function name must be supplied so that we can refer to and rerun the function later as required.

When the panel is complete, apply the template by clicking LB on Apply. The road will be instantly 
designed.

After the mtf file has been applied, observe the cut, fill and balance volume quantities at the base of the 

The default section separation is 10 metres. For the purposes of the tutorial, set this to 5 or 50 for the 
practise version. This tells 12d to calculate sections at every 5m (or 50m) as well as at all special points 
such as tangent points.

The models for the 
road strings, sections, 
polygons and boxing 
on the Models tab are 
read from the default 
file.

Note: Boxing is not calculated at this stage so the models created will be empty

We will not use the LHS or RHS Prefix box 

The only other data we need to change is to indicate to 12d the road centreline (i.e. the reference string) 
along which the chainage is defined. Do this by clicking LB on the Reference button in the Main tab. 

The Screen Message Box advises

<Select reference string>[picks][][Menu]

In any of the views, click LB on the magenta road centreline string. It is easiest to do this in the ‘Plan 1’  
view. Click MB to confirm the pick.

In the ‘Function name’ 
field type ‘ROAD 1’ 
then press [Enter] . 

This will activate the 
default file and fill in 
the majority of the 
panel

Some parts of the panel 
will need to be filled in 
/ changed so we work 
from the top down

In the ‘Tin’ field, click 
LB on the tin icon to 
pop up a list of 
available TINs. Double 
click LB on GROUND

In the ‘Templates file’ 
field, click LB on the 
folder icon to pop up a 
list of .mtf templates. 
Double click LB on 
ROAD 1.mtf 
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panel. These are the exact same volume quantities we experienced when we last applied our single 
template (see the chapter ‘Modification of Design Parameters’. We have used the mtf file to achieve an 
equivalent design to applying a fixed template. 

Reminder of the rules for the Reference and Hinge strings: The chainage of a road is defined along a string 
called the Reference string. The template is always applied at right angles to the Reference string. The 
centreline of the template is located on the Hinge string. The Hinge string and the Reference string do not 
necessarily coincide. In our case they do. Since the Hinge string defaults to the Reference string, we only 
need to pick the Reference string.

We will now begin modifying our mtf file to cater for more complex design changes. Note that the changes 
we are about to make are not necessarily sound engineering judgements. All cross fall and widening 
dimensions have been exaggerated to make them easily visible. The changes have been chosen to 
demonstrate as many features of the software as possible within the confines of our limited data set and 
single road centreline.

Be aware of the following template rules:

A link from a template is modified between a start and end chainage.

Template modifier effects are cumulative. More than one modifier may exist for a link at any given 
chainage.

If no modifier exists for a link at a given chainage, the link reverts back to the template definition given 
by the left_side or right_side
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19.5 Note for the Practise Version of 12d
It is possible to keep within the 5000 point limit of the Practise version and still apply the template as 
described. You can change the ‘Section separation’ to say 50m instead of 10m with some loss of detail. It 
is also possible to leave the section separation at 10m, but restrict the amount of road being produced in 
any one run to keep under the 5000 point limit. Use the ‘Start chainage’ and ‘End chainage’ fields on the 
Apply Templates Function panel to do this. For example 

By appropriately 
limiting the chainage 
range, the modelling 
for the rest of the 
chapter can be 
achieved using a 
‘Section separation’ 
of 10.

Note the chainage 
range. Run the apply 
several times with 
different ranges and 
note the various 
effects. Each time 
you press the Apply 
button, the ‘old’ cross 
sections and strings 
are deleted so your 
points total will 
reduce accordingly. 
The new cross 
sections and strings 
added will then 
increase your points 
total.
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20 Template Modifiers

20.1 Widening the Pavement and Shoulder on a Section of Road
Our first task is to widen the pavement over a part of our road. We will do this around the  major constant 
radius curve in our road including the adjacent spiral transition curves. 

We will utilise the string inquire facility to snap on to the TS and ST points around  HIP 3 to get the 
chainages at the tangent points. These chainages can also be measured ‘on the fly’ within the modifier 
options. 

Firstly we need to ensure that only model ROAD CL, survey ROAD CROWN, survey ROAD SEALED 
and survey TOPO DTM BDY are active in view ‘Plan 1’. Turn off any other models

Provided you receive a successful ‘point snap’ to the TS 3 point (the cursor returns the yellow diamond) 
observe the chainage along ‘ROAD 1’ returned in the Information panel. The profile chainage (prof ch) 
value is 455.745 (third last item in panel). Click MB to confirm the point.

As the next point you want (the ST 3 point) is also on the same string, you just need to ‘Restart’ the 
selection process. The easiest way to do this is to just move the cursor (mouse) a small distance. 
Alternatively you can click RB to pop up the Pick Ops menu and click LB on Restart.

Position the cursor over the ST 3 point and click LB. Observe the chainage of 669.806 Click MB to 
confirm the point.

These chainage values are important as most template modification commands involve the specification of 
chainages as the means for defining the extents as to where the modifications are to begin and end.

We will now increase the pavement width by 1m on the outside (RHS) of the curve using an absolute cubic 
taper. We do this by specifying that the width of the ‘lokr’ link is to change in absolute value from 3.5m to 
4.5m between a starting and finishing chainage along the road design centreline. The ‘lokr’ link is the 
distance from the ‘next innermost string’ to the ‘lokr’ string. As there is no other string in this case (the 
lokr string is the one closest to the road centreline), the ‘lokr’ link in this case is the distance from the 
‘hinge’ string to the ‘lokr’ string. The hinge string defaults to the road design centreline.

Select function key F2 to bring up the 
String Inquire panel (F2 is a short-cut for 
picking String=>Inquire). Make sure 
that you only have your points and cursor 
snap settings ON (turn line snap OFF). 

Position the 
cursor over the 
TS 3 point and 
click LB. 

TS 3

ST 3
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Modifiers can be either absolute or relative. As we are specifying an ‘absolute’ modifier, the width of the 
link specified totally replaces any previously implied value (from the template) for that link.

We will start the tapering process 28 metres before the TS 3  point and finish it 8 metres into the spiral 
transition (i.e. a taper over 36m in total starting at chainage 427.745 and finishing at 463.745). The exit 
taper will be a mirrored copy of the entry taper (start at chainage 661.806 and finish at 697.806). The full 
4.5 metre width will apply around the constant radius curve and the balance of the transition spirals. 

Finally, on the inside (LHS) of the curve, we will increase the footpath width from 3.5 to 5 metres using a 
relative linear variation over a distance of 50 metres. The increase will begin 58 metres before the TS 3 
point and finish 58 metres after the ST 3 point. The full 5 metres width will apply from 8 metres before the 
TS 3 point to 8 metres after the ST 3 point. Because we are using a ‘relative’ modifier, the value specified 
is added to the current width of the ‘bofpl’ link. The current width is calculated from the original template 
definition.

Firstly turn on the model ROAD 1 Strs in view ‘Plan 1’

From the MTF Edit menu, click LB on Modifiers=>Left Side

The Left Side Templates 
panel pops up with all fields 
blank. 

Place the cursor in the 
central grey area opposite 
line 1 and click LB. The 
Create modifiers panel 
pops up. 

Click LB on Fixed=> 
Width
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The Fixed width panel pops up. We now need to fill out this panel with the information to modify the 
‘bofpl’ link on the left side with a relative modifier of +2.5m i.e. that link is to become 2.5m wider than it 
currently is between the specified chainages.

Make sure that the string you want is the one that has highlighted in red. Click MB to accept the string. 

Click LB on the Name icon

Select from the bottom of the 
panel ‘Same as’ so that you can point at the string that is 
generated by the ‘bofpl’ template link without necessarily 

Make sure that your line snaps are ON. Zoom in on the ‘Plan 1’ 
view as shown and click LB on the ‘bofpl’ string (the dark green 
string on the left hand side of the road)

‘Bofpl’
  string
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Enter the start and end widths as shown.

Untick the ‘Absolute’ check box since the width change we require is ‘Relative’. Click LB on Apply and 
OK.

The Left Side Modifiers panel pops up as you press the OK button. It displays the latest footpath link 
modification filled in on line 1.

The bofpl link name appears.  Note that if you knew that the 
link you wanted to modify was the ‘bofpl’ link, you could have 
just typed in the name rather than point at it. The “double 
quotes” around names are optional. They are essential if the 
name contains spaces.

 Fill in the chainages by selcting the icon            picking the 
tangent points and subtracting the chainage as shown.

Move the cursor into view ‘Plan 1’ and, using the dynamic 
measure line, click LB on the TS3 point. Click MB to accept

Be sure to input the mathematical expression "-" to subtract the 
required chainage from the tangent point..

Set the interval to 1, to give better detail as you move through 
the curve and set the ‘Active’ check box to on.  This can be 
used to toggle off the modifier rather than deleting it. 

We now need to create two more lines that are very similar to the line we have just created so we can use 
the 12d editing tools to duplicate and modify the new lines (rather than create them from scratch)

Place the cursor over the ‘Line 1’ button and press RB.

Click LB on Copy

Again, keeping the cursor over the ‘Line 1’ button, press RB.

Click LB on Copy
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Now edit line 3. Click LB on the line 3 Command area. 

You now need to edit lines 
2 and 3. First click LB on 
the line 2 Command area. 

The Fixed Width modifier 
panel pops up.

Use the tools shown earlier to change this to look as shown at left. 

You can use the standard Windows cut and paste facilities for 
instance to shift chainage values between fields. Double click an 
item to highlight it, cut it with (Ctrl X) or copy it with (Ctrl C), 
click LB to locate the cursor where you want to place it (or double 
click to highlight an item you wish to replace) and paste the new 
entry with (Ctrl V).

Set the start width to 2.5.  When finished click LB on Apply and 
OK.

The Fixed Width 
modifier panel pops up 
again.

Make the changes 
shown to the chainages.

Set the End width to 0.

When finished click LB 
on Apply and OK.



12d Model Training Manual

Page  268 February 2007

The Left Side Modifiers panel redisplays showing the latest link information.

You can then make a very similar set of changes on the right side. From the MTF Edit menu, click LB on 
Modifiers=>Right side

These are the finished 
commands required to widen 
out the footpath link on the 
inside of the bend by an extra 
2.5m. 

When finished click LB on 
Apply and OK.

You will need three lines in the Right Side 
Modifiers panel, each using a fixed width 
modifier. 

For each line in turn click LB on Fixed=> 
Width

‘lokr’ string
(Lip of kerb right)

These are the commands required to taper out the ‘lip of kerb 
right’ link on the outside of the bend from 3.5m to 4.5m. 

Make sure you tick the absolute and cubic checkboxes.

When finished click LB on Apply and OK.
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20.2 Incorporating Superelevation on Curves
The template we are applying specifies that the main pavement section of our road has a 3% cross fall from 
the road crown to each kerb line. We will now introduce superelevation of a full 3% to the outside ‘lokr’ 
string into our pavement design. This will apply around the full constant radius and transition spirals 
curves. This will require a cross fall template modification to the right side pavement. The left side can 
remain as already defined at 3% cross fall. 

The transition to full superelevation will be linear (it can be cubic) and begin 28 metres before point TS 3 
(chainage 427.745). Full superelevation will occur at point TS 3 (chainage 455.745). The exit conditions 
from point ST 3 will be identical but in reverse and apply from chainage 669.806 to 697.806.

The finished Right Side Modifiers panel should look as follows

These are the finished commands required to widen out the ‘lip of kerb right’ link on the outside 
of the bend by an extra 1m using an absolute adjustment of from 3.5m to 4.5m. The taper sections 
will use a cubic taper.

When finished click LB on Apply and OK.
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From the MTF Edit menu, click LB on Modifiers=>Right Side

The Fixed XFall panel pops up. To achieve the transition required you will need three lines in the Right 
Side Modifiers panel, each using a fixed XFall modifier. You will need to click LB on Fixed=> Xfall three 
times to create the next three lines in the file

When you are finished with each panel click LB on Apply and OK

The Right Side modifiers panel pops up. Note that the previously defined modifiers appear. Your 
options at this point are that you can edit any of these or add further new modifier commands.

We will create new commands but before we do, it is a good idea to add a comment line to make 
it easier to read at a later stage. Place the cursor in the central grey area opposite line 4 and click 
LB. The ‘Create modifiers’ panel pops up. 

Click LB on Comment. In the Modify Comment panel, type "SUPER ELEVATION".  If you had 
a lot of super elevation to do in a big project you could add the chainage values also.

Click on line 5 and from the ‘Create modifiers’ panel, click LB on Fixed=> XFall

Line 5: Line 6: Line 7:
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This is a good time to save your edits. From the MTF Edit menu, click LB on Save.

Over the stated chainages, this defines the variation to the cross fall of the fixed link ‘lokr’ from the 
beginning of the previous fixed link (the hinge string in this case) to the string ‘lokr’.

A very important feature of 12d is underlining this template modifier command. 12d always linearly 
interpolates between templates. This is not to be confused with how a link can be modified between any 
two chainages - cross falls and widths can generally be varied in either a linear or cubic manner.

 Thus to achieve a linear variation of cross fall i.e. superelevation, one only needs to define the template 
geometry at either end of the superelevation. Regardless of the complexity of the road and template 
geometry and the number of sections involved, 12d will do all of the calculation for you!

20.3 Widening the Road Out to an Existing Constraint
So far we have specified widening commands that change our template links to predetermined values. We 
will now specify widening in terms of other strings already present in our project.

Earlier we imported a 2D string called ‘invert of culvert’ in a model ‘roadwidening’. This string would 
typically represent the invert of a culvert or a similar constraint that was to be used to govern the extent of 
any road widening. It might be the existing edge of bitumen. 

We will now use the template modifier features of 12d to widen our left lip of kerb line out to a theoretical 
line that is parallel with the ‘invert of culvert’ string but (say) 1.2m on the road centreline side of it. That is, 
we are using a constant offset from a known string. We will do this for only a limited section of the road, 
obviously within the length of the ‘invert of culvert’ string.

Whilst we are using a constant offset here, we could have specified a linearly tapering offset or even a 
cubically varying offset.

The finished Right Side Modifiers to perform this superelevation change should look as 
shown in lines 5, 6 and 7.

When finished click LB on Apply and OK.
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It is important to realise that the ‘invert of culvert’ is merely a plan 2D string (no Z values). Whilst the road 
will be widened in this area, the road section cross falls (as specified in the template) will be maintained. 
Thus the Z values of the left hand lip of kerb line will be calculated by extrapolation from our existing 
‘left’ template, plus any other template modifier effects that might be present.

To begin operations, turn off the model ROAD 1 Strs in view ‘Plan 1’ then turn on models busbay, road 
widening and resheeting.

In ‘Plan 1’ view menu zoom in to the area around the ‘invert of culvert’ as shown above.

From the ‘Plan 1’ view menu click LB on Toggle=>Vertices so that you can see the various points on the 
‘invert of culvert’ string.

From the MTF Edit menu, click LB on Modifiers=>Left Side.  The Left Side Modifiers panel pops up. 
Note that the previously defined modifiers appear.  Add the comment 'ROAD WIDENING" to line 4  

‘invert of culvert’ 
string

Road widening string

 We will create two new commands. Firstly, place the cursor in the central grey area opposite line 5 
and click LB. The Create modifiers panel pops up.

Click LB on Fixed=>Width to string
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Back in the Left Side Modifiers panel, place the cursor in the central grey area opposite line 6 and click 
LB. The ‘Create Modifiers’ panel pops up. Click LB on Fixed=>Width

Select the name of the link as previously shown

Use the ’measure chainage’ icon to pick the start and
end chainage, by picking on the start and end of the ’in-
vert of culvert’ string.

Click LB on the String button and select the ‘invert of 
culvert’ string in model ‘roadwidening’.

When finished click LB on Apply and OK.

Select the name of the link as previously shown

Use the ’measure chainage’ icon to pick the start and end 
chainage, by picking on the start and end of the ’invert of 
culvert’ string.

Uncheck the Absolute check box. We want it to be a relative 
adjustment of 1.2m towards the centreline. It is negative since 
we are reducing the ‘current’ link distance by 1.2m

When finished click LB on Apply and OK.
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Note that in general, the effect of  MTF commands are cumulative. Thus by having multiple commands 
modifying the one link over a set chainage, it is possible to achieve very complex modifications. You need 
to break such modifications into their component parts and then specify them one at a time as we have 
done above.

Some care is needed with the order of the modifier commands in the MTF file. For instance, it would not 
make sense to do a relative modification and then have that followed by an absolute modification. The 
reverse is fine however as we saw above. We performed an absolute modification by widening out to a 
string and then followed it with a relative modification by reducing the previous widening by 1.2m.

It is important to realise that this whole road widening operation is very flexible and not limited to the 
pavement surface. For instance, instead of widening the ‘lokl’ string out to the ‘invert of culvert’ string, we 
could have widened the ‘bofpl’ string out. In such a case all strings on the inside of the shoulder string such 
as the ‘lokl’ string would remain as is i.e. as defined by the ‘FULL LEFT W TABLE DRAIN’ template. 
The ‘iodl’ string which is on the outside of the shoulder string, would be widened. 

The rules for changing both width and grade of template links are: 

1. All template links are maintained after any changes are performed. If you start with 5 fixed links, you 
will still have 5 links regardless of how many modifications are made.

2. Any links that are not changed by MTF modifier commands will always adopt the value as specified in 
the template definition. When specifying a width modification for instance over a set chainage range, 
the width of the link will revert back to it’s template definition immediately after the end chainage of 
the modification.

The Left Side Modifiers panel should now look as shown above.

When finished click LB on Apply and OK.

To ensure that your new changes are saved, from the MTF Edit menu, click LB on Save. 
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20.4 Incorporating a Bus Bay in the Road
One of the strings we imported earlier was called ‘lip of kerb’ in model ‘busbay’. First we need to zoom in 
to the ‘busbay’ string.

The ‘lip of kerb’ string is a full alignment string and hence has meaningful vertical geometry. The vertical 
geometry of such a string is normally created in exactly the same way that we defined our ‘ROAD 1’ road 
centreline. In this case, the vertical geometry came in with the horizontal geometry when we imported the 
string. The vertical geometry of the bus bay kerb has been designed so that it is depressed i.e. it is below 
the normal kerb line.

An approximate idea of the geometry can be seen in the ‘Section LS’ view below where the ‘lip of kerb’ 
string has been profiled. The model tin GROUND was added to the view.
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We will use this ‘lip of kerb’ string to widen the road as before but this time we will be using the vertical 
geometry of the string to determine the kerb line. Thus the pavement cross fall in the vicinity of the bus 
bay will be determined by defining the slope of the ‘lokr’ link to be that slope from the previous link (in 
this case the ‘ROAD 1’ design road centreline as there is no previous link) to the bus bay kerb. The width 
of the ‘lokr’ link in the vicinity of the bus bay will also be defined as the distance from the previous link 
(road centreline again) to the bus bay kerb. A smooth transition will be used at either end of the bus bay to 
return the pavement cross fall to our standard template value of 3%.

Sidenote: In the next Chapter, we introduce a median strip into our road. In this example, it is intentional 
that this bus bay widening is being applied outside of the range of  the median strip to simplify the 
definition. If we were inserting this bus bay in a region where the median strip applied, the cross fall and 
widening definition of the ‘lokr’ link would be more complex opposite the median as the previous link 
would be the ‘invmedian’ string rather than the road centreline. Always remember that these template 
modifier definitions are specifying changes to individual ‘link’ distances and cross falls. All links outside 
of the link being changed will move accordingly.

As before, the key information we need to know to create the template modifier commands are the starting 
and finishing chainages of the tangent points where the bus bay fits in with the ‘normal’ road kerb line. We 
will get 12d to measure these chainages exactly.

Zoom in further on the left hand end of the ‘lip of kerb’ string as shown below. After zooming, click LB 
on the ‘+’ sign button and turn on the ROAD 1 Strs model.  Toggle off the vertices.

Note that the ends of the bus bay ‘lip of kerb’ string are collinear with the cyan ‘lokr’ string corresponding 
to our normal template right hand kerb line. Thus to ensure a smooth transition of templates, all we need to 
do is start and stop our road widening at the tangent points where the bus bay ‘lip of kerb’ string matches 
up to the ‘lokr’ string. 

The first chainages we need are at points M and N (see above). We need these points so that we can 
stipulate extra cross section points between M and N to ensure that we get a smooth transition in the highly 
curved regions of the bus bay. Remember our normal cross sections have only been stipulated at 5m 
centres. In this region we will ask for cross sections at 1m centres.

The next step will be easier if you turn off the road design strings temporarily. Click LB on the ‘-’ sign in 
‘Plan 1’, and turn off ROAD 1 Strs. Refresh the view by clicking MB in the View Button Area of ‘Plan 1’. 
The ‘lip of kerb’ string should now be clearly visible. 

Point M (tangent pt)

Bus bay

Point N (tangent pt)

Normal road template 
kerbline
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From the MTF Edit menu, click LB on Modifiers=>Right Side 

The Right Side Modifiers panel pops up. Note that the previously defined modifiers appear. Your 
options at this point are that you can edit any of these or add further new modifier commands.

To specify the busbay, we will need two new commands: one for width and one for cross fall, start by 
adding in another comment "BUSBAY".

Place the cursor in the central grey area opposite line 9 and click LB. The ‘Fixed Width to String’ panel 
pops up. 

Click LB on Fixed=> Width to string

The ‘Fixed Width to String’ panel pops up. 

Type in the link name lokr

To find the ‘exact’ start chainage for the modifier 
select the ‘More Information’ icon             

Use the ’measure chainage’ icon to pick the start 
and end chainage, by picking on Point M (in the 
previous diagram) and Point P (in the next 
diagram)

We can generate closer spacing of the sections 
along this modifier. This will give a better fit to 
the string. Type in 1 for the ‘Interval’

Click LB on the String button and select the ‘lip 
of kerb’ string in model ‘busbay’.

When finished click LB on Apply and OK.
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Back in the Right Side Modifiers panel, place the cursor in the central grey area opposite line 10 and click 
LB. The Create modifiers panel pops up. Click LB on Fixed=>Xfall to string.

The ‘Fixed XFall to String’ panel pops up. 

Point O

Point P

Type in the link name lokr

Use the ’measure chainage’ icon to pick the start and 
end chainage, by picking on Point M and Point P.

We can generate closer spacing of the sections along 
this modifier. This will give a better fit to the string. 
Type in 1 for the ‘Interval’

Click LB on the String button and select the ‘lip of 
kerb’ string in model ‘busbay’.

When finished click LB on Apply and OK
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20.5 Resheeting a Road
We will now introduce a further template modifier feature that permits 12d to perform resheeting 
calculations. Whilst 12d currently has features to optimise resheeting operations, it also has a facility to 
modify the cross fall of a road surface such that it most closely matches the existing surface. This is done 
by surveying the existing edge of pavement, introducing that three dimensional string into 12d and then 
defining the cross fall of the road to pick up the existing edge points. We will now do this and at the same 
time, widen this section of new road to make it a constant 3.5m width (assumes the existing pavement edge 
deviates in plan along the road giving a varying pavement width).

Whilst we could also have surveyed the existing ‘road crown’ and used that as our road centreline, for the 
purpose of the tutorial, we will use our existing ‘ROAD 1’ design string as our road centreline. Thus our 
new road will have cross falls defined by the slope between the ROAD 1 design alignment and our existing 
pavement edge. 

Note on resheeting operations: Whilst we are not demonstrating it here, a further feature of 12d permits 
width and crossfall links to be defined as the distance and slope respectively between any two strings. 
Those strings could be the existing road crown and existing pavement edge. It is also possible to translate 
both of these strings by (say) 100mm vertically to define the finished pavement surface.

A 3D string (i.e. a string with levels) called ‘existing edge’ in model ‘resheeting’ has already been 
imported.

That completes our Right 
Side Modifiers.

The Right Side Modifiers 
panel should now look as 
shown. 

Click LB on Apply and 
OK.

To ensure that your new 
changes are saved, from 
the MTF Edit menu, click 
LB on Save and click on 
Yes to save the changes. 
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From the ‘Plan 1’ view click LB on Fit. Then Zoom in as shown below. From the ‘Plan 1’ view click LB 
on Toggle=>Vertices so that you can see the various points on the ‘existing edge’ string. (or if you can’t 
see the Toggle menu item,  place the cursor in the View Button Area of ‘Plan 1’ and click RB to pop up the 
View menu. Click LB on Settings=>Toggle=>Vertices).  Turn on the Line Snap.

.

From the Main menu, click on Strings=>Inquire to perform a String Inquiry. Click on the green ‘existing 
edge’ string. Note that in the information panel that pops up, the string is a 3d string and it has meaningful 
profile Z values (observe a prof z value around 58).

From the MTF Edit menu, click LB on Modifiers=>Right Side. Add the comment "RESHEETING"
 

Edge of 
existing 
pavement

To set the cross fall 
of the ‘lokr’ link to 
be the same as the 
cross fall to the 
‘existing edge’ 
string, we will need a 
new Xfall to String 
command.

Place the cursor in 
the central grey area 
opposite line 12 and 
click LB. The 
‘Create modifiers’ 
panel pops up. 
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Click LB on Fixed=> XFall to string.  The Fixed XFall to String panel pops up. 

That completes enough Template Modifier commands for now. So that we can see any subsequent changes 
during the redesign of our road, turn the road design strings back on. Click LB on the ‘+’ sign button in 
‘Plan 1’ and double click LB on ROAD 1 Strs and ROAD 1 Sects.  Toggle off the vertices.

Click LB on Fit to fill the view.

Type in the link name lokr

On this occasion we won’t bother to give a start and 
end chainage as 12d can read the chainages from the 
start and end of the string we select.

Click LB on the String button and select the ‘existing 
edge’ string in model ‘resheeting’.

When finished click LB on Apply and OK

The Right Side Modifiers panel should now look as shown above

Click LB on Apply and OK.

To ensure that your new changes are saved, from the MTF Edit menu, click LB on Save. 
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20.6 Re-Applying the Modified mtf File (second time)
To re run the Apply Templates Function click LB on Design=>Apply=>Apply Many and the Apply 
Templates Function panel will pop up, or…

If the Recalc panel is on display, you can also pull up the same panel by walking right 
on Editor=>ROAD 1 from the Recalc menu.

Click on the icon in the Function namefield and a list of available functions will pop up. Click on ROAD 
1. This was the name we gave our first Apply Many attempt. The various answers we gave last time should 
reappear.

Nothing should need changing.

If you didn’t set up the mtf file you can use file ROAD1.mtf from the ‘Template files’ choice list

Click LB on Apply to process the Apply Many function.

All of the strings in the ROAD 1 Strs, ROAD 1 Sects and ROAD 1 Polys models will be deleted and 
replaced by recalculated strings. This happens each time you run the Apply Many function so you don’t 
have to delete any of the old strings manually. 

The new strings will appear after a short processing delay.

Note the revised cut, fill and balance calculations at the base of the panel. These volumes have been 
calculated from the combined effects of our revised road geometry.
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Zoom and Pans can then be used in the Plan view to have a closer look at the revised road design.

Zoom in around the widening strings near the end of the road

Bus bay 
widening

Resheeting
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Zoom in to the curve with superelevation and widening applied

We will now make further changes to our road. 

Note how we are incrementally building up and applying these changes. As the designer, you decide how 
many changes you make before reapplying them. It is usually wisest to only make a few changes at a time, 
get them right, and then proceed on to the next ones. In this manner, if things go wrong with your design, 
you only need focus on your latest changes.

Widening

Superelevation

Verge widening
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21 Median Strip

21.1 Inserting a Median Strip along the Road Centreline
Whilst there are a variety of ways of doing this, we will initially do it by duplicating and modifying our 
existing template to include the median geometry. This example illustrates the starting and stopping of 
templates when adjoining templates have a different number of links. These templates can typically be 
0.1mm apart at a particular chainage (to ensure that volume calculations are not impacted). It also shows 
the use of ‘hinge modifiers’ when applying templates to allow the actual point of application of the 
template to be displaced from the theoretical point of application as defined by the hinge string.

It is useful at this time to review 12d’s rules for template file application.

1. If one template stops at the same chainage that another template begins, then the two templates must 
have the same number of fixed and variable links. The templates will be varied linearly from the 
stopping template to the starting template over one section separation distance.

2. If there is a linear variation between two templates, the two templates must have the same number of 
fixed and variable links.

3. If two templates do not have the same number of links, they must be separated by a gap i.e. by a region 
with no template. This gap can be 0.1mm wide so as not to affect volume calculations.

21.2 Creating the Median template links
We begin setting up our median strip by duplicating the existing ‘FULL LEFT’ template.   

From the main menu click LB on 
Design=>Templates=>Copy

Click LB on the ‘More Information’ icon

for the ‘Old template’ field to pop up a list of templates. Click 
LB on ‘FULL LEFT’.  Press the Enter key and type the new 
name ‘FULL LEFT W MEDIAN’. Click LB on Copy to force 
the duplication.

Repeat the copy process for the ‘FULL RIGHT W MEDIAN’ 
template that is used on the right side of our road.

Click LB on Finish to complete the panel.
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STANDARD RIGHT TEMPLATE WITH SUFFIX r SHOWN

(STANDARD LEFT TEMPLATE IS SIMILAR BUT WITH SUFFIX l)

From the main menu, click LB on Design=>Templates=>Create/edit

Slope 0% -40% -3%-40%

Width 0.7m 2.5m0.3m

A

B

C

D

Theoretical point of application of template

Hinge point

topmedianl

invmedianl

lokl

iokl

tokl

bokl bofpl

The dark line shows template ’FULL LEFT W MEDIAN’. Template ’FULL LEFT’ is identical but 
without the median i.e. the 3.5 m pavement width extends from B to D at 3% cross fall.

Distance AB is 0.090m. The adopted hinge point for the application of all templates will be at point 
B. This requires template ’FULL RIGHT W MEDIAN’ to be applied with a hinge modifier vertical 
offset distance of 0.090m

Click LB on the ‘More Information’ icon 

for the ‘Template name’ field and select template ‘FULL  
LEFT W MEDIAN’ with LB. Click LB on Fixed to edit 
the details of the fixed links in this template.
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Now fill in the panel as shown for lines 1 and 2.

The template will initially 
appear as follows

Position the cursor on line 1 
over the number 1 at the left 
hand end and click RB. 

In the popup, click LB on Insert. A blank line will be inserted at line 1 and all existing 
lines pushed down one line.

Repeat the process so that two blank lines have been inserted at lines 1 and 2.

Finally, on line 3, make sure 
that you reduce the width of 
the carriageway from 3.5m to 
2.5m wide. 
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This is so that the 1.0m wide median is inserted into the overall road geometry without widening the outer 
kerb lines etc. Lines 4 through 7 (renumbered, as shown above) are unchanged. Note that by changing the 
link distances in this way, the old strings remain the same distance from the template centreline as before.

Click LB on Apply and OK

Click LB on Apply and OK

Click LB on Finish to exit the ‘Template Create/Edit’ panel

Repeat the whole process for 
the right side template 
‘FULL RIGHT W 
MEDIAN’. 

Note that all values are the 
same as the left side. The 
only difference is in the 
naming of the links – suffix 
of ‘l’ on the left and a suffix 
of ‘r’ on the right.



Chapter 21 Median Strip

February 2007 Page  289

21.3 Use of Hinge point modifiers
In the template diagram, the ‘theoretical’ point of application of template ‘FULL LEFT’ is at Point B. 
Because of the way we have defined it, the ‘theoretical’ point of application of template ‘FULL LEFT W 
MEDIAN’ is at Point A. To ensure that these two templates are applied in a manner in which they match 
up in adjoining sections, a hinge modifier must be introduced for template ‘FULL LEFT W MEDIAN’. 
The hinge point (i.e. the point of application of the template) for ‘FULL LEFT W MEDIAN’ must be 
raised by 0.090m or else the template will be applied too low into the profile causing an unwanted step in 
our road.

We will start the median strip at chainage 700 and stop it at chainage 850. The hinge modifier command is 
used to change the location of the hinge point. In particular, as we only wish to move the hinge point 
vertically (it could be moved laterally as well) we must use the ‘height’ modifier within the Hinge 
Modifier command. 

Before we do this we will make a copy of the existing ROAD 1.mtf so that we can refer back to it at a later 
date. To make a copy of the template file, go to Design => MTF => Copy MTF.  

Open the new mtf file for editing by clicking on Design => MTF => Edit => ROAD 1 w MEDIAN.mtf.  
To make changes to the Hinge modifier, in the MTF edit panel click on Hinge.

The Hinge Modifier panel pops up with all fields blank.

Place the cursor in the central grey area opposite line 1 and click LB. 

The ‘Create’ modifier panel pops up.

 Click LB on Height

The Height panel pops up.

Select the ROAD 1.mtf file from the MTF to copy icon.

Type in ROAD 1 w MEDIAN for the Target MTF.

Click on Copy to make a copy of the ROAD 1. mtf file.
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Note that this modification is to the hinge point and hence applies to all templates applied on both sides of 
the road. 

21.4 Setting up the Application of the Median Template
In addition to changing our hinge point, we must now stipulate that on the left side of the road, we will use 
template ‘FULL LEFT W MEDIAN’ within the above chainage ranges and on the right side of the road the 
template ‘FULL RIGHT W MEDIAN’.

The latest changes to the left_side and right_side definitions are now as shown below

From the MTF Edit menu, click LB on Templates=>Left Side 

Fill in the panel as shown. 

Uncheck the Absolute check box as our heights are relative 
to our design centreline. 

Click LB on Apply and OK

The finished Hinge Modifier panel should look as shown above

Click LB on Apply and OK
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We now need to insert chainages on lines 2 and 3 corresponding to where we want the median to start and 
end, but first change the template in line 1 to ‘FULL LEFT’ - we do this as we modified full left and not 
FULL LEFT W TABLE DRAIN and hence the number of links are still the same.

In the chainage field for Line 2 type 700. 

In the ‘Template 1’ field opposite line 2, click RB and double click LB on FULL LEFT W MEDIAN. 
This tells 12d that on the left side of the road we wish to start using this template at chainage 700. 

At chainage 850, we need to return to the template FULL LEFT so in line 3 type in 850 for the Chainage 
and select FULL LEFT for Template 1.

The Left Side Templates panel 
pops up with the commands 
created previously on display.

First we need to use the 
template modifier ‘edit’ 
commands to ‘push’ line 2 down 
one line.

Place the cursor over the line 
number button ‘2’ (at the left 
end of line 2) and click RB. This 
pops up the line editor menu.

Click LB on Insert above.

This will insert a blank line before line 2. ‘Old’ Line 2 will now appear as ‘new’ line 3.

Repeat this to add another new line

Your Left Side Templates 
editor panel should now appear 
as shown left
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To ensure that your new changes are saved, from the MTF Edit menu, click LB on Save. 

You then need to make a very similar set of changes on the right side. From the MTF Edit menu, click LB 
on Templates=>Right side

To save your latest changes and exit from the MTF Edit menu, click LB on Save & Finish then select Yes 
to confirm. 

So that we can see any subsequent changes during the redesign of our road, make sure that the road design 
strings are turned on. Click LB on the ‘+’ sign button in ‘Plan 1’ and double click LB on ROAD 1 Strs and 
ROAD 1 Sects. Click LB on Fit to fill the view.

The finished panel should now 
appear as shown left

When finished click LB on 
Apply and OK

The finished panel should 
appear as shown left

When finished click LB on 
Apply and OK
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21.5 Re-Applying the Modified mtf File (third time)
That completes the Template Modifier commands to insert a median strip.

We will now apply this latest version of our changed ‘many template file’.

If the Apply Templates Function panel is not already on display, from the Main menu, click LB on 
Design=>Apply=>Apply Many and the Apply Templates Function panel will pop up. 

Click LB on the icon for the ‘Function name’ field to pop up a list of available functions. Click LB on 
ROAD 1. This was the name we gave our first Apply Many attempt. The various answers we gave last time 
should reappear.

Note that the MTF File field is set to use ROAD 1.mtf, however we wish to apply the MTF file containing 
the Median Strip and hence we need to select this mtf file.  Click on the folder icon, nd from the pop up list, 
select ROAD 1 W MEDIAN.mtf.

 Click LB on Apply to process the mtf file.

As before, all of the strings in the design strings, sections and polygons models will be deleted and replaced 
by recalculated strings. This happens each time you run the Apply Many function so you don’t have to delete 
any of the old strings manually.

Note the revised cut, fill and balance calculations at the base of the panel. These volumes have been 
calculated from the combined effects of our revised road geometry.

Click LB on Finish to terminate the panel.
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Zoom and Pans can then be used in the Plan view to have a closer look at the median

Median Strip
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22 Boxing

22.1 Overview
Boxing in the context of 12d is the excavation required to form up the subgrade of a road. Generating 
boxing means creating the strings and sections that represent the surface of the boxing excavation. A 
boxing surface TIN can then be created from these strings and boxing quantities calculated.

Boxing is defined in terms of boxing rules which are stored in a boxing file. Each boxing rule specifies the 
width and depth of boxing in terms of the geometry of the road template links. The beauty of this system is 
that if you (say) widen the lip of kerb link i.e. the road surface at a bus bay, by default the boxing widens 
accordingly to match the road surface. This happens automatically and only has to be changed by 
exception. In most cases, this is exactly the behavior road designers are looking for.

This clever design feature means that boxing is quite simple to implement. The easiest way to generate 
boxing is to complete the design of the surface of your road first and then implement boxing afterwards.

Applying boxing is very similar to applying a template. Boxing can be applied as part of the MTF ‘Apply 
Many’ process or it can be applied in a standalone manner. Most users prefer to use the former of these two 
ways. Boxing is then specified and stored as just another part of your MTF file.

In general, there are two steps to boxing – defining it and then applying it. Boxing is easy to apply. 
However, defining boxing is more complex than applying it.  This is generally not a problem as often 
within an organization, only one specialist person need be involved in setting up all of your boxing rules. 
Boxing rules often don’t change from client to client or project to project for a particular client. Thus once 
these rules are setup, they don’t need much attention. All you as a 12d user needs to know is the names of 
the various boxing rules and how to apply them. 

This chapter will focus on applying boxing that is already defined. 

The Boxing (.bf) File

A boxing file is a simple ASCII file and always has the suffix ‘.bf’. A boxing file will contain one or more 
‘Boxing Rules’. Thus all the rules for a particular client or project can be stored in one file for 
convenience. Boxing files can be copied from project to project etc just like mapping files. They can also 
be stored in the user library on a server so that all users can access the one master boxing file.

The easiest way to learn about boxing is simply to use it. We will now use several existing ‘Boxing Rules’ 
to generate longitudinal boxing strings and boxing sections.

22.2 Applying Boxing from the ‘Apply Many’ Command
In the Chapter 20 Template Modifiers,  we designed the road ‘ROAD 1’ using the mtf file ‘ROAD 1.mtf’. 
We will make a copy of this mtf file and then add the boxing and rerun the ‘Apply many’ using this new 
mtf file.  Observe that the ROAD 1.mtf was before the median was added but it still contains all of our 
road widening and bus bay. We will use this file as a starting point for implementing boxing.

Next we need the ‘Recalc’ menu on display.  This should be torn off by clicking LB on 
Utilities=>Recalc=>[Recalc] and positioned somewhere on the left hand side of your screen.

From the Recalc menu, click LB on Editor=>ROAD 1. 

The Apply Templates Function panel will pop up with the values that were set last time we ran this 
function. 
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To make a copy of the MTF file, click on Design=>MTF=>Copy MTF.  Select the ROAD 1.mtf file as 
the MTF to copy and type ROAD 1 w BOXING in the Target MTF field.  Click on Copy.

Change the MTF file from ROAD 1 w MEDIAN.mtf to ROAD 1.mtf to ensure that we no longer have the 
median strip in our design.

To see the results of this file, click LB on the Apply button at the base of the panel. Your ‘Plan 1’ view 
should now show the revised strings and sections along ROAD 1.

We now want to make a copy of ‘ROAD 1.mtf’ and store it’s contents in a new file ‘ROAD 1 w 
BOXING.mtf’ (Road 1 with boxing). We will then implement our boxing changes into this new file and 
rerun the revised design.

To generate boxing strings and sections, we make use of the previously created models ROAD 1 Box strs 
and ROAD 1 Box sects as shown in the Models tab of the Apply Templates Function.
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Generally, we apply boxing on the left side only. Boxing is always applied from left to right and typically 
spans the entire width of the road. It is permissible to refer to links on the right hand side from boxing 
applied on the left so there is very little reason to ever specify boxing on the right side.

From the MTF Edit menu, click LB on Boxing=>Left side

The boxing rules we are going to apply is full boxing down the entire length of the road.

We now want to make interactive changes to file ‘ROAD 1 w 
BOXING.mtf’ to implement boxing along the entire road.

In the Apply Templates Function ‘ROAD 1’ panel, opposite the 
Templates file field, click LB on the folder icon and click LB on 
‘ROAD 1 w BOXING.mtf’ to highlight that file. Click LB on the 
Select button to place the name back in the Templates file field (or just 
double click LB on ‘ROAD 1 w BOXING.mtf’ to highlight and select).

It is essential that you edit file ‘ROAD 1 w BOXING.mtf’, not ‘ROAD 
1.mtf’. Make sure that the name ROAD 1 w BOXING.mtf  is visible 
in the ‘Templates file’ field before proceeding further.

In the Templates file field of 
the Apply Templates Function 
panel, click LB on the folder 
icon to bring up the Directory 
*.mtf list and then click LB on 
[Open]. 

The MTF Edit menu for 
ROAD 1 w BOXING.mtf will 
appear.

From the MTF Edit menu, click LB on Boxing=>File

From the User Library of the popup panel, select the name 
BOXING.bf. This is the file that contains our various boxing 
rules.

Click LB on Apply and OK.
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.

Click LB on Apply and OK to close down the panel.

From the MTF Edit menu, click LB on Save & Finish and Yes to shut down the MTF Edit session.

Fill in the panel as shown.

This is interpreted as starting at Chainage 
21.8792, use ‘full boxing’ until the end of the 
road (Ch 926.5046).  Note that the chainages 
given are the chainages of the first and last 
full cross section, spanning the full width of 
the road.  

From the Apply Templates Function panel for function ‘ROAD 1’, click LB on the Apply button at the base 
of the panel.

The ROAD 1 Strs and ROAD 1 Sects should be recalculated but this time with boxing.

We will assume that you have your ROAD 1 Strs and ROAD 1 Sects turned on in View ‘Plan 1’.

You should now be able to add in models ROAD 1 Box Strs and ROAD 1 Box sects in view ‘Plan 1’ and 
you should see your boxing strings and sections overlaying your surface longitudinal strings and cross 
sections. The box strings are coloured red and the box sections are coloured orange.
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22.3 Reviewing your Boxing by Cross Section 
It is assumed that you have a ‘Section XS’ view which is used to profile cross sections. We should be able 
to profile any cross section and see the corresponding boxing section.

Firstly, click LB on the ‘+’ sign button and add model ROAD 1 Box sects to View ‘Section XS’.  Set the 
vertical exaggeration back to 2x.

If you click LB on the Profile button and then point to a red cross section string in the bus bay area, you 
should see the cross section profiled with the orange boxing section beneath the surface. The boxing string 
is visible because it falls within the corridor of the cross section string being profiled.

Note how the right hand carriageway has been widened and graded to the bus bay string and the boxing 
string has in general followed this same geometry. This happens by default to make your life easy as a road 
designer!

The following view shows a profiled cross section at Chainage 590 on the left hand curve where 
superelevation is implemented. Again observe how the boxing runs parallel to the surface strings.

To see these strings in isolation, 
create a new view with 
View=>New=>Plan and turn on 
models ROAD 1 Box Strs and 
ROAD 1 Box sects.

Keep this view ‘Plan 3’ for future 
use
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22.4 More Complex Boxing Issues
In the above example, the boxing rules in file ‘BOXING.bf’ have been set up to link in closely with the 
templates we are using. These are defined in the templates file ‘ROAD TEMPLATES.tpl’. The interaction 
can be summarised:-

Left Template Right Template Boxing rule

FULL LEFT FULL RIGHT full boxing
FULL LEFT w MEDIAN FULL RIGHT w MEDIAN boxing_u_median

If we created a template for intersections then we would need to also use the appropriate boxing found in 
the BOXING.bf file:-

FULL LEFT w KERB none boxing u intersection left
none FULL RIGHT w KERB boxing u intersection right
LEFT KERB ONLY RIGHT KERB ONLY boxing_u_kerb_returns

Note: This interaction is essential. If at any time you change the link names in your template, you will 
need to change your boxing definitions to match.

The second line of the above table specifies the templates which include the median strip down the centre 
of the road. If you were to recalc the function ‘ROAD 1’ but this time use MTF file ‘ROAD 1 w 
MEDIAN.mtf’ (after editing it to include the boxing as shown above), you will observe that the boxing has 
been setup to go under the median. 

This is shown in the following view.
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This is the reason that a further boxing rule had to be created to cater for boxing under the median strip. If 
you had used ‘full boxing’, the boxing section would have ‘stepped up’ under the median as shown below, 
which is probably not what you want to happen.
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23 Creating A Surface of the Road Formation
Assuming that the design is now finished, we could create a ‘Road Formation’ TIN by combining the 
design strings from these various road elements into one TIN. 

As a reminder, TIN  is just an abbreviation for a surface. It stands for ‘Triangular Irregular Network’. The 
steps to create the Road Formation TIN are

1. Assemble the appropriate design string models in a View

2. Create a TIN from all of the strings that are on display in the View

3. Null out superfluous triangles

4. Create a TIN Boundary 

For each road element we must turn on the design strings that have been created during the design process. 
These are typically the longitudinal strings and cross sections.   This is certainly a legitimate method for 
creating the triangualtion of the road surface, but 12d can do it all automatically for you in the Apply 
Many function.

From the Recalc panel click on Editor => ROAD 1 to bring up the Apply Templates Function panel.  In 
this panel so far we have concentrated on the first two tabs, Main and Models.  We willl now look at two 
more tabs, the Tin and the Filter tab.

Click on the Tin tab.

When you click on the Create road tin check box, 12d unlocks the fields below.  Fill in the panel as 
shown below.  Notice that when you type in the Road tin name, if you press the enter key, 12d will 
automatically fill in the Model for tin field.
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If we now pressed the Apply button, then 12d would create the triangulation, however there are a few 
things that you need to be aware of.

The spacing of cross sections may have introduced minor errors as a result of adjoining cross sections 
being joined by simple 3d strings (straight lines).

Each alignment string in 12d has a concept of a chainage interval. The chainage interval defaults to 10m. 
12d also considers a property that is present for curved alignment strings called the ‘chord/arc tolerance’. 
This defaults to 0.1m. If your cross sections are far enough apart and your chord/arc tolerance and/or 
chainage interval are large enough, 12d will generate extra points automatically along an alignment string 
as the TIN is created. These extra points are generated to minimise errors associated with not having 
enough points around a curved alignment string. The extra points will not be created unless needed.

To help with the accuracy of the triangulation we will rerun the ‘ROAD 1’ apply many function at a 
chainage spacing of 2 metres.   Go to the Main tab, set the Section separation to 2. This will solve the 
triangulation problem however, it would create sections every 2 metres and hence when it comes time to 
create the cross section plots, we would need to run the function again with another section separation.

To solve this issue, 12d Model also gives you the ability to create a second set of cross sections at a 
separate interval, and it is these sections that we use in the plotting.

Click on the Filter tab. 

Click on the Filter 
cross-sections check 
box to unlock the other 
fields.

Select the ROAD 1 
Sects model from the 
list and add the word 
‘Filtered’ to the end.  
This will create a new 
model to place the 
filtered sections into, 
while leaving the 
original sections at a 2m 
spacing.

Leave the other fields 
with their default 
values. 

You can now click on Apply to create the triangulation and filter the sections.
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The first thing you should notice is that, regardless of the colour selected in the Apply Templates Function 
panel, 12d Model actually colours the triangulation based on the colour of each link given in the template.  
What this allows us to do is to create a visualisation of our design right from the time we apply the 
templates to our road.

While visualisation is well beyond the scope of this 
course, if you have the Visualisation module, to quickly 
show you what 12d has done, go to View => 
Visualisation => Tin render settings.  The Tin Render 
Settings panel displays.

Fill in the panel as shown.

The Texture mapping file, Visualisation, is a simple 
ascii file which associates the colour of the triangles to a 
particular texture.  

In view ‘Plan 1’, turn off all the models and turn on the triangulation, tin ROAD 1.  You may need to 
toggle of the contours.



12d Model Getting Started and Training Manual

Page  306 February 2007

Open up view Perspective OpenGL 2 and turn on tin ROAD 1.  Toggle on the shade function to see the 
effect.

.

In view Plan 1, turn off all the models and turn on ROAD 1 Sects Filtered and ROAD 1 Strs.  Note that 
the cross sections are shown at every 20m and at the tangent points.  We would then use the model ROAD 
1 Sects Filtered when plotting the cross sections

..
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24 Road Design Volume and Area Calculations

24.1 Volume Calculations During Apply Functions 
During any Apply function, 12d reports on the cut and fill volumes calculated. By default, just the 
summary cut, fill and balance volumes are reported at the bottom of the panel.

You can optionally get a detailed report of the volumes calculated as the Apply executes.

We will rerun the ‘ROAD 1’ function as we last left it but this time we will look at the volume report. 

Note that the report includes every cross section so it includes every discontinuity you specified in your 
MTF file. 

From the main menu, click LB on Utilities=>Recalc=>Editor=>ROAD 1

In the ‘Report file’ field, the file name was provided by the default settings created prior to running the 
function for the first time The suffix .rpt is added.

Click LB on the Apply button.

To see the report click LB on the ‘Folder’ icon to the right of the ‘Report file’ field, then click LB on 
[Open]. The 12d editor will pop up.
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24.2 Volume Calculations Between Surfaces in Road Design 
Now that we have two TINS, ‘GROUND’ and ‘ROAD 1’, it is possible to get 12d to calculate the volume 
between the TIN surfaces. 12d provides two methods of calculating such volumes:

End Area. Volumes are calculated by considering the area of each cross section which is at right angles to 
the design centreline and multiplying it by the user defined distance separating each cross section. When 
calculating end area volumes the quality of the answer is highly dependant on the distance between each  
sections, particularly if the centreline is curved.

Exact. In this method exact volumes are calculated by summing the volumes of the various ‘prisms’ 
between the  triangulated surfaces. This method is ‘exact’ in that it is as accurate as the TINs themselves. 
Depending upon the overlap between ‘triangles’ in each TIN, each triangle may be split up into multiple 
prisms. All prisms are accounted for hence the term ‘exact’.

We will use both methods and compare any differences.

Whilst it is not essential, it is usual to have a boundary polygon when calculating quantities. The volume 
calculation is then limited to those triangles or cross sections that fall within the polygon.  

24.3 Cut and Fill Calculations
In your ‘Plan 1’ view, click RB in the View Title Area (blue) and click LB on Models=>Remove all 
models. 

Then use the ‘+’ sign button to turn 
on models  ROAD 1 Strs and 
ROAD 1 Sects.

If you look at the interface string in 
model ROAD 1 Strs, you will notice 
that some parts of it are red and some 
green. The red sections indicate 
where the road batter meets the 
natural surface in a ‘cut’ situation. 
The green indicates a ‘fill’ situation. 
This convention allows us to 
differentiate between cut and fill 
when we view data in plan.
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24.4 Process Volumes - Using the Interface polygon
By definition, the end area method only gives reasonable answers when considering a single piece of road. 
To ensure any volume comparisons we do are meaningful, we will limit the calculation to be within the 
extents of the ‘ROAD 1’ interface polygon.
In view ‘Plan 1’ turn off all models then turn on model ROAD 1 Polys

The ‘interface polygon’ is shown 
highlighted. We will use this polygon 
to limit the extents of the calculation 
for both methods.
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24.5 End Area Volume Calculations
All volume calculations are generated from the Volumes menu which can be torn off by clicking LB on 
Design=>Volumes=>[Volumes].

We will use view ‘Plan 1’ which should be displaying our ROAD 1 Polys model as shown above. We will 
also use view ‘Plan 3’ which should be showing our centreline model ROAD CL so remove the boxing 
models.

.
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To calculate volumes between TINs using end areas, from the Volumes menu, click LB on End 
Area=>String tin to tin

Fill the panel in as shown.

Click on the String for Tin to Tin 
button and click on the magenta 
‘ROAD 1 centreline’ in view ‘Plan 
3’.

Place the cursor on the TIN icon for 
the ‘Original tin’ field and click LB 
to popup a list of the available TINs. 
Double click LB on GROUND. 
Repeat the process for ‘New tin’ and 
set it to ROAD 1.

Set the ‘Distance between sections’ 
to 5m initially. It will be refined 
later if needed 

By entering a name in the ‘Report 
file’ field, a report can be created 
showing the details of the end area 
calculations. 

Enter END AREA VOL and press 
return. The suffix .rpt is appended 
by 12d. 

Set the report mode to full if you 
want to see the calculations 
associated with each cross section. 

It is compulsory to define a closed 
polygon to restrict the extents within 
which the calculations will be 
performed. We can use the 
‘interface polygon’ for this purpose 
i.e. the intersection of the ‘ROAD 1’ 
function with the ‘GROUND ’ tin. 

Click LB on the Poly icon then click LB on the ‘String’ pick icon. Click LB on the polygon in the 
‘Plan 1’ view with LB. Confirm the selection with MB

Click LB on Volume to cause the end area volumes to be calculated. 

If a name is entered in the ‘Report file’ field, 12d will immediately jump to the Editor and display the 
report. A sample report is shown on the following page. 
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Click LB on File=>Exit to terminate the Editor and return to 12d.

Note that once the calculation is finished, the Cut, Fill and Balance volumes are displayed in the panel’s 
message line.  Click LB on Finish to terminate the panel. 

24.6 Comparison of End Area Volumes with a Template Apply Function
You should not expect to get exactly the same cut and fill volumes from the End Area Volumes report as 
the Apply Template Function report. 

The reason for this is that the End Area Volumes report generates parallel cross sections at whatever 
interval you ask for – in our case 5m intervals.

The Apply Templates Function volume calculations also uses cross sections but we have not taken account 
the fact that the cross sections are not parallel when going around curves. On the Apply Functions, there is 
a field for Volume correction for curves which will apply Pappus’ Theorem for correction areas involving 
non-parallel sections. This will give more accurate results for the Apply Functions.

However, running the End Area Volumes with parallel sections and a very small distance between sections 
will give the most accurate results for any end area methods.
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24.7 Exact Volume Calculations
Firstly make sure that model ROAD 1 Polys is turned on in your ‘Plan 1’ view. Click LB on Fit to fill the 
view.

To calculate exact volumes between TINs, from the Volumes menu, click LB on 

Exact=>Tin to tin

Fill the panel in as shown. Place the cursor on the ‘+’ sign button for the ‘Original tin’ field and click LB to 
popup a list of the available TINs. Double click LB on GROUND. Repeat the process for ‘New tin’ and 
set it to ROAD 1.

By entering a name in the ‘Report file’ field, a summary report can be created showing the details of the 
end area calculations. Enter EXACT VOL and press the Enter key. The suffix .rpt is appended. 

Click LB on Volume to initiate the calculation. A summary report will be calculated and immediately 
displayed.

24.8 Displaying ‘depths’ of Cut and Fill using Colour Shading
We will now rerun the ‘Exact Volume Between Tins’ panel again but this time with different parameters.

This time we will use a Range file. Select file 
ROAD DEPTH.drf from the User Library in 
the popup list.

We will display the results in view ‘Plan 1’.

To keep a permanent copy of the face 
colourings we need to supply a ‘Model for 
faces’. Type in faces.

Make sure that you remove the entry in the 
Report file.

Select the ‘Use a polygon’ radio button
Click LB on the Polygon icon then click LB 
on the ‘String’ pick icon. Click LB on the 
polygon in the ‘Plan 1’ view with LB. 
Confirm the selection with MB.
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Click LB on Volume to rerun the calculation. This time 12d will read the values in the Range file and 
colour in view ‘Plan 1’ in shades of red and green corresponding to the depths of cut and fill respectively.

This image can be exported or plotted as desired. When the data is transferred to AutoCAD, Microstation 
or other rendering packages, the face data will be retained and hence can be manipulated further if 
required.

Zoom in as above to get a closer look at the shading.

If you refresh the view 
you will notice that the 
shaded image disappears 
and the view reverts to 
whatever models you had 
turned on prior to 
performing the volume 
calculation. 

Use the ‘+’ sign button to 
add model faces to view 
‘Plan 1’. You now have a 
permanent copy of the 
shaded faces. This model 
can be manipulated just 
like any other model in 
12d.

The darker shades show the 
areas of greatest depth of 
cut and fill.

The quality of the finished 
image is a function of the 
number of ranges specified 
in the range file. Each 
range has a colour 
associated with it. This file 
is a normal ASCII file and 
can be edited. If you place 
the cursor near the name 
ROAD DEPTHS.drf, in 
the panel, click LB on the 
‘More Information’ icon to 
pop up the list of names 
again and then select 
[Open], the 12d editor will 
pop up with the Range file 
displayed ready for editing.



Chapter 24 Road Design Volume and Area Calcs

February 2007 Page  317

If we were to rerun the panel and ask for the report again but this time, generate it in conjunction with the 
use of the Range file, 12d will split up the cut and fill volumes by vertical depth i.e. it will calculate cut and 
fill volumes for a range of depths. The depths used are determined by those specified in the Range file.

Thus by prudent use of depths in your range file, you have the ability to split up your volumes into parallel 
depth layers. If you have varying substrata in a job, this can be a useful way of extracting quantities by 
material type. 

The format is ‘starting 
depth’,‘finishing depth’ and 
‘colour’. Cut depths are negative. 
This file is user definable. 

Any colour can be used. For a full 
list of the colours available, see the 
colours.4d file. 

To exit the panel select Finish
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24.9 Sign Conventions for Cut and Fill
The entire tutorial on volume calculations so far has been performed assuming the default convention that 
Cut volumes are negative. This is a user definable convention however. If preferred, Cut volumes can be 
made positive.

This convention is set from the Main menu. Click LB 
on Project => Management => Defaults.

Click LB on the Default Settings tab.

The values shown are the system default settings.

Note the field near the bottom of the panel. 

Place the cursor on the ‘+’ sign button for the ‘Cut 
volume sign’ field and click LB to pop up a list of 
alternatives. Click LB on either positive or negative. 
At this time, leave the value negative.

Click LB on Set to activate any changes.

Click LB on Finish to terminate the panel.
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24.10 Surface Areas of Pavement and Formation
12d has various facilities to assist with area calculations. The only prerequisite is that a closed string 
(polygon) is required around any area that 12d is to calculate. If a string is ‘open’, the starting and end 
points will be considered as joined for the purposes of the calculation. 

We will use the strings created from our template calculation to get the plan and slope areas of our road 
surface. This should give us an indication of the bitumen required to seal our road.

Plan areas are calculated by projecting the area of the string chosen onto the XY plane. 

Surface areas are calculated by summing the areas of the various sloping triangular surfaces of a TIN. A 
polygon is required to restrict the summation to only those triangles in the TIN that fall within the polygon.

Plan Areas:

In the ‘Plan 1’ view, make sure that your ROAD 1 Polys model is on display.

From the Main menu, click LB on Utilities=>Measure=>Plan area

The ‘Measure Plan Area’ 
panel appears. Make sure 
that you have line snaps 
ON. 

Click LB anywhere on the 
cyan ‘lokr polygon’. Click 
MB to accept the 
highlighted string.  Then 
click on the ‘lokl polygon’

The Plan area of each 
polygon appears in the 
panel with the sum also 
shown.
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Surface Areas:

From the main menu, click LB on Utilities=>Measure=>Surface area

If you were to repeat this but pick the ‘Edge polygons’, you would get the surface areas of your battered 
slopes. These can be used to take off plantation quantities on road reserves.

Click LB on Finish to terminate the panel.

The ‘Surface Area 
Within a Polygon’ 
panel appears. 

Make sure that you 
have line snaps ON. 

Click LB on the TIN 
icon then select ROAD 
1

Click LB on ‘Poly’ 
icon then selcet the 
‘String’ pick icon.

Click LB anywhere on 
the magenta ‘lokr 
polygon’. Click MB to 
accept the highlighted 
string.

Click LB on Area. 

The slope and plan area 
appears in the panel.

A report can be created 
if required
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24.11 Volumes of Boxing Quantities
In the Apply Template Function panel, ensure that you are using the ROAD 1 w BOXING.mtf file, then 
click on the Misc tab.

The last five checkboxs on the Misc tab determine which volumes are reported in the volumes report.

If you require the volumes to give more information concerning the stripping then check on Show 
detailed stripping volumes.   

It would be normal that you require the volumes between the natural surface and the design, however if 
you do not require this, you would uncheck Calculate natural surface to design volumes.  In a 
situation such as this you may want the volumes between the natural surface and the bottom layer of 
the boxing, or the subgrade.  Therefore, you should check on the Calculate natural surface to 
subgrade volume.  

Other volumes that you can report on would be from the finished design surface to the subgrade 
(Calculate road to subgrade volume) and the volume of each layer of boxing (Calculate inter-
boxing layer volumes).  You can click on any or all of the volume options.

Click on Apply to run the function and calculate the various volumes.  You can check the report, by 
clicking on the folder icon in the Report file on the Main tab, and clicking on [Open].
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24.12 Stripping Depths and Volumes 
Setting a stripping depth and getting 12d to calculate the quantities of stripping material is a byproduct of 
the Apply or Apply Many functions. If a non-zero stripping depth is specified at any chainage, the cut and 
fill calculations at that chainage are performed with respect to the section through the TIN reduced in 
height by the stripping depth.

Note however that the design strings from the Apply or Apply Many function are always generated by 
battering into the unstripped surface. 

The stripping volume is the volume between the stripped and unstripped surface.

Even if you specify stripping in the MTF file, stripping as a concept can be toggled on or off from the ‘Use 
Stripping’ check box in the Apply Templates function. 

We will now investigate this further by modifying our design of ‘ROAD 1’ to include a stripping depth of 
0.2m for the entire length of the road.

We will use the ‘ROAD 1’ function with the MTF file ROAD 1.mtf.  We will use this file as a starting 
point for implementing stripping.

From the main menu, click LB on Utilities=>Recalc=>Editor=>ROAD 1

The Apply Templates Function panel will pop up with the values that were set last 
time we ran this function. 

Make sure you use the mtf file ROAD 1.mtf

To edit the mtf file click LB on the‘Templates file’  ‘More information’ icon and 
click LB on [Open]. The MTF Editor will appear.
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From the MTF Edit menu, click LB on Stripping

Select OK to exit the stripping panel, then select Save and Finish to exit the MTF editor.  On the Apply 
Template Function panel click on Apply to rerun the design with stripping.

Select File=>Exit to exit the report

Fill out the panel as shown.

Type in the start chainage or use the 
dynamic measure to select the chainage from 
view ‘Plan 1’.  Give a stripping depth of 0.2

For the end chainage use the dynamic 
measure option and type in the stripping 
depth of 0

It is essential to set the stripping depth back 
to zero at Chainage 926.5183.
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25 Merging the New Road with the Existing Terrain (Fencing)

25.1 Overview
To create a TIN of our ‘final surface’, we need to merge the finished ‘road design’ strings with parts of the 
‘natural surface’ strings – the parts that are outside our Road Formation boundary. 

The steps to create the Final TIN of the merged data set can be summarized as follows.

1. Use the Road Formation boundary polygon to make a copy of all of the ‘natural surface’ data that is 
outside the polygon. This operation is called fencing.

2. Create a new Plan View and turn on all of the remaining natural surface strings you created in the step 
above (the ones outside the polygon).

3. Add the appropriate design strings to the View

4. Create a TIN from all of the strings that are on display in the View

5. Null out superfluous triangles

25.2 Use of Polygons Resulting from the Application of Templates
We previously described how the polygons that get created automatically during an Apply function on a 
simple road can be useful for calculating areas, colouring in regions of a TIN, fencing etc.

25.3 Fencing
The process of constructing data sets or subsets in 12d utilises a technique called ‘Fencing’. After Fencing 
is complete, data subsets are then typically merged to create new surfaces.

Fencing is a pwerful option which will be explained in the following example. In the context of our 
training data, we will use Fencing to clip out and remove various parts of the strings that were used to 
create the GROUND tin. The parts that are to be removed are all of those that cross or fall within the Road 
Formation boundary polygon. Strings in this context includes all points and lines.

If we replace these parts of the Natural Surface strings with the strings that represent our Road Formation, 
we can then merge these two data subsets into a new ‘Final’ surface. The various steps to do this are now 
explained in detail:-

25.3.1 Create the ‘Road Formation’ TIN and the Boundary Polygon
Create the ‘Road Formation’ TIN and the Boundary polygon around the Road Formation TIN as shown in 
Chapters 23. This polygon will be referred to as the Road Formation boundary polygon

25.3.2 Assemble all of the strings that constitute your ‘GROUND’ TIN in a View
The easiest way to implement Fencing is to have two plan views up – one containing the data you wish to 
fence and the other containing just the fence itself. We will use views ‘Plan 1’ and ‘Plan 3’ for this 
purpose.

Firstly, turn off all models in view ‘Plan 1’. Click RB in the View Title Area (blue) and click LB on 
Models=>Remove all models
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Now we need to turn on all models that were used to build the ‘natural surface’ TIN. The models used in 
this tin were written out to a file in Chapter 6.2

From the main menu, click LB on 
View=>Models save/restore

Click LB on the Restore tab.

Select the file natural surface.vml

In the ‘View to Add’ field, click LB on 1

Click LB on Read and Restore and Finish

There should be 11 models 
turned on in view ‘Plan 1’.

Your view should look as 
shown.
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In view ‘Plan 3’, turn OFF all models and turn ON  ROAD 1 Polys 

The ROAD 1 Polys model 
contains all the individual 
polygons created during the 
triangulation of the road.  In 
fact if you zoom in on the 
data it looks very similar to 
the ROAD 1 Strs model. 

All we require is the 
interface polygon. This 
polygon defines the 
outermost parts of our road 
design. It also lies exactly on 
the natural surface.

To make it easier to select 
this polygon when fencing 
the data, we will copy the 
interface polygon to a new 
model.

Select the String icon from the Data to 
convert box and select the interface 
polygon 

We can leave the properties of the string 
as they are so there is no need to fill any 
of this data in.

In the Target box select the Model icon in 
the Copy to model field and select the 
ROAD 1 Polys model.  Add the word 
Interface to the model name as shown.

Click on Change then Finish.

Click on Utilities => A - G => Change. 

Turn OFF the model ROAD 1 Polys in view ‘Plan 3’ and turn ON ROAD 1 Interface Polys
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25.3.3 Use the Road Formation Boundary to Create a ‘hole’ in your ‘natural sur-
face’ Data
We will now use the Road Interface polygon to clip out all the ‘GROUND’ data that is inside the polygon 
to create a ‘hole’.

12d has several ways to do this. 

By default, the parts of the strings in model survey TOPO SURFACE LEVEL that are inside the 
polygon will be duplicated and placed in a model called survey TOPO SURFACE LEVEL in. 

More importantly for our purposes, the parts of the strings in model survey TOPO SURFACE LEVEL 
that are outside the polygon will be duplicated and placed in a model called survey TOPO SURFACE 
LEVEL out. 

It is important to note that model survey TOPO SURFACE LEVEL will remain intact. 12d never 
modifies your data. Thus if you make a mistake and the fencing fails, you can always delete any new 
models created and go back to your original untouched data for a further attempt.

We will now see how this works in practice. In view ‘Plan 3’ turn OFF model survey TOPO SURFACE 
LEVEL. The only data on display in view ‘Plan 3’ should be our interface polygon.

From the main menu, click LB on Utilities=>Fence=>Fence stem

The easiest way is through the 
use of the ‘fence stem’ facility 
that uses wild cards to manipulate 
models by name. 

To assist with an explanation of 
how this will happen, turn on 
model survey TOPO 
SURFACE LEVEL  in the 'Plan 
3’ view.

Various strings in modelTOPO 
SURFACE LEVEL (and all the 
other models in our ‘GROUND’ 
TIN) cross our interface polygon. 
We can use a tool in 12d to split 
each string where it crosses the 
boundary

This part goes into survey 
TOPO SURFACE LEVEL in

This part goes into survey 
TOPO SURFACE LEVEL out
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Click LB on Fence and Finish to execute the fencing operation.

We now need to turn OFF all models that are on display in view ‘Plan 1’ and then turn ON all models that 
end in ‘out’ i.e. *.out

In view ‘Plan 1’, click RB in the View Title Area (blue) and click LB on Models=>Remove all models.

In view ‘Plan 1’, click RB in the View Title Area (blue) and click LB on Models=>Add model. [Note, 
don’t  walk right on add model]

Click on the View icon.

Select view 1 as the view to fence.

At the right of the ‘Polygon for fence’ 
field, click on the ‘More Information’ 
icon.  Click on the String pick icon, then 
click on the Road Formation boundary 
polygon in view ‘Plan 3’

In the ‘Prefix for fence inside’ field, 
remove the *.in entry. We don’t need any 
of the strings inside the Road Formation 
boundary polygon for the final surface.

Leave the *.out entry as is.

Select view 1

Type *.out as shown. This will select every model in 
your database that ends with ‘out’.

Click LB on Add.

A list of all models that end in *.out  
appears. Click LB on Yes to confirm 
the list.
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25.3.4 Turn on the ‘design strings’ that represent the Road Formation to fill the 
‘hole’. 
Turn on models ROAD 1 Sects  and Strs which should fit neatly within the ‘hole’. Visually check that this 
is so before proceeding.

View ‘Plan 1’ should now not have any ‘holes’.

Your view ‘Plan 1’ should 
now look as shown.

Note the ‘hole’ in the data 
where the road design strings 
will fit.

The data currently on display 
represents that part of the 
natural surface that stays 
intact after the road is built.

Zoom in around the creek 
area and observe that all 
strings have been clipped 
exactly where they cross the 
interface boundary polygon 
with no gaps present.
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That completes the 
preliminary steps associated 
with fencing operation. We 
now need to create a TIN of 
this merged data.
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25.4 Merge These Two Data Sets by Creating a TIN of the Finished Surface
We now have on display in view ‘Plan 1’ all of the strings that are needed to form up our final design 
surface. The TIN we create from these strings will be called ‘final surface’.

From the main menu, click LB on Tins=>Create=>Triangulate data

Fill in the panel as shown.

Give the function the name tin FINAL SURFACE

After typing FINAL SURFACE in the New tin name field, press the Enter key. You should see the field 
‘Model for tin’ updated with the name tin FINAL SURFACE.

From the Data tab, select the View to triangulate as view 1

Click on the Nulling  tab, click on the Apply Nulling check box, then select the Null polygon button.  
Click LB on the outer red ‘survey TOPO DTM BDY out’ polygon we can see in view ‘Plan 1’. Click MB 
to confirm the selection.

Click LB on the Triangulate button. Click LB on Finish.
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If you turn on model tin 
FINAL SURFACE in view 
‘Plan 1’ you should see the 
finished TIN as shown.

To view finished contours

Click LB on Toggle=>Tin 
contours [on]. 

The ‘FINAL SURFACE’ 
TIN appears in ‘quick’ 
contour form.
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25.5 Write Out a Final Surface.vml File for later use
It is important that we don’t include the TIN itself in this model list. In view ‘Plan 1’, turn OFF model tin 
FINAL SURFACE.

From the main menu, click LB on View=>Model save/restore

25.6 Conclusion
This concludes the tutorials covered by the Getting Started for Design manual.

There is also a Getting Started for Surveying manual which covers material relevant to Surveying. The 
Getting Started for Surveying manual is also distributed as a PDF file on the 12d Model Installation CD.

Click LB on the Save tab.

In the ‘File name to Save’ field, type in 
final surface and press the Enter key. The 
suffix .vml is added (view model list).

Select view 1 (where these models are 
currently on display).

Click LB on Save and Finish.
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